cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1684
Views
0
Helpful
2
Replies

Cisco 831 DHCP Help

justineyres
Level 1
Level 1
Hi, I have a Cisco 831 and I am fairly new with configuring cisco routers. What I have is


Internet>>>Modem>>>Router>>>Switch>>Computers

What I want to do is have the Router hand out IP's through DHCP

Heres my config

Building configuration...

Current configuration : 1306 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
no ip dhcp use vrf connected
!
ip dhcp pool my_pool
   network 12.168.1.0 255.255.255.0
   default-router 192.168.1.1
   dns-server 24.226.1.93 24.226.10.193 24.226.1.94 24.226.10.194
!
!
ip cef
!
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
interface Ethernet1
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
!
interface Ethernet2
no ip address
shutdown
!
interface FastEthernet1
duplex auto
speed auto
!
interface FastEthernet2
duplex auto
speed auto
!
interface FastEthernet3
duplex auto
speed auto
!
interface FastEthernet4
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 Ethernet1
!
no ip http server
no ip http secure-server
!
ip nat inside source list 117 interface Ethernet1 overload
!
access-list 103 deny   ip 10.0.0.0 0.255.255.255 any log
access-list 103 deny   ip 172.16.0.0 0.15.255.255 any log
access-list 117 permit ip 192.168.1.0 0.0.0.255 any
!
!
!
control-plane
!
!
line con 0
no modem enable
speed 115200
line aux 0
line vty 0 4
!
scheduler max-task-time 5000
end
2 Replies 2

RonMorrill
Level 1
Level 1

kyukim
Cisco Employee
Cisco Employee

Hi,

From your config, you miss one statement and one typo.

one missing is "ip dhcp excluded-address 192.168.1.1"

one typo is "network 12.168.1.0 255.255.255.0". This should be "network 192.168.1.0 255.255.255.0"

you can confirm if you dhcp server is working by "sh ip dhcp pool" or "deb ip dhcp server pacekt or event"

Hope this helps.

KK

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card