Routing OSPF through a 3750 switch

Answered Question
Aug 10th, 2010
User Badges:

I am trying to simulate the internet by bringing in 3 different routers on point to points into a 3750G switch.  While I can ping through the network, I am not getting any convergance of OSPF.  We are using IOS version 12.2(53)se.  Thanks.

Correct Answer by Nagaraja Thanthry about 6 years 11 months ago

Hello,


From the configurations, between Router 1, 2, and 3, there is no common subnet. While router 2 and 3 have 206.36.206.x in common, I do not see any other common subnets between all three routers. If you are configuring so that even 3750 should participate in OSPF, you need to make sure that you are running IPServices image on the switch. Once you are running IP Services image, the configuration will be pretty much similar to the routers:


Router ospf 1

Network 205.0.0.0 0.0.0.3 area 0

Network 205.1.1.0 0.0.0.3 area 0

Network 205.2.2.0 0.0.0.3 area 0


Hope this helps.


Regards,


NT

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Jerry Ye Tue, 08/10/2010 - 14:18
User Badges:
  • Cisco Employee,

Please post the config and topology so we may assist further.


Regards,

jerry

charles.e.davis... Tue, 08/10/2010 - 14:30
User Badges:

The topology is 3 routers coming into the swith on P-P networks.  Each router is advertising for the network behind it as well as the P-P.


Switch Config


sho config
Using 1887 out of 524288 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
!
!
!
no aaa new-model
switch 1 provision ws-c3750g-24ts-1u
system mtu routing 1500
authentication mac-move permit
ip subnet-zero
ip routing
!
!
!
!
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
!
interface GigabitEthernet1/0/1
switchport access vlan 10
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
switchport access vlan 20
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
switchport access vlan 30
!
interface GigabitEthernet1/0/24
switchport access vlan 30
!
interface GigabitEthernet1/0/25
!
interface GigabitEthernet1/0/26
!
interface GigabitEthernet1/0/27
!
interface GigabitEthernet1/0/28
!
interface Vlan1
no ip address
shutdown
!
interface Vlan10
ip address 205.1.1.2 255.255.255.252
!
interface Vlan20
ip address 205.0.0.2 255.255.255.252
!
interface Vlan30
ip address 205.2.2.2 255.255.255.252
!
ip classless
ip http server
ip http secure-server
!
!
ip sla enable reaction-alerts
!
!
!
line con 0
line vty 5 15
!
end


Switch#


Router 1



Using 668 out of 29688 bytes
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
memory-size iomem 10
ip subnet-zero
!
!
!
!
!
interface Ethernet0/0
ip address 205.2.2.1 255.255.255.252
no ip directed-broadcast
!
interface Serial0/0
no ip address
no ip directed-broadcast
shutdown
!
interface Ethernet0/1
no ip address
no ip directed-broadcast
!
interface Serial0/1
no ip address
no ip directed-broadcast
shutdown
!
router ospf 1
network 205.2.2.0 0.0.0.3 area 0
!
ip classless
ip route 0.0.0.0 0.0.0.0 205.2.2.2
no ip http server
!
!
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end


Router#


Router 2



Using 1016 out of 245752 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Enterprise_Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
dot11 syslog
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
  hidekeys
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
ip address 206.36.206.2 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 205.0.0.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
network 205.0.0.0 0.0.0.3 area 0
network 206.36.206.0 0.0.0.255 area 0
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 205.0.0.2
ip route 206.1.1.0 255.255.255.0 206.1.1.254
!
!
ip http server
no ip http secure-server
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end


Enterprise_Router#


Router 3



Using 1234 out of 245752 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Base_Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$y5h3$INTpPIlaRy8WY1RtgLrAa0
!
aaa new-model
!
!
aaa authentication login default local
!
!
aaa session-id common
dot11 syslog
!
!
ip cef
!
!
!
multilink bundle-name authenticated
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username admin privilege 15 password 7 0257145A1815182E5E4A58
archive
log config
  hidekeys
!
!
!
!
!
class-map match-all CPPr-host-known-undersirable
!
!
!
!
!
interface GigabitEthernet0/0
ip address 206.36.206.3 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
ip address 205.1.1.1 255.255.255.252
duplex auto
speed auto
!
router ospf 1

Correct Answer
Nagaraja Thanthry Tue, 08/10/2010 - 15:07
User Badges:
  • Cisco Employee,

Hello,


From the configurations, between Router 1, 2, and 3, there is no common subnet. While router 2 and 3 have 206.36.206.x in common, I do not see any other common subnets between all three routers. If you are configuring so that even 3750 should participate in OSPF, you need to make sure that you are running IPServices image on the switch. Once you are running IP Services image, the configuration will be pretty much similar to the routers:


Router ospf 1

Network 205.0.0.0 0.0.0.3 area 0

Network 205.1.1.0 0.0.0.3 area 0

Network 205.2.2.0 0.0.0.3 area 0


Hope this helps.


Regards,


NT

Jerry Ye Tue, 08/10/2010 - 18:16
User Badges:
  • Cisco Employee,

Only one additional comment from NT's post. Once you configure OSPF on the 3750 switch and if the neighbor is not coming up, check the MTU of both side with the command ip ospf interface. From what I remember, VLAN SVI will have MTU 1504 and router interface is MTU 1500 and the neighbor will not form due to MTU mismatch. To correct this problem, you can add the following command on the router interface and the interface VLAN to bypass the MTU check


interface xxxx

ip ospf mtu-ignore


Regards,

jerry

madathilsiva Tue, 08/10/2010 - 20:23
User Badges:

Hi

Between R1 and R2 there is no proper subnet assigned . That could be reason for this . Is there any ospf running in switch?   

{R1                                                                              R2

interface Ethernet0/0                                                          interface GigabitEthernet0/1
ip address 205.2.2.1 255.255.255.252                         ip address 205.0.0.1 255.255.255.252
no ip directed-broadcast                                                  duplex auto
                                                                                               speed auto                        }

Actions

This Discussion