Some CME 7 questions

Answered Question
Aug 11th, 2010

Hi,

First of all, go easy on me...I'm not the most proficient when it comes to Cisco telephony, and CME in particular...and for Cisco routers/switches too.  I can get around in them and do common things, but once you dive deep into technical details about network-centric topics, I may get lost.  I have a deep technical telephony background in Avaya (voip and tradtional).   We have a call manager (Windows server) that has been installed for awhile that I'm more familiar with (it was a pilot test from awhile back).  We just got a new 2921 router with CME installed for free from Cisco as a tester because we've bought so much other network gear.  Anyway, I'm trying to configure this CME and I'm having trouble with a few things.  I've tried reading to understand what's going on, but so far I've not been able to figure this out on my own.

What I have working so far is a H.323 link to an Avaya system we use as our main system.   I can call ext's on that system and even use the outside lines to make external calls.   Works fine.   I can call from the Avaya to Cisco CME, no problem.

Here are my questions.

1.  I can't seem to get the web GUI to work.  I can get to the GUI for the main router config (Cisco CP Express)...but I can't get the GUI for the telephony stuff working.  When I go to the web page http://192.168.1.10/ccme.html  (IP address is bogus, but for demonstration purposes...) I get the login prompt.  I type my login/password and then it goes to a blank page.  Nothing there at all.  Just blank.  Any ideas?

2.  I can't seem to get the conference function to work.  When I press Conference, it says 'cannot complete conference'.   The situation is, I have a call live on the phone and then I try to press conference to initiate a conference.  Am I doing it wrong is or there some other issue?  The phone is setup like this:

ephone-dn  1  dual-line
number 61234
name TEST USER

3.  I'm confused about flash: vs. flash0:    I see all the CME 7.1 files are stored in flash0: in my system.  I screwed up and watched some 'how to install CME' video on youtube and I was trying to upgrade it to CME 8 or trying to get it working in the first place, before I realized all the files were already installed at the factory in flash0: and I copied all the new CME 8 files into flash:.   I don't know if this creates any problems other than I'm just wasting that flash memory space now in flash:....but you tell me.  Is this a problem?   I can't find an easy way to delete those files I extracted there in flash:.  I'd like to remove them if possible, without it taking 4 hours of command line typing.   Is there an easy way to do it?   Anyway, what IS the difference between flash: and flash0:?   Is it just two different flash memory sources?

4.  Somewhat related to number 3 above.  I see taht CME 8 is available.  But how do you go about upgrading to that from CME 7.1?   Is there a guide on how to do this without wiping out your existing config, etc?   How do you install CME 8 over top of 7.1 without leaving a bunch of extra 7.1 files in place that just waste space, etc?

5.  I cant' get the correct time to show on the phone (7942).  I have the time zone set and a NTP server assigned in the router.  The phone is exactly 4 hours fast.  The minutes are correct.  It seems like some kind of time zone issue.  Any ideas?

Here is the config you see when you type 'show telephony-service' from the command line.  Any IP's and passwords you see below have been alterered, to protect the innocent ;-) ....

Version 7.1
Cisco Unified Communications Manager Express
For on-line documentation please see:
http://www.cisco.com/en/US/products/sw/voicesw/ps4625/tsd_products_support_serie
s_home.html

ip source-address 192.168.1.10 port 2000
ip qos dscp:
ef (the MS 6 bits, 46, in ToS, 0xB8) for media
cs3 (the MS 6 bits, 24, in ToS, 0x60) for signal
af41 (the MS 6 bits, 34, in ToS, 0x88) for video
default (the MS 6 bits, 0, in ToS, 0x0) for serviceservice directed-pickup
max-ephones 25
max-dn 25
max-conferences 10 gain -6
dspfarm units 0
dspfarm transcode sessions 0
conference software
privacy
no privacy-on-hold
hunt-group report delay 1 hours
hunt-group logout DND
max-redirect 10
cnf-file location: system:
cnf-file option: PER-PHONE-TYPE
network-locale[0] US   (This is the default network locale for this box)
network-locale[1] US
network-locale[2] US
network-locale[3] US
network-locale[4] US
user-locale[0] US    (This is the default user locale for this box)
user-locale[1] US
user-locale[2] US
user-locale[3] US
user-locale[4] US
srst mode auto-provision is OFF
srst ephone template is 0
srst dn template is 0
srst dn line-mode single
moh music-on-hold.au
time-format 12
date-format mm-dd-yy
timezone 12 Eastern Standard/Daylight Time
secondary-dialtone 9
no transfer-pattern is configured, transfer is restricted to local SCCP phones o
nly.
keepalive 30 auxiliary 30
timeout interdigit 10
timeout busy 10
timeout ringing 180
timeout transfer-recall 0
timeout ringin-callerid 8
timeout night-service-bell 12
caller-id name-only: enable
web admin system name xxxxx  password xxxxx
web admin customer name Customer
edit DN through Web:  enabled.

edit TIME through web:  enabled.
Log (table parameters):
     max-size: 150
     retain-timer: 15
create cnf-files version-stamp 7960 Aug 11 2010 07:09:37
transfer-system full-consult
transfer-digit-collect new-call
local directory service: enabled.
Extension-assigner tag-type ephone-tag.

Here is some of what you see when you do a 'show run':

telephony-service
max-ephones 25
max-dn 25
ip source-address 192.168.1.10 port 2000
time-zone 12
max-conferences 10 gain -6
moh music-on-hold.au
web admin system name xxxxx password xxxxx
dn-webedit
time-webedit
transfer-system full-consult
secondary-dialtone 9
create cnf-files version-stamp 7960 Aug 11 2010 07:09:37

ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip http path flash0:

I have this problem too.
0 votes
Correct Answer by Paolo Bevilacqua about 6 years 3 months ago

I have found that starting from some past release, the only location the GUI files will work from, is root.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Paolo Bevilacqua Wed, 08/11/2010 - 05:24

1. need to use the very specific files for IOS in use. However, GUi is crap, so you are not loosing much.

2. something misconfigured. check manual again.

3. they are the same thing.

4. no easy way. you must figure out what stays and what goes by yourself.

5. update phone firmware.

jmeier10510 Wed, 08/11/2010 - 06:03

Well, when if you do a 'dir flash:' and a 'dir flash0:', you get two different results....so it looks to me like they are two different storage areas, because you don't see the same files in flash: that you see in flash0: and vice versa.

jmeier10510 Wed, 08/11/2010 - 06:24

When I do show flash:, I get this (FYI  - this is only part of what's there, I'm not pasting everything in since it's pretty long)....

cisco-cme-test#show flash:
-#- --length-- -----date/time------ path
1     62662920 Jul 31 2010 16:56:32 c2900-universalk9-mz.SPA.150-1.M3.bin
2         2903 Jul 31 2010 17:11:06 cpconfig-29xx.cfg
3      2915328 Jul 31 2010 17:11:20 cpexpress.tar
4         1038 Jul 31 2010 17:11:28 home.shtml
5       115712 Jul 31 2010 17:11:36 home.tar
6      1697952 Jul 31 2010 17:11:52 securedesktop-ios-3.1.1.45-k9.pkg
7       415956 Jul 31 2010 17:12:02 sslclient-win-1.1.4.176.pkg
8         5470 Aug 09 2010 16:15:04 n
9         5134 Aug 10 2010 12:26:00 7970-71-75-Background-readme-v1.txt

This is what I get when I do show flash0:, and again I didn't paste in everything...

cisco-cme-test#show flash0:
-#- --length-- -----date/time------ path
1     62662920 Jul 31 2010 16:56:32 c2900-universalk9-mz.SPA.150-1.M3.bin
2         2903 Jul 31 2010 17:11:06 cpconfig-29xx.cfg
3      2915328 Jul 31 2010 17:11:20 cpexpress.tar
4         1038 Jul 31 2010 17:11:28 home.shtml
5       115712 Jul 31 2010 17:11:36 home.tar
6      1697952 Jul 31 2010 17:11:52 securedesktop-ios-3.1.1.45-k9.pkg
7       415956 Jul 31 2010 17:12:02 sslclient-win-1.1.4.176.pkg
8         5470 Aug 09 2010 16:15:04 n
9         5134 Aug 10 2010 12:26:00 7970-71-75-Background-readme-v1.txt
10     2591877 Aug 10 2010 12:26:08 APPS-1.3.3.SBN

Here is the result from show flash1:

cisco-cme-test#show flash1:
%Error show flash1: (No such device)

jmeier10510 Wed, 08/11/2010 - 06:36

Hmmmm....I could have sworn these two were different early on when I first started configuring the system, but you're right. When I compare the two now, they both have the same amount of files and spot checking between them at various points, I see the same file names, etc.  Ok, scratch that question.

Paolo Bevilacqua Wed, 08/11/2010 - 06:39

CME and routers are just about read doc, try, read again and try again.

They work beautifully after broken in. Much better than "competitors".

Please remember to rate useful posts clicking on the stars below.

Ryan Mullins Thu, 08/12/2010 - 15:49

Try changing the line "ip http path flash:" to "ip http path flash:/".  This worked for me last time I hit this.

Paul Reck Thu, 08/12/2010 - 23:30

Hi jmeier,

in addition to Paolo's suggestions, here are a couple of pages of the Admin guide dealing with what you need.

1. http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeinstl.html#wp1071374

    http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmegui.html

Make sure you've followed the installation directions from the first link.

2. http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeconf.html

This one is dependent on if you are using software or hardware conferencing.  You should be able to get 3 way conferences with software but more than that if you have the DSPs spare to use a hardware bridge.

4. http://www.cisco.com/en/US/docs/voice_ip_comm/cucme/admin/configuration/guide/cmeinstl.html#wp1071374

Same as link from 1.  Upgrading is a matter of installing the new IOS and the correct CUCME firmware and GUI files for that version.  Your configuration won't be wiped, but removing the unwanted files from flash I've always done manually.

5. Assuming you are on Eastern Standard or -5 hours from GMT, then your timezones look right.  Paolo's suggestion of a firmware update might be a good bet.

regards,

Paul

jmeier10510 Fri, 08/13/2010 - 03:32

Update:

I was able to upgrade to IOS 15.1(2)T and CME 8.0.0.0    So my upgrade question is taken care of.   Only problem is, according to the compatibility matrix, the GUI for CME 8.0.0.0 is only supported for IOS 15.1(1)T and 15.0(1)XA.   When I go to download 15.1(1)T, I see a whole host of bugs listed there and there's a warning that you need to be aware of those bugs before you download.   So I guess I won't be going back to that IOS.   I'll leave it at the 15.1(2)T.

So at the moment, the http server is working to some extent.  If I browse to the IP address of the router with no ccme.html at the end, I get to the routers main web page, which looks like what you see in the attached image. 

For the GUI, unless I tell if that the files are in ip http path flash:/gui it will display a blank page.  When the files were extracted from the TAR, they were put in the a folder called gui.   Now here's where I think the compatibility matrix may come into play.  The IOS version I have installed is not listed as one of the compatible IOS versions for CME GUI 8.0.0.0 and when I do get SOMETHING to display on the page, I get something like this....just a bunch of garbage.  You think this is due to the compatibility issue?  I get this by going directly to page http://IPADDRESS/admin_user.html.   I get a completely blank page if I go to http://IPADDRESS/ccme.html

I assume that the web page you go to has to be one of the HTML files you see in flash, right?  Well, the user info I saw on Cisco's site said the gui page you go to is the ccme.html page, but I see no ccme.html file in my flash.  I do see other html files and I can get the ones I see below to display, but not display correctly.

My GUI files in flash:

60           0 Aug 12 2010 16:18:18 gui

61      829440 Aug 12 2010 16:18:22 gui/admin_user.html

62      677820 Aug 12 2010 16:18:24 gui/admin_user.js

63        1029 Aug 12 2010 16:18:24 gui/CiscoLogo.gif

64         615 Aug 12 2010 16:18:26 gui/CME_GUI_README.TXT

65         953 Aug 12 2010 16:18:26 gui/delete.gif

66       16344 Aug 12 2010 16:18:26 gui/dom.js

67         864 Aug 12 2010 16:18:26 gui/downarrow.gif

68        6146 Aug 12 2010 16:18:26 gui/ephone_admin.html

69        4558 Aug 12 2010 16:18:28 gui/logohome.gif

70        3866 Aug 12 2010 16:18:28 gui/normal_user.html

71       78428 Aug 12 2010 16:18:28 gui/normal_user.js

72        1347 Aug 12 2010 16:18:28 gui/plus.gif

73         843 Aug 12 2010 16:18:30 gui/sxiconad.gif

74         174 Aug 12 2010 16:18:30 gui/tab.gif

75        2432 Aug 12 2010 16:18:30 gui/telephony_service.html

76         870 Aug 12 2010 16:18:30 gui/uparrow.gif

77        9968 Aug 12 2010 16:18:30 gui/xml-test.html

78        3412 Aug 12 2010 16:18:32 gui/xml.template

79     1848343 Aug 12 2010 16:18:38 GUI-1.3.3.SBN

80     1892036 Aug 12 2010 16:18:46 GUIH-1.3.3.SBN

Paolo Bevilacqua Fri, 08/13/2010 - 04:02

try the telephony_service.html page

That is, ccme.html

However, that GUI is very poor.

If you want some GUI, use Configuration Professional.

jmeier10510 Fri, 08/13/2010 - 04:04

Thanks!

But bummer.....I get a page, but it's blank except for what you see here.  Would this be related to the compatibility issue?

jmeier10510 Fri, 08/13/2010 - 04:05

GUI is not absolutely necessary for me.  I just thought it would be nice to have it working, for convenience.  No logging into router and command line....just go to web page for some simple changes.

Paul Reck Fri, 08/13/2010 - 04:14

I'm not a fan of the GUI myself but it's an accessible way for a customer administrator, who doesn't have a lot of Cisco CLI experience, to set up users and phones.

It looks like the file permissions aren't set correctly,  did you extract the files with the archive tar /xtract source-url flash:/file-url command?

regards

Paul

jmeier10510 Fri, 08/13/2010 - 04:22

I did exactly what the CME 8 readme.txt file said to do, which is:  archive tar /xtract tftp://ip-address-of-tftp-server/cme-full-8.0.0.0.tar flash: 

(6) Download the cme-full-8.0.0.0.tar file. This TAR file includes all the phone loads

(7906/11, 7915/16, 7921/25, 7931, 7937, 7941/61, 7942/62, 7945/65, 7970/71, 7975), as well as

gui files, and ringtones.  The gui files will be unarchived to the "gui" folder, while the ringtones and xml

will be downloaded to the "ringtones" folder. Phone loads will be downloaded to the flash root directory folder.  For all other support files such as BACD scripts, extension-assigner scripts, etc, the customer should download and copy the files onto the CME flash manually.

Paul Reck Fri, 08/13/2010 - 04:31

You may be right about the version clash then,

the 8.0.0.0 GUI files are tied to the 15.0(1)XA and 15.1(1)T releases.  So it might be worth rolling back to those releases if you want to enable the GUI.

Paul

jmeier10510 Fri, 08/13/2010 - 04:57

Well shoot...I went back to the recommended IOS version and still no dice.   Same mostly blank page as shown previously.   Guess I'll go back to the newest release.  There's got to be something else making this not work right.   Hmmmm

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.1(1)T, RELEASE SOFTWARE (fc1)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Mon 22-Mar-10 02:13 by prod_rel_team

Ryan Mullins Fri, 08/13/2010 - 06:18

Did you ever try the "ip http path flash:/"?  I can recreate this in my lab on 12.4(24)T3 with just having "ip http path flash:".  Without the / after I put in credentials I get the blank page and when I add the / to the end then the /ccme.html page does work properly.

jmeier10510 Fri, 08/13/2010 - 06:25

My gui files are in a folder called gui so I must note that in the http path..they're not on the root of the flash.  If I do ip http path flash:/  I get a completely blank web page (all white - since there's no file found).   If I do ip http path flash:/gui OR ip http path flash:/gui/   I get the page displayed below.  It has a colored background and the words 'view window' in the top left, and that's it. 

Correct Answer
Paolo Bevilacqua Fri, 08/13/2010 - 13:48

I have found that starting from some past release, the only location the GUI files will work from, is root.

jmeier10510 Mon, 08/16/2010 - 03:40

FINALLY!  :-)    After moving the files to the root of flash on this new version 8 build I loaded with IOS version 15.1(1)T  (even though I know there are problems with that IOS version), the GUI works.  I may try now to move to the very newest IOS and see if it still works after that.

Davy Ad Mon, 07/11/2011 - 21:16

Hello,

Could you please advice  me on how you move your CME GUI to root please ?

I have configured ip http path flash:/, but it returns back to flash .

I would be glad on your response

Thanks,

Dak

Mishaal Khan Mon, 01/23/2012 - 01:31

You have to write

ip http path flash:GUI

If ur GUI files are in a folder called GUI

Mishaal Khan Mon, 01/23/2012 - 01:32

In CME 9.0 you NEED to add the below line in order for the GUI to work:

Router(config)#file privilege 0

Actions

This Discussion

Related Content