ACS 5.1 on Vmware

Unanswered Question

I have installed ACS 5.1 and im having issues trying to patch the server. For some reason i cant even upload the new patch 5-1-0-44-3.tar.gpg into ACS 5.1. Its looks as though its loading in then disappears. I have tried installing patch 1, but the server reports still updating for hours and hours. Please Help!!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2 (1 ratings)
Waris Hussain Wed, 08/11/2010 - 15:22


Can you copy past what you are doing and what you are getting in the CLI

make sure you have the patch saved in the ftp server with extension tar.gz and in ACS you should have repository pointing towards. that .

Also verify the checksum of the patch file which you downloaded to the one which is on the cisco website.


Waris Hussain.

Hi Warris,

To be honest all im looking for is to be able to authenticate users from Active Directory when they log onto a switch. Everything appears to be fine but having no luck. Thought i should possibly install the following patch as this may be the issue. (5-1-0-44-3.tar.gpg)

Are there any step by step instructions for using AD for Authenication and how to configure everthing.


When i log into ACS 5.1 and go into Centralized Software Updates, and select upload software update and choose the file from my local drive it does not load into ACS. I can load 5-1-0-44-1.tar.gpg using this method, but when i apply this patch, it just seems to update forever and never complete. Please help!!!

Waris Hussain Thu, 08/12/2010 - 09:33


Here is the procedure

goto this link :

downlaod the file : 5-1-0-44-3.tar.gpg

and place the file in the FTP server in your enviroment

Login to the ACS CLI :

Create a repository:

"s"  is  in your case the ftp server link where you have place the file 5-1-0-44-3.tar.gpg
"user luke password skywalker" is the login credentails to your ftp server.

run this command :

acs patch install patch-name.tar.gpg repository repository-name

Installing an ACS patch requires a restart of ACS services.
Would you like to continue? yes/no
Waris Hussain.

acs/admin(config)# repository myrepository
acs/admin(config-Repository)# url s
acs/admin(config-Repository)# user luke password skywalker
acs/admin(config-Repository)# exit
Przemyslaw Konitz Fri, 08/13/2010 - 05:23

I had the same issue, the only workaround was do it manually from a CLI as Waris Hussain wrote.

then after defining repository everything went well


farasidd Tue, 08/31/2010 - 07:34

What Waris mentioned is the workaround to install the patch . I have tried this method and it works .



This Discussion