CUPC 8 and Unity Connection VoiceMail

Unanswered Question
Aug 11th, 2010

THe CUPC 7 client would give you the option to see and listen to voicemail. I do not see that option in the CUPC 8 client. Has that been removed?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Chris Tolley Fri, 10/08/2010 - 13:16

Make sure to follow the Configuring Cisco Unity Connection Servers section in the Presence 8 Deployment Guide.

You will also need to configure a Mailstore (Presence Admin -> Application -> CUPC -> Mailstore)

As we as a Voicemail Server (Presence Admin -> Application -> CUPC -> Voicemail Server)

and Voicemail Profile (Presence Admin -> Application -> CUPC -> Voicemail Profile)

Sarthak kumar Rohal Fri, 10/08/2010 - 13:24

Just for the sake of understanding "Why we need to configure Mail store server, because they will be lying on Unity Connection servers only"

Thanks in Adv.

SKR

Chris Tolley Fri, 10/08/2010 - 13:26

Interestingly enough, the Mailstore is the connection to the Voicemail store. The Voicemail server

is actually used for secure access.

One of Cisco's interesting naming conventions.

By the way, I got this info from Michael Luo's book on configurating Presence. Recommended.

Sarthak kumar Rohal Fri, 10/08/2010 - 13:46

Still it is not working. Earlier system was running on CUPC7 and few users having older version are working perfectly.

After upgrading to CUP 8.0.2 and CUPC 8 its not working.

Even i am not able to see Voice mail as a part of Server health status.

Pic attached.

Thanks in adv.

SKR

Chris Tolley Fri, 10/08/2010 - 14:52

Has the CUPC client been restarted since you created the Mailstore and Voicemail Profile?

Di you add all the users to the Voicemail Profile?

Sarthak kumar Rohal Fri, 10/08/2010 - 15:38

Problem solved.

Earlier Voice server were added with HTTPs and 443 port. I changed them to http and 80.

Thanks a lot

SKR

keithknowles Thu, 03/03/2011 - 12:04

You should be able to use HTTPS though, I am facing a similar issue using Unity Connection 8.5, CUPS 8.5, and CUPC 8.5.  The voicemails are delivered, and I can lisen to and manage them, however the server health shows that only the message store is connected, the voicemail is disconnected.  if i change the voicemail profile on CUPS to use http on port 80 all is well..i do not however wish to use http as that means the passwordsd are being sent clear text.

Does anyone know if there is a certificate that has to be excanged between the Unity Connection and Presence Server?

Keith

Nelson Alonso Thu, 08/04/2011 - 08:10

Hey. Was wondering if you found out what the issue was. I'm in the same boat. I can connect http/80, but not https/443. Was it a certificate issue. In my case I'm using single sign-on, so UnityConnection is authenticating against ldap but not secure ldap. I wonder if when Unity gets the encrypted credentials via https, it sends them encrypted to the ldap server and the server rejects authentication.

anil.batra Sat, 03/12/2011 - 21:38

Chris, For the "Mailstore" - for this am I supposed to enter Unity Connection IP/Hostname pls ?

Chris Tolley Mon, 03/14/2011 - 10:35

That's correct. I used the hostname for Name, and 443 for the web service port and HTTPS for the protocol.

anil.batra Mon, 03/14/2011 - 10:41

Thanks a lot, Chris. And I beleive Cisco documention/CUPS development  team will udtae "Mailstore" to "Unity Connection" or something more appropriate so that others will not confused on this.

Matthew Berry Wed, 01/11/2012 - 13:44

Here's the solution that worked for me:

Go to the Unity Connection web page and open the SSL certificate from the web brower (e.g. using Firefox).  Click "View Certificate" and look for what the Common Name (CN) is set to.  For me, this was servername.domain.local.

Download the certificate and upload to the cup-trust certifcate store in CUPS OS Administration.  Do this for each Unity Connection server.

In CUPS Administration, under voicemail servers, I was configuring using hostname or IP address.  When using port 443 and HTTPS, my Voicemail section in CUPC would show "Disconnected."  If you change the hostname/IP entry to the FQDN it will connect over HTTPS/443.

jesse.schafer Wed, 03/28/2012 - 10:32

Although I didn't test this solution, if you are running into this issue with voicemail showing disconnected in CUPC and are using HTTPS, port 443, and are connecting to the Unity connection servers by IP address it seems to be caused by the servers self signed certificates. I believe an alternate solution would be to regenerate Unity Connection's Tomcat certificates with an alternate name matching each Unity Connection server's IP address.

From the CLI:

Enter: show web-security

Make note of the following line:

Subject: C=CA, ST=STATE, L=LOCALE, O=ORGANIZATION, OU=ORGANIZATIONALUNIT, CN=COMMONNAME

Use values from above in the set web-security command. Use quotes around items with spaces, ie: replace ORGANIZATION with "My Company" and replace SERVERIP with the IP address of the host you are entering the commands on.

Enter: set web-security ORGANIZATIONALUNIT ORGANIZATION LOCALE STATE CA SERVERIP

Select yes to regenerate the Tomcat certificate

Restart the tomcat service.

Enter: utils service restart Cisco Tomcat

iantra123 Tue, 11/27/2012 - 03:24

Hello,

I'm using CUPC 8.6.

Use the Name instead of the IP address. i.e  CUP-servername.

I've tested with the IP address, and it always fails with CUPC.

But in Jabber 9, it works.

Hope this help.

Antra

Actions

This Discussion