DFM 3.2.0 device discovery problem - stuck in questioned

Answered Question
Aug 13th, 2010
User Badges:

Hi all,

I have a problem with DFM device discovery status. Two devices are added to DFM but booth of them are in Questioned state.

When I check device details its saying SNMP Timeout problem.

DFM.JPG

I increased SNMP timeout to maximum of 30 sec, but there's no changes. Can someone help me about this???


thanks in advanced

Correct Answer by ngoldwat about 6 years 7 months ago
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
CSCO11227946 Wed, 08/18/2010 - 08:40
User Badges:

can anyone help about this?

I added two more devices and both of them are stuck in questioned state.

ngoldwat Wed, 08/18/2010 - 09:03
User Badges:
  • Cisco Employee,

- Go to DFM > Device Management > Rediscover/Delete. Click on your test
device and send me a screenshot of the resulting page, showing the Item
Information.


- Go to Common Services > Device and Credentials > Device Management. Select
only your test device and click Export. Send me the resulting text file from
the server (Be sure to remove any sensitive data).


- Send show version and show run from your test device (not show tech).


- \CSCOpx\log\dfmLogs\cfi\InventoryCollector.log


- \CSCOpx\log\dfmLogs\TIS\DeviceMangement.log


:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:.:


Try to discover the device using the cli:


NMSRoot/objects/smarts/bin>sm_tpmgr -s DFM --add-agent=

CSCO11227946 Thu, 08/19/2010 - 03:56
User Badges:

hi mate, thanks for your reply,

files U requested are attached here.

I tried to discover device usig CLI but same result. Devices are in Questioned status.


Thanks In advanced.

Attachment: 
CSCO11227946 Mon, 08/23/2010 - 05:45
User Badges:

Thank for reply mate,

but i did' find any update on page U gave me, just info about CSCta56151 bug.

is there any update for this bug?


cheers

mayurkpatel Wed, 10/27/2010 - 05:35
User Badges:

Hi Nick ,


I am using LMS 3.1 DFM 3.1.3

I have added 130 devices in DCR through CSV file,

Alls are showing in CS moduls (Device Allocation summary) but those are not come in DFM module.

I am put all modules in auto allocation mode

I have restarted services (crmdmgtd)  and also restarted hard reboot server.

I have also checked pdshow command all services are running ok.

I had tried with all database reinitialized using all those command


NMSROOT\bin\perl.exe NMSROOT\bin\dbRestoreOrig.pl dsn=cmf dmprefix=CMF


same for rmeng, ani, ipm, dfminv, dfmemp, dfmfh, opsxml, upm

but probleme is same .


I had removed both database file from NMSROOT/objects/smarts/local/repos/ISF after data base reintialized


Still I did't get devices in DFM>> Devices Management >> Device Import


some of log file and screensort of DFM are attached for ref


pls help me

CSCO11227946 Sat, 11/06/2010 - 10:25
User Badges:


Hi there, just to conclude this topic with a solution to original problem...

after applying patches:

dfm3.2-win-CSCta56151.tar
dfm3.2-win-CSCtb87449.tar

the problem was still present, but couple of devices vent to KNOWN state, and others stayed in QUESTIONED.

Only thing different on these devices ware that KNOWN devices ware added manually to DCR and other devices ware discovered using device discovery.

With help of coupe of associates we found out that only difference between this two sets of devices (manually added and discovered) is that discovered devices  have ENGINE ID field in Device Credentials automatically filled.

After deleting only Engine ID from Device Credentials and adding them again to DFM all of them vent to KNOWN state.


I'm not sure if this is caused by a bug in DFM, becouse Engine ID is added automatically in discovery process, but it's a reason that they get stuck in QUESTIONED state?


I hope this might be helpful to other LMS users.


cheers

jsfsantos Wed, 12/22/2010 - 06:05
User Badges:

Hello,


I am with a the same problem to configure DFM . All devices that I added stay with status QUESTIONED. I checked the credential and All is okay. About tha patches mentioned in the case I installed all but the problem not solve.


I want to know how you do to delete the Engine ID of the credential of the devices. because how you saw after this the devices change the status to Know right.


Thanks,


João Ferreira.

CSCO11227946 Thu, 12/23/2010 - 03:49
User Badges:

Hi João,

U can delete Engine ID in DEVICE AND CREDENTIALS > DEVICE MANAGEMENT > select a device and go to EDIT CREDENTIALS.

Then U Select a used Credential Set to Edit and under the SNMP CREDENTIALS u can find Engine ID field.

deleting Engine ID solved my problem, I hope it'll be the same for you.

Actions

This Discussion

Related Content