Migrating from 3745 to 2811 Voice Gateway

Unanswered Question
Aug 13th, 2010

We are migrating our Voice Gateway from a 3745 to a 2811.  I plan on taking the dual port WIC out of the 3745, inserting it into the 2811 and then configure the router.  I would like the new 2811 to run the same as the 3745.  I know that there are differences between the two boxes however such as how the ports are identified, but don't know what else to change regarding the config.  I am attaching the current running config of the 3745 with edits that I think should be made to it.  Any help on identifying things I have missed or that won't work on the 2811 would be greatly appreciated.  I have indicated the lines I think need to be changed with !! followed by what I believe the line should be changed to.

MIG-PA-VG3745#sh run
Building configuration...

Current configuration : 8155 bytes
!
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname #####
!
boot-start-marker
boot system flash:c2800nm-advipservicesk9-mz.124.22.T5.bin
boot-end-marker
!
logging buffered 51200 warnings

clock timezone Eastern -5
clock summer-time EDT recurring 2 Sun Mar 2:00 1 Sun Nov 2:00

!! network-clock-participate slot 1
network-clock-participate wic 0

!! no network-clock-participate slot 2
no network-clock-participate wic 1

! I don't think we need the following for 2811
!! no network-clock-participate aim 0
!! no network-clock-participate aim 1
!! network-clock-select 1 T1 1/0

network-clock-select 1 T1 0/0/0


voice-card 0
dspfarm
!
voice-card 1
dspfarm
dsp services dspfarm
!
aaa new-model
!
!
aaa authentication login default group tacacs+ local
aaa authentication login no_tacacs local
aaa authorization exec default group tacacs+ local
aaa accounting exec default start-stop group tacacs+
aaa accounting commands 15 default start-stop group tacacs+
aaa accounting network default start-stop group tacacs+
aaa session-id common
ip subnet-zero
no ip source-route
ip cef
!
ip host Call-Manager-01 10.101.11.250
ip host Call-Manager-02 10.101.12.250
no ftp-server write-enable
isdn switch-type primary-5ess
!
!
voice call send-alert
voice rtp send-recv
!
voice service voip
h323
!
!
voice class codec 99
codec preference 1 g711ulaw
codec preference 2 g729br8
codec preference 3 g729r8
!
voice class h323 1
h225 timeout tcp establish 3
!
!! controller T1 1/0
controller T1 0/0/0

framing esf
clock source line primary
linecode b8zs
pri-group timeslots 1-24

!

!! controller T1 1/1
controller T1 0/0/1

framing esf
linecode b8zs
pri-group timeslots 1-24

!
interface Loopback1
ip address 172.16.32.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.6.1 255.255.240.0
duplex auto
speed auto
h323-gateway voip interface
h323-gateway voip bind srcaddr 172.16.6.1
!

!! interface Serial1/0:23
interface Serial0/0/0:23

no ip address
no logging event link-status
isdn switch-type primary-5ess
isdn incoming-voice voice
no cdp enable
!


!! interface Serial1/1:23
interface Serial0/0/1:23

no ip address
no logging event link-status
isdn switch-type primary-5ess
isdn incoming-voice voice
no cdp enable
!

ip classless
ip route 0.0.0.0 0.0.0.0 172.16.1.40

no ip http server
ip http authentication local
ip tacacs source-interface FastEthernet0/1
!

!
tacacs-server host 172.16.17.241
tacacs-server host 172.16.1.31
tacacs-server directed-request
tacacs-server key 7 ###########
!
control-plane
!
!
call application voice rorerrecord flash:callrecorded.tcl
!
!


!! voice-port 1/0:23
voice-port 0/0/0:23


input gain -2
output attenuation 1
echo-cancel coverage 48
bearer-cap Speech
!


!!voice-port 1/1:23
voice-port 0/0/1:23


input gain -2
output attenuation 1
echo-cancel coverage 48
bearer-cap Speech
!


voice-port 0/1/0
!
voice-port 0/1/1
!
voice-port 0/1/2
!
voice-port 0/1/3
!


no mgcp package-capability res-package
no mgcp package-capability fxr-package
no mgcp timer receive-rtcp
!
sccp local FastEthernet0/1
sccp ccm 10.101.12.250 identifier 1 version 4.0
sccp ccm 10.101.11.250 identifier 2 version 4.0
sccp
!
sccp ccm group 1
bind interface FastEthernet0/1
associate ccm 1 priority 1
associate ccm 2 priority 2
associate profile 2 register MTP000f24e785f1
switchover method immediate
!
dspfarm profile 2 transcode
codec g711ulaw
codec g711alaw
codec g729br8
codec g729r8
codec gsmfr
codec g729abr8
codec g729ar8
maximum sessions 14
associate application SCCP
!
!
dial-peer voice 9 pots
preference 1
destination-pattern 9T
progress_ind setup enable 3
progress_ind alert enable 8
progress_ind connect enable 1

!! port 1/0:23
port 0/0/0:23
!
dial-peer voice 99 pots
destination-pattern 9T
progress_ind setup enable 3
progress_ind alert enable 8
progress_ind connect enable 1

!! port 1/1:23

port 0/0/1:23
!
dial-peer voice 999 voip
preference 2
destination-pattern .
progress_ind setup enable 3
voice-class codec 99
voice-class h323 1
session target ipv4:10.101.11.250
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 9999 voip
preference 2
session target ipv4:10.101.11.250
incoming called-number 9
codec g711ulaw
no vad
!
dial-peer voice 888 pots
incoming called-number .
direct-inward-dial
!! port 1/0:23
port 0/0/0:23


!
dial-peer voice 9900 voip
preference 1
destination-pattern .
progress_ind setup enable 3
voice-class codec 99
voice-class h323 1
session target ipv4:10.101.12.250
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 911 pots
destination-pattern 911
progress_ind setup enable 3
!! port 1/0:23
port 0/0/0:23


forward-digits all
!


dial-peer voice 9112 pots
preference 1
destination-pattern 911
progress_ind setup enable 3
!! port 1/1:23
port 0/0/1:23


forward-digits all
!


!does the following line have one too many eights?  circle back and check
dial-peer voice 88888 pots
incoming called-number .
direct-inward-dial
!! port 1/1:23
port 0/0/1:23

!


dial-peer voice 343 pots
application rorerrecord
incoming called-number 343.
direct-inward-dial
!
dial-peer voice 341 pots
application rorerrecord
incoming called-number 341[9]
direct-inward-dial
!
dial-peer voice 342 pots
application rorerrecord
incoming called-number 342[289]
direct-inward-dial
!
dial-peer voice 344 pots
application rorerrecord
incoming called-number 344[01]
direct-inward-dial
!
dial-peer voice 345 pots
application rorerrecord
incoming called-number 345[2345678]
direct-inward-dial
!
dial-peer voice 346 pots
application rorerrecord
incoming called-number 346[0123456]
direct-inward-dial
!
dial-peer voice 3500 voip
preference 2
destination-pattern 6035..
progress_ind setup enable 3
voice-class codec 99
voice-class h323 1
session target ipv4:10.101.11.250
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 349 pots
application rorerrecord
incoming called-number 349[7]
direct-inward-dial
!
dial-peer voice 351 pots
application rorerrecord
incoming called-number 351[1]
direct-inward-dial
!
dial-peer voice 899 voip
preference 1
destination-pattern .
progress_ind setup enable 3
voice-class codec 99
voice-class h323 1
session target ipv4:10.101.12.250
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 8999 voip
preference 1
session target ipv4:10.101.12.250
incoming called-number 9
codec g711ulaw
no vad
!
dial-peer voice 3501 voip
preference 1
destination-pattern 6035..
progress_ind setup enable 3
voice-class codec 99
voice-class h323 1
session target ipv4:10.101.12.250
dtmf-relay h245-alphanumeric
no vad
!
dial-peer voice 350 pots
application rorerrecord
incoming called-number 350[9]
direct-inward-dial
!
gateway
timer receive-rtp 1000
!
!
line con 0
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
privilege level 15
password 7 #####
transport preferred all
transport output all
line vty 5 15
privilege level 15
transport preferred all
transport output all
!
ntp clock-period 17175144
ntp server 172.16.1.40 prefer
ntp server 131.107.1.10
end

MIG-PA-VG3745#

Thanks,

Josh

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.

Actions

This Discussion