WAAS and MSCAD 2010

Unanswered Question
Aug 13th, 2010

We utilize AutoCAD within our WAAS infrastructure and it works great however we have been having some performance issues with Microsurvey CAD 2010. http://www.microsurvey.com/products/mscad/  . Anyone else in here use MS CAD in their environments and if so, what have you done ot optimize this traffic?  I'm waiting to hear back from our vendor on how the software works and what type of protocols it uses.

Any help would be great from the community.

Thanks

Shaun

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
focused Tue, 08/17/2010 - 07:37

I'll post an e-mail I got back from Microsurvey that may or may not help.  So far it has

not for us.

"Here is how our database works, in a nutshell...

The two main MicroSurvey CAD files are the .dwg drawing file and the .msz database file – these two are always be together in the same folder (there are also several others: a log file, backups of both the dwg (bak) and msz (mbk), and possibly others depending on data imported/exported with the project).  When a drawing is opened, we uncompress the .msz database file into a .msj database folder which resides at the same location the dwg/msz files are.  Typically, the .msz file is read when the project is opened, and then written when the project is saved. While the user is working within a project, MSCAD uses the temporary files inside the .msj folder which for the most part are CodeBase data files (You can look inside one of these .msj folders to see its full contents, but they are *.dbf, *.mdx, incad.cfg, x99.dat, x100.dat, ch.dll).  Every time MSCAD needs to read/write something from the database it uses the appropriate files(s) in the msj folder.  The files in the msj folder are being constantly read and written, so the waas caching system in Calgary may be working overtime keeping them synced with the file server in Edmonton.  "

Seems to me there isn't much to this and while on the Central Manager I watched the traffic from the IP's that actually are running MicroSurvey and the only thing that's running through the WAE is CIFS (the files they have open).  It's doing a fine job compressing and optimizing that traffic however its still slow for them.  Could it be there isn't anything the WAE's can do in this situation?  If not we've got a big problem.

jomerril Tue, 08/17/2010 - 07:55

Personally, I am unfamiliar with MicroSurvey CAD software, and don't recall working with any accounts where that was deployed.  Of course, I am not involved with every deployment and can't say whether others watching this forum might have experience with deploying MSCAD across WAAS.

I went to their web site to see if they perhaps have posted protocol information, but didn't find anything helpful.  We would need to know the protocol(s) over which MSCAD communicates (ex. CIFS, HTTP, HTTPS, proprietary TCP, etc.).  We also would need to know whether the data is already compressed and/or encrypted. 

Cisco TAC should be able to assist you in diagnosing the cause of the slower performance with MSCAD.  They will likely ask for a good, detailed problem description, a set of packet captures that show the problem, and sysreports from the WAEs.  A sysreport contains a collection of logs, configuration information, and statistics which TAC will use in conjunction with the packet captures to pinpoint where the slowness is occurring.

focused Tue, 08/17/2010 - 08:07

Thanks Joseph,

I'm very familiar with the TAC case as we used it to troubleshoot some ACAD slowness.

Hopefully someone else here has seen this or has some insight.

Actions

This Discussion