Failed to open Unity Manage Integrations

Unanswered Question
Aug 13th, 2010

Okay it worked before after Unity 5.0 was installed. Recently, it just stops working. This issue can be tracked under CSCsi54038.

Workarounds:

http://cisco.biz/application/pdf/paws/112026/unity-cucm-integration.pdf

I tried the Option 1 in the document above and it seems to work fine.

i.e. If you stop Cisco Unity services, UTIM launches without problem.

However, I wanted a permanent fix. I believe that's Option 2. With option 2, it won't allow me to add UnityInstall account. Under the Security settings (see attached MTXMiuRegistryReadWrite.png), I can see the UnityMsgStoreSvc account with some permissions. But, if I want to add the UnityInstall account and give it the same or even more permissions than the UnityMsgStoreSvc account, then save it, it appears that it took it. But when I reopen the MTXMiuRegistryReadWrite properties box, the UnityInstall account is gone.

Also from the Application Event logs, I'm showing the following error messages and I think they're related to what I was trying to do with the MTXMiuRegistryReadWrite

Event Type: Error
Event Source: CiscoUnity_LogMgr
Event Category: Startup
Event ID: 1013
Date:  8/13/2010
Time:  1:51:37 PM
User:  N/A
Computer: UM2SJE
Description:
procexp: Failed creating mutex for Cisco Unity: Sessions (Voice) (AvVoicePerf).  Unity performance data will not be available.

Event Type: Error
Event Source: CiscoUnity_LogMgr
Event Category: Startup
Event ID: 1013
Date:  8/13/2010
Time:  1:51:37 PM
User:  N/A
Computer: UM2SJE
Description:
procexp: Failed creating mutex for Cisco Unity: Unity MTA (AvUnityMTAPerf).  Unity performance data will not be available.

I didn't try Permissions Wizard and Service Configuration Wizard. Did anyone try this without touching options 1 and 2? Did it get fixed permanently for you?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Bradford Magnani Sun, 08/15/2010 - 12:19

Hi,

You have 2 different issues going on.  The CiscoUnity_LogMgr errors you're seeing are most likely because CUPID (http://www.ciscounitytools.com/Applications/Unity/CUPID/CUPID.html) has been installed at some point and it can't read performance counters anymore for some reason.  Those errors shouldn't be related to the permissions warning that you're seeing when launching UTIM.  Your screen shot looks like you've manually added UnityInstall?  The workaround states to add the Local Administrators group.  It may behave differently if you explicitly add the user.  Try adding the Local Administrators group instead.  Also have you checked to see if the Local Security policy may be overriding the default behavior as mentioned in the "additional comments" section of the defect here?

http://tools.cisco.com/Support/BugToolKit/search/getBugDetails.do?method=fetchBugDetails&bugId=CSCsi54038

Brad

ktran-anet Mon, 08/16/2010 - 01:01

HI Brad,

You could be right about the App Event error messages. Howover, sometimes, I don't touch the MTXMiuRegistryReadWrite for days and the App Event looks all clean. As soon as I open the MTXMiuRegistryReadWrite, those messages show up right after that in the App Event Viewer. That's why I thought it is somewhat related.

I'm not sure how to add a "Local Administrators group" instead. But yeah, adding a user will not work.

Yes, you're right that the screenshot shows that I can add a domain user and give it some permissions. However, like I said, after adding the unityinstall, saving and exiting, it's gone.

Can you tell from the attached Local Security Policy screenshot if it was overriding the default behavior?

Thanks,

KT

Bradford Magnani Mon, 08/16/2010 - 06:32

Yeah, that looks like yours is inheriting from some other place, not allowing you to change it.  Here's what mine shows in the lab with the Administrators group as the default owner.  Sounds like maybe there's some sort of Group Policy that may be acting on your Unity server?

Brad

ktran-anet Wed, 08/25/2010 - 11:55

Thanks Brad.

Mine is showing "Object creator" instead and it's greyed out. I believe this is controlled by Group Policies. Unfortunately, our IT and Security Departments don't want to make any changes to Group Policies. So I just use the unitymsgstorevsc account as a workaround.

Actions

This Discussion