Cannot ping to ftp server ip address from CUE

Answered Question
Aug 15th, 2010
User Badges:

Hello Everyone,

I am having a problem with CUE interface. I need to do a clean install the language file pkg to cue and cannot ping to ftp server form cue module.

Here's my CUE config, I'll really appreciate if you guys can help.


Regards,

PK


interface Loopback0
no ip address
!
interface FastEthernet0/0
description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0/0$
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 1 native
ip address 192.168.42.2 255.255.255.0
!
interface FastEthernet0/0.100
encapsulation dot1Q 100
ip address 192.168.44.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Internal-Service-Module0/0
ip address 192.168.100.1 255.255.255.252
service-module ip address 192.168.100.2 255.255.255.252
!Application: CUE Running on AIM2
service-module ip default-gateway 192.168.100.1
hold-queue 512 out

Correct Answer by Steven Holl about 6 years 8 months ago

I would run a traceroute from the FTP server to the CUE IP and find out where it is failing, and if it is going out the right hops to the network that the CUE is on.  You can do the same thing for the CUE->FTP direction.


FYI, if you can session into the module from the chassis the device is in with 'ser i0/0 sess' then the configuration on the router for CUE is fine, assuming you don't have a duplicate IP address anywhere.

Correct Answer by paolo bevilacqua about 6 years 8 months ago

Your ftp server is not using 192.168.42.2 as default gateway, or has firewall enabled.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
paolo bevilacqua Sun, 08/15/2010 - 02:27
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Read again the cue docuemntation.


is0/0 address must be unnumbered from voice vlan


CUE address must be taken from voice VLAN. Gatwat is the rotuer address.


Then you have an host route pointing to IS module.

pyaykhaing789 Sun, 08/15/2010 - 03:09
User Badges:

Thank for your reply. Here's my update config. I made changes according to not only cue docement also your advice but still the same.

cannot ping to ftp server.


Config

interface Internal-Service-Module0/0

ip unnumbered FastEthernet0/0.100

service-module ip address 192.168.44.3 255.255.255.0

!Application: CUE Running on AIM2

service-module ip default-gateway 192.168.44.1

hold-queue 512 out


ip route 192.168.44.3 255.255.255.255 Internal-Service-Module0/0


Errors

CUE# ping 192.168.42.2
PING 192.168.42.2 (192.168.42.2) 56(84) bytes of data.
64 bytes from 192.168.42.2: icmp_seq=1 ttl=255 time=700 ms
64 bytes from 192.168.42.2: icmp_seq=2 ttl=255 time=4.50 ms
64 bytes from 192.168.42.2: icmp_seq=3 ttl=255 time=59.0 ms
64 bytes from 192.168.42.2: icmp_seq=4 ttl=255 time=340 ms
64 bytes from 192.168.42.2: icmp_seq=5 ttl=255 time=452 ms


--- 192.168.42.2 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 2379ms
rtt min/avg/max/mdev = 4.507/311.475/700.928/257.023 ms, ipg/ewma 594.800/510.68
8 ms


CUE# ping 192.168.42.222 (ftp server)
PING 192.168.42.222 (192.168.42.222) 56(84) bytes of data.


--- 192.168.42.222 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4007ms
, ipg/ewma 1001.880/0.000 ms

Correct Answer
paolo bevilacqua Sun, 08/15/2010 - 13:05
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Your ftp server is not using 192.168.42.2 as default gateway, or has firewall enabled.

pyaykhaing789 Sun, 08/15/2010 - 21:41
User Badges:

I used Filezilla server as my ftp. So, my laptop is FTP server.

My Lapotp default gateway is 192.168.42.1 which is Firewall ip.

Do I need to add new static route to my laptop? or Is there other way to install license file to cue?


Thank you,

PK

brendand05 Sun, 08/15/2010 - 21:51
User Badges:

Set static route on the ftp server

Route to CUE subnet via gateway CME IP

pyaykhaing789 Wed, 08/18/2010 - 20:01
User Badges:
Hi bevilacqua,

I changed my laptop default gateway to 192.168.42.2 but still cannot. Any idea?

Thanks for your kind help.


Regards,

PK

brendand05 Sun, 08/15/2010 - 21:17
User Badges:

Can you ping the T/FTP from CME?

Did you reload the service module after the above config change?

pyaykhaing789 Sun, 08/15/2010 - 21:45
User Badges:

Yes, I can ping from CME.

I also did reload the service module after ip address had changed.


why do i need to add a supervisory disconnect tone? (sorry I'm new to IP Telephony)


Regards,

PK

brendand05 Sun, 08/15/2010 - 21:19
User Badges:

Hi you don't need disconnected tone......posted reply in wrong tab


You need to add a route to the TFTP server to send traffic destined to the CUE subnet to the CME router

Let me know how you go

pyaykhaing789 Wed, 08/18/2010 - 20:04
User Badges:

Hi brendand,

I added default route to TFTP server but still cannot ping..

Thanks for your kind support.


Regards,

PK

Aaron Harrison Thu, 08/19/2010 - 00:19
User Badges:
  • Super Bronze, 10000 points or more
  • Community Spotlight Award,

    Member's Choice, May 2015

Hi


Post up your gateway config.... including the ISM and FA0/0.100 interfaces, and the static route config.


Aaron

Correct Answer
Steven Holl Thu, 08/19/2010 - 07:22
User Badges:
  • Cisco Employee,

I would run a traceroute from the FTP server to the CUE IP and find out where it is failing, and if it is going out the right hops to the network that the CUE is on.  You can do the same thing for the CUE->FTP direction.


FYI, if you can session into the module from the chassis the device is in with 'ser i0/0 sess' then the configuration on the router for CUE is fine, assuming you don't have a duplicate IP address anywhere.

pyaykhaing789 Thu, 08/19/2010 - 08:15
User Badges:

Wow..After doing many tests using all of your suggestions/advices, I can manage to ping my tftp server

Here's how I solved.

I just changed my tftp server default gateway to 192.168.42.2 which is CME. Previously, it was 192.168.42.1 which is Firewall.

Not finished yet, I also need to disable my window firewall and Kaspersky Firewall. If not, you cannot get reply form ftp server.


Many thanks to Mr.Bevilacqua and Mr.Steven


Sincerely,

PK

paolo bevilacqua Thu, 08/19/2010 - 08:37
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Thank you for the nice rating and good luck!

Actions

This Discussion

Related Content