cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1952
Views
0
Helpful
3
Replies

configure voice vlan

jlaureneana
Level 1
Level 1

i am currently studying cisco ip telephony and would like some help on how to configure Voice Vlans in the network...

i have read many articles from cisco and others as well online but have not understood it clearly....

i have a lab setup at my house with a 3750 Switch to which all my ip phones (7970) are connected and i have one call manager hosted on the mcs7825 server, currently i have created one dhcp pool on my 2821 voice gateway to give out ip addresses in the range 192.168.1.x,

please can someone explain how to configure voice vlans, it would really help if you could give me a configuration example to view and understand....

i read that voice vlans are not supported on trunk ports... please give me a nice explanation.

thank you.

1 Accepted Solution

Accepted Solutions

nascoentr
Level 1
Level 1

On the router:

ip dhcp pool lab

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.1.5 (if you have a dns server)

   domain-name something.local (if its on a domain)

!

ip dhcp pool voice

   network 192.168.2.0 255.255.255.0

   option 150 ip 192.168.1.10

   default-router 192.168.2.1

   dns-server 192.168.1.5

   domain-name voice.lab.local

interface GigabitEthernet0/0

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.1.1 (this address is called the Relay Agent, its the ip address of the dhcp server, in this case the router itself)

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

On the Switch:

Interface Fa1/0/1  (you have to put this configuration on ever port of the switch that connects to the IP Phone that has a pc attached to it)

switchport mode trunk

Switchport trunk encapsulation dot1q

Switchport voice vlan 11

Switchport trunk native vlan 12

Interface Fa1/0/13 (this is the port on the switch that connects to the Gi0/1 on the Router – Data Vlan)

Switchport access vlan 12

Interface Fa1/0/24

Switchport access vlan 11 (this is the port on the switch that connects to the Gi0/0 on the Router – Voice Vlan)

** ip phones should register and do check the operational vlan in the settings on the phone, the phones should be on the subnet 192.168.2.x and the pc on 192.168.1.x

Please rate if helpful.

View solution in original post

3 Replies 3

brendand05
Level 1
Level 1

!

interface vlan1

description - mydata vlan -

ip address 10.10.1.1 255.255.0.0

!

interface vlan100

description - myvoice vlan -

ip address 10.100.1.1 255.255.0.0

!

interface fa 0/1

autoqos

switchport access vlan 1

switchport voice vlan 100

spaning-tree portfast

!

interface fa0/2

autoqos

switchport access vlan 1

switchport voice vlan 100

spaning-tree portfast

!

nascoentr
Level 1
Level 1

On the router:

ip dhcp pool lab

   network 192.168.1.0 255.255.255.0

   default-router 192.168.1.1

   dns-server 192.168.1.5 (if you have a dns server)

   domain-name something.local (if its on a domain)

!

ip dhcp pool voice

   network 192.168.2.0 255.255.255.0

   option 150 ip 192.168.1.10

   default-router 192.168.2.1

   dns-server 192.168.1.5

   domain-name voice.lab.local

interface GigabitEthernet0/0

ip address 192.168.2.1 255.255.255.0

ip helper-address 192.168.1.1 (this address is called the Relay Agent, its the ip address of the dhcp server, in this case the router itself)

duplex auto

speed auto

!

interface GigabitEthernet0/1

ip address 192.168.1.1 255.255.255.0

duplex auto

speed auto

On the Switch:

Interface Fa1/0/1  (you have to put this configuration on ever port of the switch that connects to the IP Phone that has a pc attached to it)

switchport mode trunk

Switchport trunk encapsulation dot1q

Switchport voice vlan 11

Switchport trunk native vlan 12

Interface Fa1/0/13 (this is the port on the switch that connects to the Gi0/1 on the Router – Data Vlan)

Switchport access vlan 12

Interface Fa1/0/24

Switchport access vlan 11 (this is the port on the switch that connects to the Gi0/0 on the Router – Voice Vlan)

** ip phones should register and do check the operational vlan in the settings on the phone, the phones should be on the subnet 192.168.2.x and the pc on 192.168.1.x

Please rate if helpful.

thanks alot, i tried exactly the same and it finally worked

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: