QoS Not working as expected

Unanswered Question
Aug 16th, 2010

Hi Guys,

I am at my last rope here with this situation, we have contacted our ISP who does Cisco and they have been unable to create a proper working configuration for what I believe is a rather simple request, they rather refer us to a IBC (Private network) setup...

The situation is as follows;

2 sites both connected to the Internet using ADSL2, they both also have Cisco 877 routers, there is a DVTI IPSEC setup between the sites to route traffic through the Internet.

At each site there is also a phone system, 1 site has the master and the other the slave, the problem is with out QoS when the branch office downloads a file from the main office the main office saturates its upload link (1Mbps) and the call quality drops to almost 0%

So the question is how can we setup the QoS to guarantee as much as 50% of bandwidth will goto the phone system IF it requires?

I can attach the configurations but did not want to clutter up the thread unless requires

Kind Regards,

Andrew James

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3 (1 ratings)
Loading.
u1kumar2002 Mon, 08/16/2010 - 01:22

Hi,

    To run QOS for phones. you can make a class map for phone(VOIP) then make a policy map QOS  match the class VOIP in that strict priority of 30%. then for class default - remaining. Apply that class map to Virtual template.

For example : http://www.cisco.com/en/US/docs/ios/12_3t/12_3t14/feature/guide/gtIPSctm.html#wp1085879

Refer Dynamic Virtual Tunnel Interface with QOS.

Hope this information will help you..

Do rate for helpful posts...

Uttam

http://www.startnetworks.blogspot.com

jamesitsolutions Mon, 08/16/2010 - 05:41

Thank you for that, after going over the configuration provided by the ISP it appears they dont even touch the SVTI (sorry made spelling mistake before)

Please note the below configuration does not work, this configuration appears to be over complicated and a bit redudant

class-map match-any MATCH-VOIP

match  precedence 5

class-map match-any TAG-VOIP

match access-group name LOCAL-VOIP

!

!

policy-map QOS

class MATCH-VOIP

  priority percent 35

policy-map QOS-IN

class TAG-VOIP

  set ip precedence 5

!

interface Tunnel1

bandwidth 865

ip address 172.30.0.1 255.255.255.252

ip route-cache flow

load-interval 30

qos pre-classify

tunnel source Dialer1

tunnel destination xxx.xxx.xxx.xxx

tunnel mode ipsec ipv4

tunnel path-mtu-discovery

tunnel protection ipsec profile Site-to-Site

!

interface Vlan1

description --- Ethernet to Customer ---

ip address 10.0.0.1 255.255.255.0

ip nat inside

ip virtual-reassembly

ip route-cache flow

ip tcp adjust-mss 1400

service-policy input QOS-IN

hold-queue 100 out

!

interface Dialer1

bandwidth 865

ip address negotiated

ip mtu 1492

ip nat outside

ip virtual-reassembly

encapsulation ppp

ip route-cache flow

load-interval 30

service-policy output QOS

!

ip access-list extended LOCAL-VOIP

permit ip host 10.0.0.200 any

permit ip host 10.0.0.201 any

permit ip host 10.0.0.202 any

jamesitsolutions Mon, 08/16/2010 - 06:12

I have created the following configuration do you believe this is on the right track?

class-map match-any MATCH-VOIP

match access-group name VOIP-SERVERS

!

!

policy-map QOS

class MATCH-VOIP

  set ip precedence 5

  priority percent 50

  set dscp ef

class class-default

  fair queue

  !

!

interface Tunnel1

ip nbar protocol-discovery

service-policy output QOS

!

ip access-list extended VOIP-SERVERS

permit ip host 10.0.0.200 any

permit ip host 10.0.0.201 any

permit ip host 10.0.0.202 any

Actions

This Discussion

Related Content