Cisco 6509 doesn't learn Dynamic mac on a Vlan ?

Unanswered Question
Aug 16th, 2010

Hi,

I noticed this strange behaviour on my Cisco 6509.

According to the diagram attached, I have:

- A cisco 6509 Switch

- A F5 load Balancer

- An Alteon load Balancer

- A server farm

Pb-Vlan14.jpg

My servers are in vlan 14 connected to Alteon, and my two load balancers (F5 and Alteon) are attached to my Cisco via trunks.

The mac addresses of my servers are learned by the F5, the Alteon but not by the Cisco. Could you explain me why I 'm faced to this behaviour ?

Thank you for you help,

Regards,

Julien

*** Below several usefull displays:

¤¤¤ Cisco trunk config connected to Alteon

interface Port-channel2
  switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,3,14
switchport mode trunk
switchport nonegotiate
no ip address
logging event link-status

¤¤¤ Cisco trunk config connected to F5

interface Port-channel8
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 14,104
switchport mode trunk
no ip address
spanning-tree portfast

¤¤¤ sh etherchannel port-chan

Group: 2
----------
                Port-channels in the group:
                ----------------------

Port-channel: Po2
------------

Age of the Port-channel   = 456d:02h:27m:05s
Logical slot/port   = 14/2          Number of ports = 2
GC                  = 0x00000000      HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =    -

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     55     Gi7/46   On    4
  1     AA     Gi7/47   On    4

Time since last port bundled:    12d:18h:44m:48s    Gi7/47
Time since last port Un-bundled: 12d:18h:44m:51s    Gi7/47

Group: 8
----------
                Port-channels in the group:
                ----------------------

Port-channel: Po8    (Primary Aggregator)

------------

Age of the Port-channel   = 101d:01h:49m:26s
Logical slot/port   = 14/8          Number of ports = 2
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP

Ports in the Port-channel:

Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     55     Gi2/48   Active    4
  1     AA     Gi3/48   Active    4

Time since last port bundled:    86d:22h:16m:39s    Gi2/48
Time since last port Un-bundled: 86d:22h:17m:19s    Gi2/48

¤¤¤ Cisco sh vlan

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
...
14   Old-Prod-                     active

¤¤¤ Cisco mac-address-table

Legend: * - primary entry
        age - seconds since last seen
        n/a - not available

  vlan   mac address     type    learn     age              ports
------+----------------+--------+-----+----------+--------------------------
*   14  3333.0000.000d    static  Yes          -   Gi1/4,Gi1/5,Gi1/8,Gi1/9
                                                   Gi1/10,Gi1/12,Gi1/13,Gi1/15
     ...
                                                   Gi9/45,Gi9/46,Po1,Po2,Po4
                                                   Po5,Po6,Po7,Po8,Router,Switch
*   14  3333.0000.0001    static  Yes          -   Switch,Stby-Switch
*   14  3333.0000.0016    static  Yes          -   Switch,Stby-Switch

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chad Peterson Tue, 08/17/2010 - 10:46

This seems a little strange, but there has to be something more to it.

Ping the server from the switch...does it work?  Regardess run:

show ip arp x.x.x.x

show mac-add add x.x.x !<---run this for the mac address that is tied to the arp you see above

Also you may just run 'show mac-add dynamic'...i think thats the right syntax.  I'm not sure what you ran in your output, but its only showing some ipv6 mcast mac addresses

ju.mahieu Tue, 08/17/2010 - 22:04

Thank you Chad for your answer,

Unfortunately , my Cisco has no Layer3 attachment in the Vlan 14, It has only a Layer2.

In the Cisco switch, I route the Vlan 14 toward my Alteon. So I can ping the servers but the mac-address in show arp command is the Alteon's mac.

I have already tried the 'show mac-add dynamic' but the list returned was empty.

Any other idea ?!

Thanks,

Ju

Chad Peterson Wed, 08/18/2010 - 09:51

Thats really strange.  I've seen where some loadbalancers will use a vitural mac or something of that nature...but a mac address is still learned.

Could you span the port channel and then ping.  The packet capture may provide other clues.  There isn't any reason this shouldn't work, thats why I'd like to see this, just to see if there is something else going on.

Actions

This Discussion

Related Content