CUPS 7 Sametime Plugin :- Phone Presence Decorator issue

Unanswered Question
Aug 16th, 2010

Hi,


I have a CUPS 7 server, and am testing phone presence against various versions of Sametime.


The good news for me is that I can get the onhook  / offhook decorator to showup in the ST Plugin.


  However, I dont fully understand whats required for it to work.



My issue is that I have two  sametime communites with the same userid. I am usign BusinessCard MailAddress to map the user to CUCM/CUPS


    I can see presence for that user only if the user is in the PRIMARY sametime community.


I installed ST 8.0.2 and the plugin version 7.1 on another PC, and used the second community as the primay, and I could see the same

user presence on that PC.



So I know that


     1. Presence works

     2. I get the SIP NOTIFY always for the user


     But is it a requirment that the user be in the PRIMARY community for the decorator icon to work ?


Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
shahedvoicerite Mon, 08/16/2010 - 22:54

A Clarification :-


What I am trying to do, is to have BOTH Sametime communities present in my ST CLient.


  I then add both user (same userid , mapped to the same CM user) to my ST contacts.


  Now, only the PRIMARY communities user id shows phone presence.


        This makes sense.


However, I then remove the user from my sametime contacts, and also log off the primary community.


The other user (from second community)is still present, but NO presence is shown.


         The user id is the same, and the mapping is the same (MailAddress in Business Card) so I am not sure why the icon does not show.



If I REMOVE the secondary community and chnage the primary community to be the second community, then

presence DOES WORK  for the second user !!


So it seems like I users need to be in the primary community for presence ???

shahedvoicerite Tue, 08/17/2010 - 06:27

Thanks Michael,



But does that mean it will not work for two communities, if I dont use LDAP ?


   That is what seems to be happening now :-(


But in my case, I have the same user id in both communities... not sure if I had different users, with BOTH in CUCM as well (using the same id in

CUMC and Sametime)


I'll have to test this


Thanks !

Actions

This Discussion