vlan won't come up

Unanswered Question
Aug 16th, 2010
User Badges:

I just got handed taking care of our switch's at work and have some questions, i have not worked with switch's that much but i know a little.


i have a 2960 with 3 vlans 1 vlan for the ports 1 for the trunks and 1 for management with an ip. the switch is up and passing traffic but i can't seem to get my management vlan to up up. vtp settings are ok i have done a shutdown and no shut on the vlan still down down. We have 2950's running the same type of config so not sure if this is something new with the 2960 i have attached a config.  thanks for any help

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
shahhardik Mon, 08/16/2010 - 23:32
User Badges:

Hi,


Hey i have seen your configuration. you are not getting your VLAN 995 (i.e. your management vlan) UP UP, beacause none of your interface belongs to that vlan. All the interface belongs to vlan 78.  To have your vlan in UP UP state you have to have your one port as a member of that vlan.



Try to change one port to vlan 995 and have a check. I hope this will help you out.



Regards,

Hardik

Just_here Mon, 08/16/2010 - 23:56
User Badges:

Thanks for the reply i will try that.  But i have 2950's

with this same config all ports say on 78 vlan and my management

vlan of 995 is up up

shahhardik Mon, 08/16/2010 - 23:59
User Badges:

Hi,


Can you please post your 2950's config too.



Regards,

Hardik

Just_here Tue, 08/17/2010 - 00:07
User Badges:

one thing i have noticed between the 2960 and the 2950 is if i do a show

int gi0/1 trunk and a int gi0/2

trunk

the 2960 only has vlans 1 and 78

the 2950 shows all of my vlans

shahhardik Tue, 08/17/2010 - 00:32
User Badges:

Hi,



Your VLAN is the SVI (i.e switched virtual interface).  To have this interface in UP UP state you should have at least one device connected to a Layer 2 interface within the VLAN. i.e your vlan 995. so you can do the same thing as i had suggested before.


If any question, feel free to ask. I will try my best to answew.


Regards,

Hardik

Antonio Knox Wed, 08/18/2010 - 09:09
User Badges:
  • Silver, 250 points or more

Just,


the 2960 only has vlans 1 and 78

the 2950 shows all of my vlans


This WREAKS of a VTP issue.  I know you said the settings look fine, but I think you should give them a second look.


Check the output of a 'show vtp status' command.  Make sure your VTP domain is correct.  Your switch may not be recieving Vlan data from your VTP server if it is set to transparent (likely culprit) or server.  If it is transparent or server, do the following:


conf t

vtp mode client

vtp domain vtpdomainname

vtp password vtppassword (if this applies, do 'show vtp password' on the vtp server to check)


Issues like this will not appear in your config. 

Fraser Reid Mon, 08/23/2010 - 13:56
User Badges:

type


vlan xxx when in config mode and replace xxx with the VLANs that you want to see.......VTP also as server or transparent......make life easy - get rip of VTP ntil the fault has gone.......

sugarpaddy Mon, 08/23/2010 - 05:26
User Badges:

Put an interface into your management vlan then it will come up you can take the interface back out of it again and it will stay up.

Hope this helps!

Fraser Reid Mon, 08/23/2010 - 13:54
User Badges:

when you do


Sho vlan


do the VLANs all get listed ?


Are the vlans allowed to GET to this switch ie. is something like "Switchport trunk allowed vlan all"


on each of the other trunk ports pointing back to this switch ?

martin_knorre Thu, 08/26/2010 - 00:14
User Badges:
  • Bronze, 100 points or more

Hi,


can you describe why you configured a VLAN for trunking? Or have I understood it wrong way?

The basic problem why the VLAN Interfaces won't come to the up/up state is that the VLan (management) isn't assigned to an access port or isn't allowed on a Trunking port.

Basically the easiest would be to configure: switchport trunk allowed vlan 995 for you management access. Then should become the state up/up.


Regards Martin

Jaswild999 Mon, 09/20/2010 - 12:44
User Badges:

Just here,


Have you found a resolution to this issue?  I have the same switches, all trunked behind my 2811 voice gateway and my admin vlan attached to the trunk ports:



!

interface FastEthernet0/24

description EP-2811

switchport trunk native vlan 250

switchport mode trunk

speed 100

duplex full

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

priority-queue out

mls qos trust cos

auto qos voip trust

!

!

interface range g0/1 - 2

switchport trunk native vlan 250

switchport mode trunk

srr-queue bandwidth share 10 10 60 20

srr-queue bandwidth shape  10  0  0  0

queue-set 2

priority-queue out

mls qos trust cos

auto qos voip trust

!

interface Vlan250

description AdminVlan

ip address 10.250.15.12 255.255.255.0

no ip route-cache

no shut

!


Does not allow me to access the switches.  I have followed all the tips in this thread with not luck.  I have even wiped out the configs and reloaded.  I have devices plugged in.  My voice (vlan 5) and data (vlan 10) come up fine.  Just my management vlan 250 does not.  I can even watch the term show vlan250 being set to down status.


Anyone have any other tricks?


Jason

Antonio Knox Mon, 09/20/2010 - 12:52
User Badges:
  • Silver, 250 points or more

You may want to consider NOT using your management vlan as your native vlan.  That's not a good practice.  I would suggest you making your native vlan an unused vlan.  May solve your problem.


Please rate if it helps.

Julio Garcia Fri, 09/24/2010 - 08:44
User Badges:
  • Bronze, 100 points or more

Agree with Khaled earlier, this looks like vtp issue


Could you paste us the vtp info.




Cheers

Actions

This Discussion