Upgrade UCM 4.1(3) to UCM 8.0(3)

Answered Question
Aug 17th, 2010

Hi,

we would like to upgrade our UCM cluster from release 4.1(3) to 8.0(3) using new hardware. Unfortunately there is no DMA tool available on cisco.com to migrate configuration and no specific upgrade guide from release 4 to 8. Does anybody have some experience for such an upgrade?

thanks in advance

Gundolf.

I have this problem too.
0 votes
Correct Answer by Rob Huffman about 6 years 5 months ago

Hi Gundolf,

Sadly, there is no direct upgrade path between any 4.x CCM to

CUCM 8.x as shown below;

Table 4     Supported Cisco Unified Communications Manager Upgrades for Release 8.0(x)

Cisco Unified Communications Manager
8.0(3)
8.0(2c)SU1
8.0(2c)
8.0(1)
System Version

8.0.3.10000-8

8.0.2.41900-3

8.0.2.40000-1

8.0.1.10000-40

Release Date
Jul 27 2010
Jul 8 2010
May 6 2010
Feb 26 2010

Standard Support

Direct upgrade:

8.0(2c)SU1, 8.0(2c), 8.0(2b), 8.0(2a), 8.0(2), 8.0(1), 7.1(3b)SU2, 7.1(3b)SU1, 7.1(3b), 7.1(3a)SU1a, 7.1(3a)SU1, 7.1(3a), 7.1(3), 7.1(2b)SU1, 7.1(2b), 7.1(2a)SU1, 7.1(2a), 7.1(2), 7.0(2a)SU3, 7.0(2a)SU2, 7.0(2a)SU1, 7.0(2a), 7.0(2), 7.0(1)SU1a, 7.0(1)SU1, 7.0(1), 6.1(5)SU1, 6.1(5), 6.1(4a)SU2, 6.1(4a), 6.1(4)SU1, 6.1(4), 6.1(3b)SU1, 6.1(3b), 6.1(3a), 6.1(3), 6.1(2)SU1a, 6.1(2)SU1, 6.1(2)

Direct upgrade:

8.0(2c), 8.0(2b), 8.0(2a), 8.0(2), 8.0(1), 7.1(3b)SU2, 7.1(3b)SU1, 7.1(3b), 7.1(3a)SU1a, 7.1(3a)SU1, 7.1(3a), 7.1(3), 7.1(2b)SU1, 7.1(2b), 7.1(2a)SU1, 7.1(2a), 7.1(2), 7.0(2a)SU3, 7.0(2a)SU2, 7.0(2a)SU1, 7.0(2a), 7.0(2), 7.0(1)SU1a, 7.0(1)SU1, 7.0(1), 6.1(5)SU1, 6.1(5), 6.1(4a)SU2, 6.1(4a), 6.1(4)SU1, 6.1(4), 6.1(3b)SU1, 6.1(3b), 6.1(3a), 6.1(3), 6.1(2)SU1a, 6.1(2)SU1, 6.1(2)

Direct upgrade:

8.0(2b), 8.0(2a), 8.0(2), 8.0(1), 7.1(3b)SU2, 7.1(3b)SU1, 7.1(3b), 7.1(3a)SU1a, 7.1(3a)SU1, 7.1(3a), 7.1(3), 7.1(2b)SU1, 7.1(2b), 7.1(2a)SU1, 7.1(2a), 7.1(2), 7.0(2a)SU3, 7.0(2a)SU2, 7.0(2a)SU1, 7.0(2a), 7.0(2), 7.0(1)SU1a, 7.0(1)SU1, 7.0(1), 6.1(5)SU1, 6.1(5), 6.1(4a)SU2, 6.1(4a), 6.1(4)SU1, 6.1(4), 6.1(3b)SU1, 6.1(3b), 6.1(3a), 6.1(3), 6.1(2)SU1a, 6.1(2)SU1, 6.1(2)

Direct upgrade:

7.1(3b)SU2, 7.1(3b)SU1, 7.1(3b), 7.1(3a)SU1a, 7.1(3a)SU1, 7.1(3a), 7.1(3), 7.1(2b)SU1, 7.1(2b), 7.1(2a)SU1, 7.1(2a), 7.1(2), 7.0(2a)SU3, 7.0(2a)SU2, 7.0(2a)SU1, 7.0(2a), 7.0(2), 7.0(1)SU1a, 7.0(1)SU1, 7.0(1), 6.1(5)SU1, 6.1(5), 6.1(4a)SU2, 6.1(4a), 6.1(4)SU1, 6.1(4), 6.1(3b)SU1, 6.1(3b), 6.1(3a), 6.1(3), 6.1(2)SU1a, 6.1(2)SU1, 6.1(2)

Direct upgrade using DMA:

none

Direct upgrade using DMA:

none

Direct upgrade using DMA:

none

Direct upgrade using DMA:

none

From this excellent doc;

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp184796

You would have to complete a "two-hop" upgrade to 6.x or 7.x as an intermediate step

FYI - many people are holding off going to CUCM 8.x due to the number of bugs.

Cheers!

Rob

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Correct Answer
Rob Huffman Tue, 08/17/2010 - 06:42

Hi Gundolf,

Sadly, there is no direct upgrade path between any 4.x CCM to

CUCM 8.x as shown below;

Table 4     Supported Cisco Unified Communications Manager Upgrades for Release 8.0(x)

Cisco Unified Communications Manager
8.0(3)
8.0(2c)SU1
8.0(2c)
8.0(1)
System Version

8.0.3.10000-8

8.0.2.41900-3

8.0.2.40000-1

8.0.1.10000-40

Release Date
Jul 27 2010
Jul 8 2010
May 6 2010
Feb 26 2010

Standard Support

Direct upgrade:

8.0(2c)SU1, 8.0(2c), 8.0(2b), 8.0(2a), 8.0(2), 8.0(1), 7.1(3b)SU2, 7.1(3b)SU1, 7.1(3b), 7.1(3a)SU1a, 7.1(3a)SU1, 7.1(3a), 7.1(3), 7.1(2b)SU1, 7.1(2b), 7.1(2a)SU1, 7.1(2a), 7.1(2), 7.0(2a)SU3, 7.0(2a)SU2, 7.0(2a)SU1, 7.0(2a), 7.0(2), 7.0(1)SU1a, 7.0(1)SU1, 7.0(1), 6.1(5)SU1, 6.1(5), 6.1(4a)SU2, 6.1(4a), 6.1(4)SU1, 6.1(4), 6.1(3b)SU1, 6.1(3b), 6.1(3a), 6.1(3), 6.1(2)SU1a, 6.1(2)SU1, 6.1(2)

Direct upgrade:

8.0(2c), 8.0(2b), 8.0(2a), 8.0(2), 8.0(1), 7.1(3b)SU2, 7.1(3b)SU1, 7.1(3b), 7.1(3a)SU1a, 7.1(3a)SU1, 7.1(3a), 7.1(3), 7.1(2b)SU1, 7.1(2b), 7.1(2a)SU1, 7.1(2a), 7.1(2), 7.0(2a)SU3, 7.0(2a)SU2, 7.0(2a)SU1, 7.0(2a), 7.0(2), 7.0(1)SU1a, 7.0(1)SU1, 7.0(1), 6.1(5)SU1, 6.1(5), 6.1(4a)SU2, 6.1(4a), 6.1(4)SU1, 6.1(4), 6.1(3b)SU1, 6.1(3b), 6.1(3a), 6.1(3), 6.1(2)SU1a, 6.1(2)SU1, 6.1(2)

Direct upgrade:

8.0(2b), 8.0(2a), 8.0(2), 8.0(1), 7.1(3b)SU2, 7.1(3b)SU1, 7.1(3b), 7.1(3a)SU1a, 7.1(3a)SU1, 7.1(3a), 7.1(3), 7.1(2b)SU1, 7.1(2b), 7.1(2a)SU1, 7.1(2a), 7.1(2), 7.0(2a)SU3, 7.0(2a)SU2, 7.0(2a)SU1, 7.0(2a), 7.0(2), 7.0(1)SU1a, 7.0(1)SU1, 7.0(1), 6.1(5)SU1, 6.1(5), 6.1(4a)SU2, 6.1(4a), 6.1(4)SU1, 6.1(4), 6.1(3b)SU1, 6.1(3b), 6.1(3a), 6.1(3), 6.1(2)SU1a, 6.1(2)SU1, 6.1(2)

Direct upgrade:

7.1(3b)SU2, 7.1(3b)SU1, 7.1(3b), 7.1(3a)SU1a, 7.1(3a)SU1, 7.1(3a), 7.1(3), 7.1(2b)SU1, 7.1(2b), 7.1(2a)SU1, 7.1(2a), 7.1(2), 7.0(2a)SU3, 7.0(2a)SU2, 7.0(2a)SU1, 7.0(2a), 7.0(2), 7.0(1)SU1a, 7.0(1)SU1, 7.0(1), 6.1(5)SU1, 6.1(5), 6.1(4a)SU2, 6.1(4a), 6.1(4)SU1, 6.1(4), 6.1(3b)SU1, 6.1(3b), 6.1(3a), 6.1(3), 6.1(2)SU1a, 6.1(2)SU1, 6.1(2)

Direct upgrade using DMA:

none

Direct upgrade using DMA:

none

Direct upgrade using DMA:

none

Direct upgrade using DMA:

none

From this excellent doc;

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp184796

You would have to complete a "two-hop" upgrade to 6.x or 7.x as an intermediate step

FYI - many people are holding off going to CUCM 8.x due to the number of bugs.

Cheers!

Rob

Jaime Valencia Tue, 08/17/2010 - 06:44

That's because there is no direct upgrade from any Windows version. You need to be in 6.1 o 7.0 for that upgrade.

Table 4     Supported Cisco Unified Communications Manager Upgrades for  Release 8.0(x)

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/compat/ccmcompmatr.html#wp184796

EDIT: once again you beat me Rob, should avoid replying until I get a cup of coffe to really wake up =)


HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

g.anders Tue, 08/17/2010 - 06:49

Hi Rob, hi Java,

many thanks for the quick answers.

Best regards

Gundolf.

bernhardczapp Tue, 10/19/2010 - 02:20

Hello all,

i've one more question regarding the upgrade 4.1(3) to 8.x.

Is there a possibility to purchase a upgrade license or do you have to buy everything new with UCL or CUWL?

So can I use the 3&3 upgrade program or is there an other possibility?

Thanks,

Bernhard

g.anders Tue, 10/19/2010 - 03:23

Hi Bernhard,

you can use the 3 x 3 offer to upgrade from 4.x to 8.0x.

Starting from the CUCM-USR you than configure into this container migration users.

Regards

Gundolf.

bernhardczapp Thu, 10/21/2010 - 01:50

That would be great because it's much cheaper.

Where did you find this information?

Thanks,

Bernhard

bernhardczapp Mon, 02/14/2011 - 00:01

It's not really a problem, is it?

The point is, that there is no DMA-Tool any longer starting with CUCM 8.x

So if you want to migrate Devicelicenses and the configuration from a windows version you have to do a 2 step upgrade.

Step 1) Use DMA-Tool to get to any Version from where you can upgrade to 8.x

Step 2) Upgrade to 8.x

Actions

This Discussion