ASA Booting Config From Flash:

Unanswered Question
Aug 17th, 2010
User Badges:

Sorry for the totally stupid question...


While in rommon reseting the password I somehow managed to get the ASA 5510 booting to an old config on the flash: drive. I searched but I couldn't see a way to set it back to boot from nvram. Can someone please help?



Thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
praprama Tue, 08/17/2010 - 09:28
User Badges:
  • Cisco Employee,

Hi,


I am assuming you restored the config from a file in the flash and not from the startup-config. You can give a "show startup-config" and check if you have the required configuration saved there.


All the best!


Thanks and Regards,

Prapanch

Praveena Shanubhogue Tue, 08/17/2010 - 17:09
User Badges:
  • Bronze, 100 points or more

Hi,


Are you saying that everytime ASA reloads, it is loading the config off of flash?? Check if you have boot config pointer like this:


boot config flash:/saved_config (do a "show run boot config" to see).


You can remove it by saying:


no boot config flash:/saved_config


Let me know if it helps.


Regards,

Praveen

wrickk_2 Wed, 08/18/2010 - 12:45
User Badges:

Thanks guys.


It was/is booting from disk0: not flash: somehow from rommon I managed to copy an old config to the startup-config. Not too big of a deal as I had a putty log with close to the latest config and was able to erase the startup and copy that back.


Thanks for your help and I'll try and stay out of rommon! =)

Actions

This Discussion