AVAYA PBX & Cisco CUCM integration

Unanswered Question
Aug 18th, 2010

Hi

We have following devices:-

CUCM 7.0

Avaya PBX 8730 server with CM 5.2

Both these devices are integrated over H.323. Avaya PBX is configured as h.323 gateway in CUCM. I am facing two problems:-

1. If Avaya phones calls Cisco IP phone, the call gets connected but the caller id is not displayed on Cisco IP phone. Cisco IP phone displays as unknown number.

2. If Cisco phone try to call Avaya phone the call does not get connected & user hear fast busy tone. In dial number analyzer tool it shows that call is getting properly routed to h.323 gateway (Avaya PBX).

Please suggest to resolve this issue.

Regards,

AJ

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.3 (5 ratings)
Loading.
Paolo Bevilacqua Wed, 08/18/2010 - 03:24

Why you think these problems are on the cisco side? They seem to be caused by the other system and their technicians should take care of.

philip.e.denton Wed, 08/18/2010 - 07:00

Paolo is right - you need to work with your Avaya compatriots to figure this out.

I'd start troubleshooting the caller ID at the source, but since there is no (Cisco) gateway to run debugs on can you verify from the Avaya side that caller ID information is being sent to your CallManager using the "Display Information Element (IE)"?

As for Cisco->Avaya call routing, if everything looks good in DNA right up to where it routes the call to the Avaya PBX I'd double-check all your configuration parameters on both sides, but pay particular attention to how the Avaya is going to accept the call.  Make sure both sides of the link match and any necessary media resources are in place.

Troubleshooting these issues is going to be difficult since you have no physical gateway between the PBXs that you can run debugs on.  I suppose if you really wanted to get down and dirty you could span one of the ports (Cisco or Avaya), run Wireshark, and see if you can pull out the H.323/H.225 call setup info.

abhasjain Wed, 08/18/2010 - 09:47

Hi,

Is there any way that I can see real time debug of call going through h.323 gateway configured for Avaya - Cisco connectivity on RTMT.

Regards,

AJ

Tommer Catlin Wed, 08/18/2010 - 09:52

Avaya has a proprietary message code or "feature" that needs to be turned on for caller ID to come across the trunk.  And they charge for this.  I forgot exactly what its called, but I know you have to pay for it and it has to be turned on.  If you do not see it in the H323 logs at the router.. then they are not sending (they being avay)

abhasjain Wed, 08/18/2010 - 09:56

Hi tcatlinins,

It will great if u can tell me that feature name.

Regards,

Abhas Jain

Paolo Bevilacqua Wed, 08/18/2010 - 10:39

Beside any technical matter, I would like to ask to the person that unfairly rated "3" two perfectly correct and helpful posts above, to avoid to do again in the future and to use better judgement when it comes to recognizing the free help received by professionals.

I also rated the posts above for what they are worth: 5 stars.

philip.e.denton Wed, 08/18/2010 - 10:46

^Thank ya, sir.

To the original poster:  Another option for information gathering would be to collect detailed traces from your CUCM cluster but detailed traces can be a beast to decode if you don't know what you're looking for.  I don't mean to be snide but the Cisco UC Troubleshooting book is really helpful with detailed trace decodes.

eramaya Wed, 04/20/2011 - 09:00

Are you poininting your Avaya syste to ip address of the publisher or the subcriber? I had a similar issue that got resolved by chaning the ip address the Avaya was pointing too. it's worth a try.

spvaidya Fri, 09/14/2012 - 03:08

Hey,

My colleague faced this similar problem and got resolved after we changed Avaya system to point to our sub.

Thanks for your input

Rgds

Actions

This Discussion

Related Content