cisco 877 and netflow

Answered Question
Aug 18th, 2010

HI all,

i have configured netflow on the cisco 877 router on the vlan interface on port 2055.  the data reaches the server only every time the router is rebooted. its a remote router with VPN configuration and sends the data back to the head office. i have googled and tried many things. didnt work. pls help

pls s see the version

Cisco IOS Software, C870 Software (C870-ADVIPSERVICESK9-M), Version 12.4(6)T6, RELEASE SOFTWARE (fc2)

Technical Support:

Copyright (c) 1986-2006 by Cisco Systems, Inc.

Compiled Fri 08-Dec-06 22:44 by kellythw

ROM: System Bootstrap, Version 12.3(8r)YI3, RELEASE SOFTWARE

router uptime is 4 days, 19 hours, 40 minutes

System returned to ROM by reload

System image file is "flash:c870-advipservicesk9-mz.124-6.T6.bin"

Last reload reason: Reload Command

I have this problem too.
0 votes
Correct Answer by jakewilson about 6 years 1 month ago

There is also a good blog on Network World regarding how to enable flexible netflow.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
jakewilson Mon, 08/23/2010 - 04:48


Can you send us a few more details?  This is sort of vague to me "the data reaches the server only every time the router is rebooted."   How long does it send before it stops? How many interfaces are active?  What does the CPU utilization look like?

tomphilip Mon, 08/23/2010 - 13:57

hi jake,

thanks for the reply.i have found the problem. the remote cisco router 877 is not sending the data over the vpn tunnel. when the router reboots it makes the vpn connection and during that time the data comes through after that it stops. i had the laptop on the remote vlan and the data was flowing i guess its the vpn config that causing the issue here. are you able to help with the config,if i post the config here

tomphilip Mon, 08/23/2010 - 14:50

hi KK,

thanks, i will try the flexible netflow.

what i tried was normal netflow

config-if)# interface vlan
config-if)# ip route-cache flow

ip flow-export destination x.x.x.x 2055

i will try the flexible one and let u know tomorrow



tomphilip Tue, 08/24/2010 - 01:58

Hi KK,

I removed all the original netflow commands and tried the flexible ones. no one of the commands are available or not recognised...


tomphilip Fri, 08/27/2010 - 01:30

thanks jake..still for some reason certain commands are unavailable on mine. as you see the first post,i am u

sing the latest IOS

tomphilip Tue, 08/31/2010 - 04:07


i have the latest IOS on the cisco 877 . still commands like flow monitor,flow records are not available. any suggestions please?


This Discussion