TUP.ini File Error

Unanswered Question
Aug 18th, 2010
User Badges:

I have Call Manager and Contact Center and installed both of them. Then i added license but i want to install CAD Client Configuration. I downloaded .exe file in CCX (Tools-->Plug-ins-->Download CAD Client Configuration) but when i open this .exe file, the program gives a error. Error is: "TUP.ini file on the server is missing a critical value for the Call Center Language."


How can i fix this problem?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Michael Turnbow Wed, 08/18/2010 - 07:33
User Badges:
  • Cisco Employee,

Hi,


I have seen this error before but in order to diagnose the issue better I really need to know the version of UCCX software you are running.  There was a defect for this issue in the 5.0x version but depending on your version it may not apply.  Let me know the version and I'll be able to comment more.


Thanks

ozcan.yildiz Wed, 08/18/2010 - 07:42
User Badges:

Hi Michael,


My UCCX version is 8.0 and Unified  Call Manager version is 6.0


Thanks.

Michael Turnbow Wed, 08/18/2010 - 07:59
User Badges:
  • Cisco Employee,

Hi Ozcan,


I'm not aware of this issue affecting UCCX 8.0 but I can tell you that your current configuration is unsupported.  CCX 8.0 is not compatible with CUCM 6.0.  I would not be surprised at all if this is the root of your issue.  Even if it is not at the root of the issue, this setup will cause you many problems since CCX 8.0 was never designed to work with CUCM 6.0.


The compatibility guide is here:  http://www.cisco.com/en/US/docs/voice_ip_comm/cust_contact/contact_center/crs/express_compatibility/matrix/crscomtx.pdf


As far as that particular error is concerned though it sounds like the CAD configuration tool needs to be run again but first the system needs to be set back to a fresh install state (which allows you to go through the setup again and choose the language options).  This can only be done by TAC so I suggest you open a case for that.


TAC will likely not be able to assist with your current configuration though so I advise to upgrade the CUCM to a supported version first.


Thanks


Mike


Be sure to rate this post if the information is helpful.

m.moloney Thu, 08/11/2011 - 07:26
User Badges:

I have installed ccx 8.5.1 and cucm 8.5.1 and I am having the same problem with the TUP.ini error message when trying to run the client configuration tool.  This is a new install not an upgrade. Any ideas?

Michael Turnbow Thu, 08/11/2011 - 10:22
User Badges:
  • Cisco Employee,

If this is HA make sure you are pointing to the Node1 or Publisher IP address in the tool, not node 2.  Also, what language setting are you currently using on the server?

m.moloney Thu, 08/11/2011 - 10:36
User Badges:

This is not HA. I have cucm on one server and cuccx on another.  The language should be english.

Michael Turnbow Thu, 08/11/2011 - 10:42
User Badges:
  • Cisco Employee,

The only other suggestion I have at this point is open a TAC case.  I am not aware of any other fixes for this issue.

rschwendeman Mon, 10/10/2011 - 15:13
User Badges:

Did you get your issue resolved.  I am having the same issue with 8.5

m.moloney Tue, 10/11/2011 - 05:15
User Badges:

The only thing that fixed it was re-installing it. I found that my rmuser was an end user not an application user, so checking that may be the fix you are looking for.

qpippen Thu, 02/09/2012 - 11:05
User Badges:

Had the same issue with UCCX 8.5SU2 with my system language in french and CSD/CAD in french...


So I switched to english, then I was able to package the CSD/CAD correctly


Then I reswitched back to french and everything was ok


good luck

prashraj Thu, 02/09/2012 - 16:15
User Badges:
  • Cisco Employee,

Hello,


Please try the following for the UCCX 8.5 system


-From the CLI run the following command

-The output should display in this format

command to be run  =  show uccx cad prefs SiteSetup

-For the CALLCENTERLANG=

-Check the value if none present

-Enter this from the CLI

"set uccx prefs SiteSetup CALLCENTERLANG 1033"

-RESTART the server

-check the command line again by running the

show uccx cad prefs SiteSetup

-it should update

-try the process again if it doesnt work

-

add CALLCENTERLANG=1033 to the TUP.ini file manually and try running Configuration tool


Let me know if this works


Thanks,

Prashanth

reena.mundary Wed, 02/15/2012 - 20:32
User Badges:

Hi Prasanth,


I have faced the same TUP.in error. When I tried to do what ever you mentioned I found CALLCENTERLANG is blank. I tried to run the command  "set uccx prefs SiteSetup CALLCENTERLANG 1033" , but its saying no valid command entered.


Can you plz help..


Thanks in advance.

prashraj Fri, 02/17/2012 - 09:54
User Badges:
  • Cisco Employee,

Hi Reena,

Please run the following command

show uccx cad prefs SiteSetup

this wil give you and output

scroll down and check what the valye of the CALLCENTERLANG Is set to now

-if its nots set then run the command if it fails

-I would suggest open up a TAC case for assistance


Thanks,

Prashanth

NRichie_2 Sat, 02/16/2013 - 10:35
User Badges:

The actual command should be

set uccx cad prefs SiteSetup CALLCENTERLANG "1033"

aniramac Tue, 10/22/2013 - 18:42
User Badges:

Switching to another language is not a good idea.

Please check CallCenterLang using https:///TUP/CAD/Maintenance/TUP.ini or show uccx cad prefs SiteSetup

.

You can use the set uccx cad prefs SiteSetup CallCenterLang "1033" to set it to en_US, and check once again. If not, please contact TAC and we will edit the TUP.ini file for you.



Thanks & Regards,
Anirudh
"Protocol, then product"

Actions

This Discussion