VOIP Monitor Never Works

Unanswered Question
Aug 18th, 2010

I setup it up exactly as it shows here:

http://www.cisco.com/en/US/products/sw/voicesw/ps556/products_tech_note09186a00801a62a8.shtml

I run Postinstall on the voip monitor server and make sure my sniffer NIC is chosen.

I checked Cisco Desktop Administrator and make sure VOIP Monitor is set to the correct server.

Configured RSPAN as follows:

Source switches (where phones connected)

!

vlan 99

remote-span

!

monitor session 1 source vlan 60 rx (Note, this is my voice vlan)

monitor session 1 destination remote vlan 99

!

Destination switch (where VOIP monitor servers connected)

!

monitor session 1 destination interface Fa0/4

monitor session 1 source remote vlan 99

!

Volume is up, sound card works great but I still didn't hear nothing.

So I'm not sure what I missed here. Any suggestions on where I should be looking at to troubleshoot this issue would be greatly appreciated.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Wed, 08/18/2010 - 14:14

Hi

A couple of suggestions:

1) You need to span the rx and tx source traffic, unless you just want to hear one side of the conversation

2) Run a network monitor trace on the server while a conversation is in progress and ensure you can see the RTP traffic to verify your RSPAN config. You can save a cap from the MS Net Mon that is installed by default and analyse in something nicer like Wireshark...

Regards

Aaron


Please rate helpful posts...

ktran-anet Wed, 08/18/2010 - 14:45

Thanks for your recommendation Aaron.

Just a another note, I did a sh int f0/4 (which is my RSPAN destination port) and it's showing me lots of output packets and 0 input packets. Does it look like an RSPAN issue?

Aaron Harrison Thu, 08/19/2010 - 00:40

Hi

No - SPAN destination ports are intended to transmit a copy of the SPAN traffic OUT (i.e. copy traffic from phones to server). A SPAN port doesn't allow inbound traffic by default, and it's only really in some circumstances you would want it to. In this example the SPAN port doesn't need to allow inbound traffic, as the second port on the UCCX server is dedicated to sniffing only.

The best way to verify whether SPAN is working is to look at the packets... on smaller switches it can be a little unstable when you are configuring this feature; I've seen lots of cases where a valid configuration didn't work until the switch was rebooted.

Regards

Aaron

Hi,

I've setup recently a similar monitoring for one Customer.I'm giving the command summary for your setup...

##############################

Switch-X (where VOIP monitor servers connected)
vlan 99
remote-span

interface GigabitEthernetx/y
****Description 2nd NIC of IPCC Server********
switchport
switchport access vlan 99
switchport mode access

monitor session 1 destination interface Gi2/6
monitor session 1 source remote vlan 99

##############################

Switche-Y (where phones connected)

vlan 99
remote-span

monitor session 1 source interface Fa0/4 (or monitor session 1 source vlan 60**if you want monitor all the phone***)

monitor session 1 destination remote vlan 99

##############################
Points to remember

The span to PC , PC Port,PC VLAN access  are enabled in the phone  settings in call manager
Phone should be in the same Vlan of IPCC/VOIP Monitor Server e.g  Voice Vlan 60

Agent should login thorugh CAD software,IPPA doesn't work properly

Agent desktop lan cable should connected from Phone's PC port

Plz rate if it works(it should work)

Aaron Harrison Thu, 08/19/2010 - 00:48

Hi


That is a very confusing post...

interface GigabitEthernetx/y
****Description 2nd NIC of IPCC Server********
switchport
switchport access vlan 99
switchport mode access

     - It doesn't matter what VLAN this port is in; a SPAN destination port not enabled for ingress traffic isn't a member of any specific VLAN and just replicates SPAN traffic out...

The span to PC , PC Port,PC VLAN access  are enabled in the phone  settings in call manager

     - These settings are only relevant if you are doing Desktop Monitoring, not SPAN monitoring


Phone should be in the same Vlan of IPCC/VOIP Monitor Server e.g  Voice Vlan 60

     - Doesn't matter; both Desktop Monitoring and SPAN(with careful SPAN config) can work with different VLANs for phones/servers

Agent should login thorugh CAD software,IPPA doesn't work properly

     - Both work fine. IPPA can be recorded only with SPAN; CAD supports SPAN and Desktop Monitoring

Agent desktop lan cable should connected from Phone's PC port

     - Again, confusion between SPAN and Desktop Monitoring. Phones/PCs daisy chained together is only required for Desktop Monitoring.

Basically you need to decide whether to use SPAN or Desktop Monitoring. If you have CAD agents only, generally Desktop Monitor is the best choice as it doesn't require SPAN which can be complex to set up especially in larger/distributed contact centres. SPAN should be used where you have to use it due to compatibility issues with PCs (which is a lot rarer than documents suggest) or you use IP Phone Agents.

Regards

Aaron

Please rate helpful posts....

Hi Aron,

Welcome for your maked comments..it's make me clear a few points too.

***Phone should be in the same Vlan of IPCC/VOIP Monitor Server e.g  Voice Vlan 60******it's recommended by CISCO Tac engineer when we opened a TAC case .

The span to PC , PC Port,PC VLAN access  are enabled in the phone  settings in call manager******-When PC to SPAN is not selected monitoring doesn't work in our setup

Yes it's true      - Both work fine. IPPA can be recorded only with SPAN; CAD supports SPAN and Desktop Monitoring..

We also tried IPPA login in SPAN monitoring..but lot of noise are coming...and when tested with CAD monitoring was perfect without noise.

Also for rest of the configuration we have done lot of tesing with cisco engineer which not worked.

What I've post It's running properly without any fail in our setup.

I need to check all you have pointed out.However thanks for your comments

Aaron Harrison Thu, 08/19/2010 - 02:06

Hi

Sounds to me like you are using Desktop Monitoring then; otherwise SPAN-to-PC wouldn't affect it.

It also sounds like you should queue your case to a better TAC engineer :-)

Regarding the noise when SPANning IPPA - this is probably due to a SPAN misconfig. For example, if you SPAN a VLAN rather than the edge ports, you can end up with a config where you SPAN the voice conversation twice - once on the edge port, and once (or more) as the RTP stream passes over a trunk link. THis means you get each packet twice or more at the server, and you get poor quality as a result.

CAD works OK in your setup as the SPAN traffic is being ignored and the system is using CAD to do the monitoring.

If not being able to monitor IPPA is a problem for you, open a new thread detailing your switch topology and configuration. Otherwise, just get everyone using CAD, use Desktop Monitoring, and delete your SPAN config as it's just fillingup your network with unnecessary traffic!

Regards

Aaron

Actions

This Discussion