Problem with WAP4410N & Cisco 7921G

Unanswered Question
Aug 18th, 2010

I have 2 7921G phones registered to a CUCM 7.1.5 server through a WAP4401N V2 running 2.0.2.1



PID VID:WAP4410N-A V02
Software Version:2.0.2.1


Inbound signalling to these phones experiences serious delays - a phone that is 8-10 feet from the AP (i.e. 5 bars, full signal, etc) will experience a several second delay in starting to ring on an inbound call(as compared to a 7961 sitting right next to it), and after the call is answered on the hardphone the 7921 will continue to ring an additional 10-20 seconds.


Taking the 7921 offhook is immediately indicated on the 7961, so the delay seems to be entirely from the wired network out to wireless clients.


If I home the phones thorugh a buffalo 54g AP, the phones are as responsive as a 7961, the problem is absolutely localized to the WAP4410N.


When is a firmware coming that will fix it.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jimander Mon, 08/23/2010 - 15:12

I have collected more information now - as near as I can tell the WAP4410N is very bad at remembering its list of active clients that are associated to it because I only see traffic being sent out from the WAP in the 1-2 seconds immediatly following some wireless client initiated traffic.


I have wireshark captures spanned from the wired port of the 4410N and then taken at the same time from the wireless network via AirPcap and there is sometimes a delay of as much as 28 seconds between when a packet arrives at the 4410N and when it is seen in the air. An idle 7921G by default does a keepalive heartbeat with CallManager every 30 seconds- the only time you see any traffic in the air headed for the phone is immediately after one of these phone initiated heartbeats. The rest of the time the traffic is just sitting inside the WAP4410N queued up and waiting for the WAP to send it.


If anyone would like to see the wireshark caps I can post them here.


Has anyone else experienced problems like this one where they see severe delays in traffic headed towards the wireless client devices? I realize this is a bit unusual because most of the time the typical wireless device (a laptop) is constantly going to be sending traffic out to remind the WAP that it is still there.

pierattini Thu, 09/02/2010 - 09:49

I've exactly the same issue. Did someone come out with a solution?

jimander Thu, 09/02/2010 - 18:44

It seems they introduced a new 'feature' in 2.0.2.1. WMM Power Savings. Try this:


1.Enable SSH management

2, SSH to the WAP

3. issue the command 'wmmps disable' and 'apply'


It seems to have fixed my issue- now I get about 250ms delay on ring start as opposed to the 10-20 seconds from before.


Let me know if it works for you.

Actions

This Discussion