BGP Load Sharing dual ISPs

Unanswered Question
Aug 18th, 2010
User Badges:
I have a multihomed BGP connection to the internet. Two different providers. I'm trying to setup load sharing in order to send some traffic on each link. I found the documentation on Cisco's web site. My question is this.
If one of the links went down, would the other link pickup and route for the link that went down automatically...? I don't want to reconfigure the route map to send all the traffic to one ISP or the other if there is an outage on a particular link.

Thanks.
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
kyukim Wed, 08/18/2010 - 14:47
User Badges:
  • Cisco Employee,

Hi,

It will automatically failover to anther link and failback to loadsharing if link is up again If you configure using a config example #4 from http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a00800945bf.shtml#conf4


All routing decision is based on BGP path selection decision and you will have load-sharing and redundancy at same time with below config example.


interface Serial 0

ip address 160.20.20.1 255.255.255.0

no ip route-cache


interface Serial 1

ip address 150.10.10.1 255.255.255.0

no ip route-cache


router bgp 11

neighbor 160.20.20.2 remote-as 10

neighbor 160.20.20.2 route-map UPDATES-1 in


!--- This allows only the networks up to 128.0.0.0.


neighbor 150.10.10.2 remote-as 12

neighbor 150.10.10.2 route-map UPDATES-2 in


!--- This allows anything above the 128.0.0.0 network.


auto-summary


route-map UPDATES-1 permit 10

match ip address 1

set weight 100


route-map UPDATES-1 permit 20

match ip address 2


route-map UPDATES-2 permit 10

match ip address 1


route-map UPDATES-2 permit 20

match ip address 2

set weight 100


access-list 1 permit 0.0.0.0  127.255.255.255

access-list 2 deny 0.0.0.0 127.255.255.255

access-list 2 permit any

Actions

This Discussion

Related Content