RME 4.3.1 on new server - 2 issues with Inventory and syslog

Unanswered Question
Aug 19th, 2010

Hi,

I recently installed new server 2003 with LMS3.2 and after the problems with DevicePackages i resubmitted all device and the device center tasks that was missing now reappeared.

So I went on and added my two VPN3030 VPN Concentrators.

This device is supported for RME inventory and syslog

I got the config-archive running (!) so thats fine (Runs via HTTPS login)

I have two issues:

1. I can not get inventory to work .

I have communication going, and a packet trace/sniff show I have syslog going into RME and i see SNMP GET and respones to/from device

I see some java error logs in ic_server.log fil

I have tried with two different LMS32-servers

I have increased SNMP timeout etc

I tried deleted the device and rediscover

log are like this:

[ Thu Aug 19  10:12:30 CEST 2010 ],ERROR,[Thread-14],com.cisco.nm.rmeng.inventory.ics.core.CollectionController,761, Collection failed for the device : 3748
com.cisco.nm.xms.xdi.ags.system.CollectionFailed: com.cisco.nm.lib.snmp.lib.SnmpException: SnmpResponseNoSuchName on 10.3.6.2 while performing SnmpWalk(*) at index = 10
    at com.cisco.nm.xms.xdi.pkgs.LibInventory.PortInterfaceAGI_RFC1213_HelperMethods.getIfTableEntriesFromDevice(PortInterfaceAGI_RFC1213_HelperMethods.java:639)
    at com.cisco.nm.xms.xdi.pkgs.SharedInventoryVPN3000.PortInterfaceAGI_RFC1213_Mib.g$eval(PortInterfaceAGI_RFC1213_Mib.java:77)
    at com.cisco.nm.xms.xdi.ags.PortInterfaceAGI.g$eval(PortInterfaceAGI.java:21)
    at com.cisco.nm.xms.xdi.SdiEngine.initAndEvalAGIs(SdiEngine.java:383)
    at com.cisco.nm.xms.xdi.SdiEngine.request(SdiEngine.java:309)
    at com.cisco.nm.xms.xdi.SdiEngine.getDevRepr(SdiEngine.java:302)
    at com.cisco.nm.rmeng.inventory.ics.core.CollectionController.run(CollectionController.java:539)
    at java.lang.Thread.run(Thread.java:595)

[ Thu Aug 19  10:12:30 CEST 2010 ],INFO ,[Thread-14],com.cisco.nm.rmeng.inventory.ics.core.CollectionController,841,Device collection failed for 10.3.6.2

2.:I can not get syslog into the devices syslog reports

This is wierder than issue 1: I have two VPN3030, one actually does syslog fine, but one VPN 3030 does not

I havent done any thing different for the two device ...

one simply works, one doesnt ...

I get no syslog msg in device center for one of the device.

The syslogs ARE infact in the syslog.log

The syslog msg DO show up, but in Unexpected device report  ...

The same VPN device does work with my second server so I think this is related to RME database on one specific server.

But i have tried delete device and rediscover etc ...

please help ...

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 08/20/2010 - 21:45

The inventory issue is CSCtb06637.  There is a patch available from TAC that will fix this. 

As for the syslog issue, check the address from which the syslogs are being sent, and make sure that is the address by which RME is managing the concentrator.

mbilgrav Mon, 08/23/2010 - 01:58

ok - looks like i need TAC again ...

As for the syslog issue - this happens only for one device on one of my servers ...

That is what is strange ... So IP is coorect and ok - (they do get syslogs into DevCenter on one server and on other device)

Thank you for your reply - really nice that you take your time into this forum !

mbilgrav Mon, 08/23/2010 - 08:03

I software updated today, and now the VPN gets syslogs in device center, like the other VPN devices ...

beats me ...

But case closed !

Thx again

Actions

This Discussion