PPP Authentication not working

Answered Question
Aug 19th, 2010
User Badges:

Hi,
I have configured two router R1 & R3 for ppp one way authentication. R3 calls into R1 for one way authentication however the serial interface does not seem to come up.


Can u help me with this. I have attached the config too with the debug outputs.


Thanks in advance.


Regards,


Ryel

Correct Answer by Peter Paluch about 6 years 10 months ago

Hi,


Remove the line ppp authentication pap callin from the R3 Serial1/2 configuration and try again.


Best regards,

Peter

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Correct Answer
Peter Paluch Thu, 08/19/2010 - 03:39
User Badges:
  • Cisco Employee,

Hi,


Remove the line ppp authentication pap callin from the R3 Serial1/2 configuration and try again.


Best regards,

Peter

KARUPPUCHAMY MA... Thu, 08/19/2010 - 03:46
User Badges:
  • Silver, 250 points or more

Thanks peter.


I have tested in my test lab and its working


R2#sh run int s1/1
Building configuration...

Current configuration : 188 bytes
!
interface Serial1/1
ip address 170.10.12.2 255.255.255.240
encapsulation ppp
serial restart-delay 0
no dce-terminal-timing-enable
ppp pap sent-username test password 0 test123
end

R2#



R1#sh run int s1/0
Building configuration...

Current configuration : 141 bytes
!
interface Serial1/0
ip address 170.10.12.1 255.255.255.240
encapsulation ppp
no dce-terminal-timing-enable
ppp authentication pap
end

R1#



Thanks

Samy

paolo bevilacqua Thu, 08/19/2010 - 04:01
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

As always when working with PPP problems:


- Collect "debug ppp negotiation" and "debug ppp authentication" with "term mon".


Before asking others what could be wrong.


Note: do NOT use attachments for small files. Paste directly into text.

Actions

This Discussion