VPN Agent Service not responding?

Unanswered Question
Aug 20th, 2010
User Badges:

Installed Cisco AnyConnect VPN on a Windows 7 Professional laptop. However, as soon as I start the application, I receive the error:

"The VPN Agent Service is not responding. Please restart this application after a minute."

No matter how many times I restart the application, or uninstall and reinstall, I still receive this error. I really need help to solve this problem! Any help will be greatly appreciated. Thank you.


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Praveena Shanubhogue Sat, 08/21/2010 - 09:36
User Badges:
  • Bronze, 100 points or more

Hi Sanjay,

Assuming that you are using the latest anyConnect application, few question here:

-- did you install it as an administrator AND running it as an administrator?

-- make sure the antivrus or any 3rd party firewall is not causing the issue.

-- And when u uninstall, make sure all the files from AnyConnect installation directory are deleted (if not, delete them manually).

Let me know hot it goes.



Atri Basu Sun, 08/22/2010 - 08:50
User Badges:
  • Cisco Employee,

Hey Sanjay,

The error message you've mentioned is normally seen when certain features like SBL or Always on is enabled. Do you have any of these features enabled? Also could you try downloading the standalone Anyconnect version with the DART bundle and installing that? For more information regarding DART please refer to the following link:


Once we have the DART files please open a TAC case and attach the DART files to the case. It'll be easier to diagnose why you are getting this error message.



Larrie269 Fri, 10/07/2011 - 06:47
User Badges:

It sounds like you need to start your VPN service. Open Services (under Administrative Tools in Control Panel in XP, not totally sure where in 7...) and scroll down to Cisco AnyConnect VPN Agent and start that. You may need to change its Startup Type to Manual or Automatic if it is Disabled before it will allow you to start it. Hope that fixes things for you.

jnmacdonald Wed, 10/26/2011 - 12:43
User Badges:

I'm getting this same error on Mac 10.7 Lion:

The VPN agent service is not responding.  Please restart this application after a minute.

How do i fix this?

rajeshatbuzz1 Wed, 11/16/2011 - 02:19
User Badges:


While using CISCO ANYCONNECT VPN client, i get following message

The VPN agent is not responding.Please contact your IT administrator for assistance.

i find cisco services is running fine. I un-installed and installed many  times but same issues. plz suggest what need to be done.

Also, I sanned the Ful machine i could not find what is the problem it it?

jerrynithu Tue, 04/28/2015 - 10:27
User Badges:

This is a perfect response and it worked for me.

Thank god, I referred to this post before my attempt to uninstall and reinstall the app.

datacureinc Tue, 02/19/2013 - 07:07
User Badges:

I had this problem,.. What happened was I had reverted the ASA back to a previous configuration where Anyconnect 2.5 was at the top of the list for web-deployment and I inadvertently downloaded it,.. The next time I tried connecting with the already installed version 3.1 I got the VPN agent is not responding message even though it showed running in services.  So I believe the two versions were competing for the socket at the same time (who knows) but I uninstalled both versions, rebooted my WIndows 8 laptop and reconnected to the WebUI and pulled 3.1 down fresh again.... And Viola!  It works again with no errors.  I did not do anything else so I am 100% sure for me that it was the competing versions trying to grab the service

jawad-mukhtar Tue, 02/19/2013 - 11:42
User Badges:
  • Silver, 250 points or more

The AnyConnect VPN service does not start automatically. The error message "

VPN Service not available. The VPN agent service is not responding. Please restart this application after a minute

" means, that the Cisco AnyConnect VPN service currently is not running. This could be caused by a Windows boot accelerator software, that modifies the start order of the Windows services in a way, some services cannot be started anymore. In the past such problems were caused by e.g.

Lenovo Rapid Boot

. After uninstalling such softwares, the problem should be solved.

jniblack Fri, 03/22/2013 - 21:48
User Badges:

I had this error when after rebooting my Windows 7 machine which was running on VMware Fusion.  I noticed that the boot was very slow, due to programs running on the Mac side of my computer.  When I stopped the Mac programs and rebooted the Windows 7 machine again in a normal manner, AnyConnect was working fine and there was no "VPN Service not available" message.

mguguvcevski Wed, 11/20/2013 - 08:19
User Badges:

I had a similar error, saying that the

cisco anyconnect vpn agent is not able to create interprocess communication depot

when starting the service and that the

vpn service is unavailable.

The problem was the Internet Connection Sharing between my LAN and wireless adapter.

Once I disabled this, I was able to start the VPN service normally and everything worked as it should.

VPNUser5001 Wed, 02/11/2015 - 14:26
User Badges:

I had the same issue. Spybot Search and Destroy on my PC adds address to the c:\windows\System32\etc\HOSTS file. It seems that Cisco VPN does not look at the bottom of this big list, must only look down a finite amount of lines. I moved my Cisco VPN addresses to the top of the HOSTS file with all the other stuff after, and it works. You will need to use administrator writes to update the file and change it from read only to save.

Atri Basu Wed, 02/11/2015 - 16:03
User Badges:
  • Cisco Employee,

Indeed the client only looks within a finite range. I am not sure if an enhancement request has been filed for this. Would you be willing to send me a DART file from a machine with this problem? Along with a copy of the hosts file?

VPNUser5001 Wed, 02/11/2015 - 16:16
User Badges:

I have attached my HOSTS file, I changed my companies IP address at the bottom. Not sure where the DART file is so I excluded that.

Atri Basu Thu, 02/12/2015 - 08:01
User Badges:
  • Cisco Employee,

You'll have to generate the DART bundle. For more information on using the DART tool have a look at Using DART . To install the DART tool on your machine directly(not through the ASA) do the following:

1. download the web deploy pkg file from cisco.com for your OS

2. unzip or unarchive that file and look in the binaries folder

3. there will be an installer with DART in the name. install that file.


Now you should be able to run the diagnostic tool

asharsidd Wed, 05/04/2016 - 16:36
User Badges:

I have had this problem today where my Cisco Anyconnect VPN stopped working. It was working all fine until my home broadband hung and rebooted itself. I restarted the PC but Cisco Anyconnect won't come up. I was having errors like "VPN Service is not available. Exiting", "Lost connection to Cisco VPN Service. Restart application". When I went into Services > Cisco AnyConnect Secure Mobility Agent> it was stopped. I sarted it but it went down again in few seconds. It came up and then went down again as if in a loop.I searched the whole internet where I can find a solution to this problem but none of the tips worked for me. I even restored my PC a week back but had no joy. Same VPN service issue and Anyconnect complaining that it has lost connection to VPN service. This is how I resolved the issue and I thought to put it here so someone else don't waste hours like I did to find a solution:

1) Un-install Cisco AnyConnect VPN

2) Unistall any registry cleaner softwares like CCleaner, Lenovo Rapid Boot etc.

3) Make sure the Cisco AnyConnect adapter has disapperared from Device Manager > Network Adapters

4) Delete the folder C:\Program Data\Cisco\Cisco Anyconnect Secure Mobility Client

5) Restart PC

6) Install Anyconnect Software

7) Restart PC

8) It should work as normal now

and after searching almost everywhere on internet this is how I resolved the issue.

This worked for me to stop and then start the VPN Service on my Mac.

sudo launchctl stop com.cisco.anyconnect.vpnagentd com.cisco.anyconnect.aciseagentd com.cisco.anyconnect.ciscod

sudo launchctl start com.cisco.anyconnect.vpnagentd com.cisco.anyconnect.aciseagentd com.cisco.anyconnect.ciscod

After running these two commands i was able to start my cisco any connect without issue.



This Discussion

Related Content