NAT both directions - Duplicate IP detected

Unanswered Question

Hi there,

I have a customer with a IP PBX which must stay on a specific IP subnet /24 and a specific Default gateway of the the SIP circuit router .252. Unfortunately this is not the address of their LAN and they would like to have their IP phones be able to see the phone system and browse to the systems gui. The PBX also needs to talk to the Mail server to deliver vmail. The telco is difficult to deal with and the customer doesnt want to ask them to put in a static route to the internal lan /16.

I offered to put in a 851 router between the two networks with the idea of nating in both directions so that to the PBX the phones appear to be on the same subnet and vice versa. However when I tried this I kept on getting duplicate IP addresses for the mail server and for the PBX. At the time I had a very short window to try this out and didnt have a lot of prep time to work out the config.

Here's my config that thought would work: is the PBX is the IP Address allocated for the PBX on the Internal LAN, is the mail server and is what it hould appear as on the VOIP LAN.

interface FastEthernet4
description LAN network
ip address
ip nat outside
interface Vlan1
description VOIP network
ip address
ip nat inside
ip route
ip nat pool VOIP netmask
ip nat outside source list 100 pool VOIP
ip nat inside source static

ip nat outside source static
access-list 100 remark NAT list
access-list 100 permit ip any

Does this make sense? Any suggestions gratefully received.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nagaraja Thanthry Mon, 08/23/2010 - 08:33


From the configuration you have provided, it seems like the mail server IP

is also part of the VoIP pool you have created.

ip nat pool VOIP netmask

ip nat outside source static

Can you change your VOIP pool such that .128 address is excluded and see if

that helps?




This Discussion

Related Content