cisco 851w router - "WARNING: Flash erase failed"

Unanswered Question
Aug 23rd, 2010

Hello everybody,

I just bought a Cisco 851w and while I was trying to do a password recovery on it got this message "WARNING: Flash erase failed". I am desperate, I have tried everything, the break key doesn't work during bootup. It doesn't let me get to the CLI nor the rommon. Please help. Thank you.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Nagaraja Thanthry Mon, 08/23/2010 - 18:33


You should be able to break into the ROMMON mode when you turn off the router and turn it back on (within first 60 seconds). Hit break button repeatedly. This should bring you to ROMMON mode.

Hope this helps.



ubaldodd86 Tue, 08/24/2010 - 08:29

Thanks for the reply...and yes I was able to get into ROMON mode. formatted flash: and did an xmodem transfer with new IOS. However, when I reset the router I still get the message "WARNING: Flash erase failed" and the CLI freezes. Please if anyone has seen this before let me know.

Thank you,

Nagaraja Thanthry Tue, 08/24/2010 - 10:10


If you are getting that error message even after formatting the flash in

Rommon, you might be looking at a bad hardware. If the device is under

warranty, open a case with Cisco TAC and request replacement.




This Discussion