Catalyst 6509 goes to Rommon after every reload- even with correct bootstring

Answered Question
Aug 23rd, 2010

I have a 6509 (Sup 720-3B) that upon reboot- just goes straight to the Rommon prompt.  I've done everything according to the following article:

http://www.cisco.com/en/US/products/hw/switches/ps700/products_tech_note09186a008015bfa1.shtml

All of the information shows correct - even on the set printout on the rommon upon reboot, and once the router is booted.  When you get to the rommon port- all you have to type is boot and it does.  It just looks like autoboot is not on.  Any ideas?


Greg

I have this problem too.
1 vote
Correct Answer by Atif Awan about 6 years 5 months ago

It should be 2102. Can you try setting it again on the RP and then save the config and rerun the 'remote command switch show bootvar' command. If it shows 0x2102 at next reload then I believe it should fix it. I dont exactly recall how I fixed it but I am sure if this is not the correct way someone else will provide you with the exact answer :- ).

Atif

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Atif Awan Mon, 08/23/2010 - 09:56

I have seen a similar issue in past but that was a mismatch in config register between RP and SP. I am assuming once it boots correctly you have verified that the config registers are same on both the RP and SP using the 'remote command switch show bootvar' or 'remote command switch show ver' commands?

gregwoodson Mon, 08/23/2010 - 09:59

DAL-COLO-6509-1#remote command switch sh ver

Cisco IOS Software, s72033_sp Software (s72033_sp-ADVIPSERVICESK9_WAN-M), Version 12.2(33)SXH7, RELEASE SOFTWARE (fc3)

Technical Support: http://www.cisco.com/techsupport

Copyright (c) 1986-2010 by Cisco Systems, Inc.

Compiled Thu 11-Mar-10 21:08 by prod_rel_team

ROM: System Bootstrap, Version 8.5(3)

DAL-COLO-6509-1 uptime is 52 minutes

Time since DAL-COLO-6509-1 switched to active is 51 minutes

System returned to ROM by reload at 15:32:43 CDT Fri Aug 6 2010

System restarted at 11:06:23 CDT Mon Aug 23 2010

System image file is "bootdisk:s72033-advipservicesk9_wan-mz.122-33.SXH7.bin"

cisco Catalyst 6000 (R7000) processor with 983008K/65536K bytes of memory.

Processor board ID SMG0623A04J

SR71000 CPU at 600Mhz, Implementation 0x504, Rev 1.2, 512KB L2 Cache

Last reset from s/w reset

144 FastEthernet interfaces

34 Gigabit Ethernet interfaces

1917K bytes of non-volatile configuration memory.

8192K bytes of packet buffer memory.

500472K bytes of Internal ATA PCMCIA card (Sector size 512 bytes).

Configuration register is 0x2100

gregwoodson Mon, 08/23/2010 - 10:00

DAL-COLO-6509-1#remote command switch sh bootvar

BOOT variable = bootflash:s72033-advipservicesk9_wan-mz.122-33.SXH7.bin,12;

CONFIG_FILE variable does not exist

BOOTLDR variable =

Configuration register is 0x2100

Correct Answer
Atif Awan Mon, 08/23/2010 - 10:05

It should be 2102. Can you try setting it again on the RP and then save the config and rerun the 'remote command switch show bootvar' command. If it shows 0x2102 at next reload then I believe it should fix it. I dont exactly recall how I fixed it but I am sure if this is not the correct way someone else will provide you with the exact answer :- ).

Atif

gregwoodson Mon, 08/23/2010 - 10:46

This fixed the issue.  The different config registry wasnt showing up on the Route Processor- so this fixed the issue.

Thanks

Greg

Edison Ortiz Mon, 08/23/2010 - 10:28

In global configuration mode, issue the config-register 0x2102 command, and set the configuration register to 0x2102 for both the RP and the SP.

6500_SW1(config)# config-register 0x2102

6500_SW1(config)# end

To verify the configuration register value at the next reload, issue the show bootvar command.

6500_SW1# show bootvar

BOOT variable = "bootdisk:s72033-advipservicesk9_wan-mz.122-33.SXH7.bin"

CONFIG_FILE variable =

BOOTLDR variable =

Configuration register is 0x2102

verify that the configuration register on the SP also changed.

6500_SW1# remote command switch show bootvar

BOOT variable = "bootdisk:s72033-advipservicesk9_wan-mz.122-33.SXH7.bin"

CONFIG_FILE variable =

BOOTLDR variable =

Configuration register is 0x2 (will be 0x2102 at next reload)

Reload the switch for the new SP configuration register setting to take effect.

Actions

This Discussion

Related Content