WCCP with multicast for dynamic services

Unanswered Question
Aug 23rd, 2010
User Badges:

I'm trying to configure WCCP forwarding of HTTPS traffic with a multicast group.  The group-listen configuration option doesn't seem to be taking effect for numeric service_ids.  To eliminate problems with the web-caches I tried ping-testing, and the routers respond on any address configured with web-cache, but none configured with any numeric service ID.  I've searched the support pages and release notes, but have found no mention of this behavior for our test routers (800 series running 12.4(22)YB) or any other router/IOS combination.


example config:

ip wccp web-cache group-address 224.100.100.101 password password


ip wccp 70 group-address 224.100.100.102 password password


In the above configuration pings to 224.100.100.101 are responded to by the router's unicast address, where pings to 224.100.100.102 are not responded to at all.  WCCP in all-unicast mode works with HTTP and HTTPS, and with HTTP in multicast.   I can update the router's firmware if this will help, but since there is no mention of this issue in any documentation I don't want to just randomly mess with my firmware in hope of a solution.  Has anyone seen this behavior before?  Found a solution?


thanks!


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
dclendenan Mon, 08/23/2010 - 11:46
User Badges:

OK, so after I ask for help I find the obvious solution. 


I'd added ip wccp 70 group-listen on the wrong interface. 


Working config, for the next guy to fall off this bridge:



...


ip wccp web-cache group-address a.b.c.d password password

ip wccp 70 group-address a.b.c.d password password

...


interface TheCorrectInterface1
ip address x.x.x.x y.y.y.y
ip wccp web-cache redirect out
ip wccp web-cache group-listen
ip wccp 70 redirect out
ip wccp 70 group-listen
...

Actions

This Discussion

Related Content