WAP2000 and iPhone connectivity issues?

Unanswered Question
Aug 23rd, 2010

I have several WAP2000 (Firmware 2.0.0.5), and while they work fine for PC's, iPhones, iPod touches cannot connect to them.

Well, they connect briefly, get an IP address from the router, and immediately drop the connection to re-connect again.

I have tried changing channels, eliminating all but one of the AP's, and so forth.

Has anyone else had issues with this firmware?  I see posts where people are saying their iPhones connect up fine.  This happens on versions 3.x and 4.x of the iphone O.S.  It's not limited to one iphone or ipod touch; we've tried several.

If anyone else is running 2.0.0.5 of the firmware and they are having success with an iphone, can you please tell me your settings?

Thanks in advance!

--Greg

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
wittregr Thu, 08/26/2010 - 06:04

Greg,

I think I have the same problem but with a Blackberry Storm 2.  (I posted in the last two days--Look for WAP2000 and Storm 2)  I see the Storm 2 connect successfully to the WAP2000 but then never establish a connection to the Blackberry Enterprise Server (BES)...Necessary to do anything useful with a Blackberry device.  A few months aga (Before I had my Storm 2) I had borrowed an iPhone for a week.  During that time I tried to use my WiFi but it never seemed to work (ie Established a WiFi link but then couldn't do anything else with it.).  Since I didn't have it long and WiFi wasn't the object of my testing I ignored the problem.  Now troubleshooting my Storm 2 problem and realizing that other WiFi devices on my network have been experiencing issues (the Storm 2 appears to have been most impacted) it is very likely that the iPhone I borrowed was experiencing the same problem.

You can read my previous post but a quick summary--> When I used a packet analyzer (Wireshark) I saw that my router was issuing ARP address discovery broadcasts to the Storm 2's IP address but the Storm 2 was not responding.  I had tested the same setup with a different wireless access point (Linksys WAP54G) and saw the Storm 2 properly respond (and the Storm 2 worked perfectly when connected to the WAP54G).  I concluded that the WAP2000 was either not forwarding the ARP broadcast to the Storm 2 or it was not forwarding the Storm 2's response back to the LAN.

I created a work around the now allows my Storm 2 (and multiple other devices) to function successfully on the network.  I have a Cisco ASA5505 firewall that has a ststic ARP table and is capable or proxy-arp (ie.  It can respond to ARP requests on behalf of devices on the network).  I simply created an entry for my Storm 2 and now it functions properly.  I also had a laptop and an IP security camera that had intermittent connectivity issues.  When I added static ARP entries for these items their problems disappeared as well.

I don't think this is a settings issues so I am hoping Cisco confirms this as a bug and issues a firmware update.

I hope this helps.

--Gerhard Wittreich

greg.baughman Thu, 08/26/2010 - 07:30

Well, unfortunately, it's been no joy with the cisco TAC.

Most recently, I was told that I should call Apple.

I asked specifically if they had pulled one out of the box and tried it with an iPhone, and they said they didn't have one to test.

I'm getting a total brush-off from Cisco, and I'm very unhappy about it.  I am *hoping* that downgrading the firmware will fix the issue, but I don't see why it's so much trouble to ask Cisco to actually TRY IT.

I had one Cisco person suggest that I set all of the iPhones to a static IP.  Ummm... these are installed at HOTELS... if you were a guest at a hotel, would you hand over your iphone to a front desk clerk so they could put a static IP in there, or expect them to do that themselves so that their iphone, which works EVERYWHERE ELSE they go, would work there?

I replaced a bunch of DLInk Access Points with these Cisco units, fully expecting that they would work; and if they didn't work that I could count on Cisco for some support.  Instead I get "Call Apple".

Gee... isn't that what Cisco told Duke University? 

Meanwhile, if the firmware downgrade doesn't fix the issue, I have no other choice but to RMA 16 of these units, and try to explain to two hotels that ooops... sorry... you'll be totally without internet now while we're waiting for new parts to come in.

wittregr Thu, 08/26/2010 - 11:45

Since it is now clear that the impact is not just to iPhones but other devices (eg Blackberry Storm 2, Dell Mini 9, Linksys WVC80N IP Camera) we could restate the problem as...The Cisco WAP2000 does not handle ARP broadcast traffic correctly.

I would be willing to provide ethernet packet trace data to support the claim.

william.reading Fri, 08/27/2010 - 17:54

I just tried a WAP2000 with the latest firmware on my iPhone 4 and couldn't reproduce the problem. Do you have a sample configuration that you can export and attach here? That might make it easier for others to figure out why this is happening.

greg.baughman Thu, 05/19/2011 - 08:35

I would like to point out that even with the new firmware that supposedly addressed Bonjour issues with apple products, it's now worse than ever.

I will probably lose this customer over this.  Thanks a whole freaking lot, Cisco.  It's a DOCUMENTED, PROVEN problem that they have REFUSED to address, and now I'm losing customers and getting yelled at DAILY over it.

Personally, I think that Cisco should REPLACE the 7 WAP2000's that I put in this hotel for me with something that is KNOWN to work.

Or at least RESPOND to an issue that I've been complaining about for 10 months.

All I get from them is "We're not able to replicate it", "We don't see a problem", and yet people on this thread have DOCUMENTED the problem and the cause.

So... the rule of thumb?

I guess it's "Don't buy the Cisco branded Linksys crap any more."

Oh.. here's more information:

https://supportforums.cisco.com/message/3166090

william.reading Thu, 05/19/2011 - 09:10

Greg,

I couldn't reproduce this problem the last time I looked at it, but out of curiosity, what iPhones are running into this problem? Do you happen to have version numbers? This doesn't happen on the iPhone 4, but that's not to say there isn't an issue elsewhere.

If you could post all of the variables around your issue, including the configuration of the network (I assume no captive-portal type systems) as well as the version numbers of everything, that would help people debug it. You should also post the dump of the configuration data for the device.

Cheers,

William Reading

greg.baughman Thu, 05/19/2011 - 11:24

Well, since the latest version of the WAP2000 firmware, it's worse.

Multiple IPhones, Ipads, and iPod Touches.

I have tried the following:

1) Turning the speed down to "B" Only, instead of mixed b/g.  Apple devices couldn't connect at all.

2) Setting the channels, instead of using "Auto" for the channels.

3) Playing with the power levels (trying at 50%, 75%, etc.)

4) Splitting out the SSID's, so that instead of them all saying "Hotelname" it was "Hotel103", "Hotel110" and so forth, corresponding to the installation location of the AP's.

5) Rolling the firmware backwards to pre-cisco.

I have tried two different routers; a Zyxel VSG-1200 v2 (a $1200 router made just for hotels, internet cafes, etc).  Apple devices would connect for a half second, then dump.

Then a ZyXel ZyAir B-4000.  Better luck with this one, until the latest firmware update on the AP's shot everything to hell.

I have tried the AP's both POE and powered, same results.

It seems fairly obvious to me that based on the other link referenced here with Blackberry Storms having the SAME issues, and the user verifying that ARP requests were NOT being processed properly, that it is NOT an apple issue as Cisco keeps saying, that there is a basic functionality problem with the WAP2000's.

Cisco REALLY needs to make good on this, or I will hang a sign in the hotel saying "Wireless access points provided by Cisco" for all the complaining guests to see.

william.reading Thu, 05/19/2011 - 11:39

Based on what you've said, this sounds like an issue with a proxy arp cache on the AP. Out of curiosity, do you have any VLANs configured on the device?

greg.baughman Thu, 05/19/2011 - 16:51

Nope.  Very simple, basic setup.

DHCP handed out by the Zyxel router... no encryption, no WEP keys, no nothin'.  Just basic Wi-Fi at a hotel.  Not even a walled garden.  Wide open.

meppyholdings Fri, 09/30/2011 - 18:53

I have two of these at a client site.  Constantly have to reboot them (luckily I can do it remotely via the switch as they are running off PoE ports).

Bought a couple of WAP4410N to replace them with, getting the same problem except more frequent.  Really disappointed with these WAPs from CISCO, I get he impression that not everyone has problems but many do.  Frustrating and a waste of my money and time.  I am going to call CISCO but I am sure I will get the fob off.   Every other CISCO and Linksys product I have installed has been fine, exception being the odd PoE switch failing but they always replace them no problems.

Actions

This Discussion

Related Content