ip tacacs source-interface can't be configured in 3750G

Unanswered Question
Aug 23rd, 2010

Hi All,

We have one 3750G, 12.2(35)SE5. I tried to configure "ip tacacs source-interface vlan2" but the swith won't take it. Even if I "write mem", it still doesn't show up in running configuration. The other same IOS switch does show up and tacacs works well. These two switches are trunked together. This is my first time to have this kind of issue. Is this a software bug? But the other same version switch doesn't have this issue.

Please help. Thanks in advance.

Lou

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Bobby Thekkekandam Tue, 08/24/2010 - 08:47

I believe you are running into CSCsm28901. The release note states that this problem occurs in 12.2(44)SE, but that is only an indication of where the problem was first discovered. I have seen other cases of switches being affected in earlier code.  The fix is first found in 12.2(44)SE2 and later.

Hope that helps,

Bobby

hxmengmetro Tue, 08/24/2010 - 08:51

I will upgrade these switches and see what will happen. Thanks a lot!

Lou

s-neal Wed, 01/26/2011 - 10:17

Not sure if you have found a solution to this issue yet but just wanted to add:

If the command ip tacacs source-interface Vlan# is not being accepted, you should also look to verify that your other TACACS strings are in place in the configuration.

tacacs-server host xxx.xxx.xxx.xxx

tacacs-server directed-request

tacacs-server key (encrypted key)

If any of these strings are not in place, your ip tacacs source-interface Vlan# command will not appear in the configuration.

Hope this helps if you are still having this issue!

Actions

This Discussion