6PE unspecified route question

Unanswered Question
Aug 24th, 2010

does anyone know why an unspecified route originated via a neighbor default-originate command in a 6PE environment does not have a label sent along with it?

no label makes it unusable in the 6PE environment as the receiving router sees the prefix as inaccessible, so is this a bug or am i missing something?

see the comparison of an unspecified prefix and gloabl unicast advertised over a 6PE session

thnaks

*Mar  1 00:21:16.295: BGP(1): 1.1.1.1 rcvd UPDATE w/ attr: nexthop ::FFFF:1.1.1.1, origin i, localpref 100, metric 0
*Mar  1 00:21:16.303: BGP(1): 1.1.1.1 rcvd ::/0


*Mar  1 00:21:16.335: BGP(1): 1.1.1.1 rcvd UPDATE w/ attr: nexthop ::FFFF:1.1.1.1, origin i, localpref 100, metric 0, path 2
*Mar  1 00:21:16.339: BGP(1): 1.1.1.1 rcvd 2002::/16


*Mar  1 00:21:16.351: BGP(1): no valid path for ::/0
*Mar  1 00:21:16.355: BGP(1): nettable_walker ::/0 no best path


*Mar  1 00:21:16.363: BGP(1): Revise route installing 2002::/16 -> ::FFFF:1.1.1.1 (::) to main IPv6 table

PE2#sh ip bgp ipv6 uni ::/0
BGP routing table entry for ::/0, version 2
Paths: (1 available, no best path)
  Not advertised to any peer
  Local
    ::FFFF:1.1.1.1 (inaccessible) from 1.1.1.1 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal


PE2#sh ip bgp ipv6 uni 2002::/16
BGP routing table entry for 2002::/16, version 4
Paths: (1 available, best #1, table Global-IPv6-Table)
  Advertised to update-groups:
     1
  2
    ::FFFF:1.1.1.1 (metric 3) from 1.1.1.1 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      mpls labels in/out nolabel/20

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Giuseppe Larosa Tue, 08/24/2010 - 11:54

Hello Dean,

in ipv4 we need a command to associate a label to a default route ( I know for LDP binding)

http://www.cisco.com/en/US/docs/ios/mpls/command/reference/mp_m1.html#wp1013700

mpls ip default-route

I don't know if an mpls ipv6 default-route command exists, but a default route is a special case.

if you are using IPv4 addresses mapped in IPv6 I would try to enable the above command.

Hope to help

Giuseppe

Actions

This Discussion