Problem sending E164 number in ISDN PSTN (a cisco router)

Unanswered Question
Aug 24th, 2010


I actuallly work on a test rack at home. My CUCM is coonected to a MGCP gw and this gw is connected by ISDN PRI to a router in CUCME mode that acts as the Telco. I have an Ip phone as PSTN phone.

I have a problem when I'm sending +E164 number with my CUCM 7.0.

When I debug isdn q931 i can see  something like

Bearer Capability i = 0x8090A3
                Standard = CCITT
                Transfer Capability = Speech 
                Transfer Mode = Circuit
                Transfer Rate = 64 kbit/s
        Channel ID i = 0xA98383
                Exclusive, Channel 3
        Display i = 'SiteB-Ph1'
        Calling Party Number i = 0x1081, '+33178153400'
                Plan:Unknown, Type:International
        Called Party Number i = 0x90, '0012123334444'

But when I  see on my CUCME phone that acts as PSTN switch, I cannot see +, I see only "from 33178153400".

So I lost the "+"...

My question is : Is it possible in CUCM 7 to put in ISDN something like a flag that avoid to show the "+" when it's received by ISDN switch, but permit to send it as we had seen above. Is there a special service parameter to do it????

Hope my question is clear!


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Paolo Bevilacqua Tue, 08/24/2010 - 11:46

CM and CME do not support the symbol "+" in numbers. So there is not much you can do about.

rahaman.abdoul Tue, 08/24/2010 - 15:34

Hi and thanks for your answer,

I'm not so sure about that because the main news in CUCM in the support of '+' with E164 globalization...Moreover I had done some tests with some call manager and I can receive "+' on CME phone.

But it's not exactly my question.

The question is how to send + number, E164 number and flag it in ISDN to show only the part without + sign, i.e +331234567 becoming 331234567, but only on the CME screen. Of course no translation-rule, only something to change in Call manager to put this "special" flag in ISDN


Paolo Bevilacqua Tue, 08/24/2010 - 15:43

There is no flag in ISDN to show only part of a number, and to be honest with you this is the first time I see a trace with a  + sign in number (non-standard).

My experience is that the + symbol outside business cards only causes trouble, and I would recommend not to use it, however if you can find an use for it, very good.

frlindse Tue, 08/24/2010 - 16:49

There was a bug filed last year about H.323 stripping the "+" so it should be passed in later IOS's, however as the previous post said it is not an ISDN digit.  You can pass it accross a SIP trunk however

lavanyaps Wed, 08/25/2010 - 00:05


Generally if you specify your Calling party Type as "International", your gateway will automatically takes the number format as International

and while transiting the call to the service provider, say gsm mobile operator your CLI (calling party identification) will get displayed

as + followed by the calling number... Far end operators media gateway or sbc will add the + in the display on your phone.

In your case, since you are testing in a test setup, you will not receive that + even if you add.. but your MGW actually works on E.164 number plan.

I hope this clarifies, if the info is useful.. Pl rate..



This Discussion