AA in Unity

Unanswered Question
Aug 24th, 2010

I have a call handler in unity-5 for Auto attendant. the call handler has the DN of a physical phone. now for all the calls that are either called directly to that phone device or cfwded from another phone to that extension, i would want the Auto attendant to answer. it works for directly dialed calls to that phone device, but on a fwded call, it would go to calling party's voicemail and not aa. Any ideas?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
philip.e.denton Wed, 08/25/2010 - 07:02

Unfortunately that's just how CallManager works.  Calls that end up at Unity/UConn after some forwarding behavior within the same CUCM cluster will always go to the original called party's voicemail box.


You might try applying a voicemail profile to the last-hop phone that explicitly masks the calling number to be that phone's number.  I know there's got to be a cleaner solution but I can't think of it off the top of my head.

David Hailey Wed, 08/25/2010 - 07:41

That response is not accurate.


If I read the original post correctly, the problem is not actually a problem.  When you dial the DN directly and get forwarded to VM, you hear the CH greeting as desired.  However, if a user forwards their phone to the DN of the phone/CH and is forwarded to VM, you hear the greeting for the original called party (i.e., forwarding station).  This is the default configuration for CUC and, in general, is what most end users want and expect to happen.  By that I mean that if I call Joe at x6125 and he has forwarded his phone to Sue at x5555, I want and expect to be able to leave a message for Joe since he is the person I called directly.


With that said, you can change this option within CUC.  The caveat is that the parameter is system-wide and affects all callers.  I've been involved on many threads regarding this topic.  So, in Unity Connection 7.x go to Cisco Unity Connection Administration > Advanced > Conversation Configuration > "Use Last (Rather than First) Redirecting Number for Routing Incoming Call".  The default is UNCHECKED (again, system-wide) and applies the behavior you see now.  If you check this box, then the last redirecting number will be used for routing calls to VM.  Ex: Joe forwards x6125 to Sue at x5555.  When I call Joe and the call is ultimately forwarded to VM, I will hear the VM greeting for Sue x5555.


Personally, I would recommend you leave this setting as default.  However, it's an option.  You could also configure forwarded routing rules to catch forwarded calls and route them to the CH; however, this may or may not be a bit tedious as I tend to use routing rules only as needed.  However, that gives you more insight into what's occurring and why and lays out a couple of options.


A previous thread in the same vein: https://supportforums.cisco.com/message/3133318#3133318 (for reference)


Hailey


Please rate helpful posts!

philip.e.denton Wed, 08/25/2010 - 07:54

Damn, I need to hurry up and VM up a CUCMBE so I can check this stuff out for myself before giving half answers... 

Actions

This Discussion