Cisco Stack etherchannel configuration: flag stuck in stand-alone

Answered Question
Aug 25th, 2010

I am trying to set up an etherchannel for my Cisco Stack (2x 3750G Catalyst Switches), with one port on each switch in the etherchannel. Using the Cross stack example http://www.cisco.com/en/US/products/hw/switches/ps5023/products_configuration_example09186a00806cb982.shtml as a guide I created my channel. However when i view "show etherchannel 6 summary" its says that both my ports are in stand-alone, when i want them to be in the bundled in port-channel. Thank you in advance for the your help, I have added all the information I could think of.

Here is how I created the etherchannel

sail-sw-1#conf t

sail-sw-1(config)#interface gigabiteethernet 1/0/10

sail-sw-1(config-if)#channel-group 6 mode active

sail-sw-1(config-if)#switchport trunk encapsulation dot1q

sail-sw-1(config-if)#switchport mode trunk

sail-sw-1(config-if)#exit

sail-sw-1(config)#interface gigabiteethernet 1/0/10

sail-sw-1(config-if)#channel-group 6 mode active

sail-sw-1(config-if)#switchport trunk encapsulation dot1q

sail-sw-1(config-if)#switchport mode trunk

sail-sw-1(config-if)#exit

sail-sw-1(config)#exit

The running-config

sail-sw-1#show running-config

Building configuration...

Current configuration : 5390 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname sail-sw-1

!

boot-start-marker

boot-end-marker

!

enable secret 5 .....

!

!

!

macro global description cisco-global

no aaa new-model

switch 1 provision ws-c3750g-24ts

switch 2 provision ws-c3750g-24ts

system mtu routing 1500

udld aggressive

!

!

!

mls qos map cos-dscp 0 8 16 24 32 46 46 56

!

crypto pki trustpoint TP-self-signed-538118016

enrollment selfsigned

subject-name cn=IOS-Self-Signed-Certificate-538118016

revocation-check none

rsakeypair TP-self-signed-538118016

!

!

crypto pki certificate chain TP-self-signed-538118016

certificate self-signed 01

  30.......

AF

  quit

!

!

!

errdisable recovery cause link-flap

errdisable recovery interval 60

port-channel load-balance src-dst-mac

!

spanning-tree mode rapid-pvst

spanning-tree loopguard default

no spanning-tree optimize bpdu transmission

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

!

!

interface Port-channel6

!

interface GigabitEthernet1/0/1

no mdix auto

!

interface GigabitEthernet1/0/2

no mdix auto

!

interface GigabitEthernet1/0/3

no mdix auto

!

interface GigabitEthernet1/0/4

no mdix auto

!

interface GigabitEthernet1/0/5

no mdix auto

!

interface GigabitEthernet1/0/6

!

interface GigabitEthernet1/0/7

no mdix auto

!

interface GigabitEthernet1/0/8

no mdix auto

!

interface GigabitEthernet1/0/9

no mdix auto

!

interface GigabitEthernet1/0/10

switchport trunk encapsulation dot1q

switchport mode trunk

no mdix auto

channel-group 6 mode active

!

interface GigabitEthernet1/0/11

no mdix auto

!

interface GigabitEthernet1/0/12

no mdix auto

!

interface GigabitEthernet1/0/13

no mdix auto

!

interface GigabitEthernet1/0/14

no mdix auto

!

interface GigabitEthernet1/0/15

no mdix auto

!

interface GigabitEthernet1/0/16

no mdix auto

!

interface GigabitEthernet1/0/17

no mdix auto

!

interface GigabitEthernet1/0/18

no mdix auto

!

interface GigabitEthernet1/0/19

no mdix auto

!

interface GigabitEthernet1/0/20

no mdix auto

!

interface GigabitEthernet1/0/21

no mdix auto

!

interface GigabitEthernet1/0/22

no mdix auto

!

interface GigabitEthernet1/0/23

no mdix auto

!

interface GigabitEthernet1/0/24

no mdix auto

!

interface GigabitEthernet1/0/25

!

interface GigabitEthernet1/0/26

!

interface GigabitEthernet1/0/27

!

interface GigabitEthernet1/0/28

!

interface GigabitEthernet2/0/1

no mdix auto

!

interface GigabitEthernet2/0/2

no mdix auto

!

interface GigabitEthernet2/0/3

no mdix auto

!

interface GigabitEthernet2/0/4

no mdix auto

!

interface GigabitEthernet2/0/5

no mdix auto

!

interface GigabitEthernet2/0/6

!

interface GigabitEthernet2/0/7

no mdix auto

!

interface GigabitEthernet2/0/8

no mdix auto

!

interface GigabitEthernet2/0/9

no mdix auto

!

interface GigabitEthernet2/0/10

switchport trunk encapsulation dot1q

switchport mode trunk

no mdix auto

channel-group 6 mode active

!

interface GigabitEthernet2/0/11

no mdix auto

!

interface GigabitEthernet2/0/12

no mdix auto

!

interface GigabitEthernet2/0/13

no mdix auto

!

interface GigabitEthernet2/0/14

no mdix auto

!

interface GigabitEthernet2/0/15

no mdix auto

!

interface GigabitEthernet2/0/16

no mdix auto

!

interface GigabitEthernet2/0/17

no mdix auto

!

interface GigabitEthernet2/0/18

no mdix auto

!

interface GigabitEthernet2/0/19

no mdix auto

!

interface GigabitEthernet2/0/20

no mdix auto

!

interface GigabitEthernet2/0/21

no mdix auto

!

interface GigabitEthernet2/0/22

no mdix auto

!

interface GigabitEthernet2/0/23

no mdix auto

!

interface GigabitEthernet2/0/24

no mdix auto

!

interface GigabitEthernet2/0/25

!

interface GigabitEthernet2/0/26

!

interface GigabitEthernet2/0/27

!

interface GigabitEthernet2/0/28

!

interface Vlan1

ip address 192.168.0.1 255.255.255.0

!

ip default-gateway 192.168.76.102

ip classless

ip http server

ip http secure-server

!

ip sla enable reaction-alerts

!

!

line con 0

line vty 0 4

password Mil19

login

line vty 5 15

password Mil19

login

!

end

Port-Channel 6 Interface

(according to the example there should be this line "Members in this channel: Gi1/0/10 Gi2/0/10")


sail-sw-1#show interfaces port-channel 6

Port-channel6 is down, line protocol is down (notconnect)

  Hardware is EtherChannel, address is 0000.0000.0000 (bia 0000.0000.0000)

  MTU 1500 bytes, BW 10000 Kbit, DLY 1000 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Auto-duplex, Auto-speed, link type is auto, media type is unknown

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input never, output never, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     0 packets input, 0 bytes, 0 no buffer

     Received 0 broadcasts (0 multicasts)

     0 runts, 0 giants, 0 throttles

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 0 multicast, 0 pause input

     0 input packets with dribble condition detected

     0 packets output, 0 bytes, 0 underruns

     0 output errors, 0 collisions, 1 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

Etherchannel 6 Summary

sail-sw-1#show etherchannel 6 summary

Flags:  D - down        P - bundled in port-channel

        I - stand-alone s - suspended

        H - Hot-standby (LACP only)

        R - Layer3      S - Layer2

        U - in use      f - failed to allocate aggregator

        M - not in use, minimum links not met

        u - unsuitable for bundling

        w - waiting to be aggregated

        d - default port

Number of channel-groups in use: 1

Number of aggregators:           1

Group  Port-channel  Protocol    Ports

------+-------------+-----------+-----------------------------------------------

6      Po6(SD)         LACP      Gi1/0/10(I) Gi2/0/10(I)

I have this problem too.
0 votes
Correct Answer by Nagaraja Thanthry about 3 years 7 months ago

Hello,

It seems like the Linux box NIC teaming is not working properly. Please

check the Linux side.

Regards,

NT

  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 5 (1 ratings)
Nagaraja Thanthry Wed, 08/25/2010 - 06:42

Hello,

What is connected on the other end of the EtherChannel? Have you verified

that the other end is configured properly and is up?

Regards,

NT

glen.grant Wed, 08/25/2010 - 07:40

  Try using the interface range command on the two ports that are in the channel group ,  do a shut ,  then a no shut and see what happens .  If you try to bring the ports up one at a time funky things tend to happen in etherchannels.

Jerry Ye Wed, 08/25/2010 - 08:56

Assuming the remote is configured correctly. When you add the port into the etherchannel, you shouldn't configure  trunking directly in the port, it should be done in the interface  port-channel 6. This is the sequence I usually do and it always work

interface g1/0/10

channel-group 6 mode active

interface g1/0/20

channel-group 6 mode active


interface Port-channel6

switchport trunk encapsulation dot1q

  switchport mode trunk

Regards,

jerry

martin_knorre Thu, 08/26/2010 - 00:01

Hi,

as Jerry has already said, try to set up the Interface configuration first and then the interface portchannel configuration.

I did it on Tuesday in this way and it works probably.

Regards,

Martin

sdemediuk Wed, 08/25/2010 - 17:17

If nothing is connected/setup at the other end will that matter?

Why would having nothing there put them in standalone and not bundled in the port-channel?

sdemediuk Wed, 08/25/2010 - 19:20

The connection i am using at the other end is a Linux box running CentOS 5.5 with 2 nics. I set it up by editing the rc.local script with these lines

modprobe bonding mode=4 miimon=100

ifconfig bond0 192.168.0.5 netmask 255.255.255.0

ifdown eth3

ifdown eth0

ifenslave eth3

ifenslave eth0

When I connect the linux box one of the ports on the swith changes mode from stand alone to bundled in port-channel. However the other one stays in stand alone.

The problem I am having is that when I ping another box connected to the switch on the same network it works fine. When I break one of the etherchannel links the pings continue like normal. The problem is when i reconnect the link, the pings stop for around 20-30 seconds, I get around 5 destination unreachable messages, and then it starts working again.

Ideally i want to be able to break any one of the two etherchannel links and the connection remains, and when the link is repaired I don't want my service interrupted while it figures out the link is back.

EDIT: I have tried setting up the way you suggested Jeye and still get the same results. I also tried the shutdown no shutdown trick bu with no luck.

Message was edited by: Simon Demediuk

Correct Answer
Nagaraja Thanthry Wed, 08/25/2010 - 20:41

Hello,

It seems like the Linux box NIC teaming is not working properly. Please

check the Linux side.

Regards,

NT

sdemediuk Wed, 08/25/2010 - 21:28

Is there an easy way to do this? As i have been through a bunch of guides and manuals which say that the mode 4 is the 802.3ad standard which in LACP. By setting up the ports on the switch as active that sets them up as LACP.

I found this from 06 where someone has had a similar problem, however there is no answer for it. Just a suggestion about primary and secondary modes. Could this be the cause?

https://supportforums.cisco.com/thread/29991

Nagaraja Thanthry Thu, 08/26/2010 - 05:59

Hello,

I would suggest starting with simple L2 EtherChannel. Set the switch side to

"mode on" and set the corresponding value on the Linux side. This will tell

you if the NIC teaming is working or not. Once you verify that, you can

introduce LACP.

Regards,

NT

Actions

Login or Register to take actions

This Discussion

Posted August 25, 2010 at 12:07 AM
Stats:
Replies:9 Avg. Rating:5
Views:12117 Votes:0
Shares:0
Categories: Switches
+

Related Content

Discussions Leaderboard

Rank Username Points
1 15,007
2 8,150
3 7,725
4 7,083
5 6,742
Rank Username Points
165
82
69
65
55