LAG and Etherchannel

Unanswered Question
Aug 25th, 2010

I have a 4402 conencted to a 3750 switch. I have 50 access points.

Now, I know each port on the controller will take only 48, so what's the best way to controll 50 ap's ?

If I enable LAG on the controller, then will it adopt 50 ap's ?

If so can anyone guide me through the config on the controller and the switch ?

If no lag is to be used, how do I enable both ports on the controller.

Any other advice ?

NM

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Stephen Rodriguez Wed, 08/25/2010 - 04:49

Easier route first.

  If you do not want to use LAG, on teh WLC create a second AP-Manager interface, best to use the same subnet as the current management and ap-manager, then link it to the unused port.  i.e. If management is on port 1, put the new ap-manager on port 2.   For the switch, it's just configured as a trunk port, same as the port you are already using.

  Now for LAG, you tell teh WLC to use LAG, Controller Tab,  then save config and reboot.  On the switch side, you configure an ether-channel with a mode of on, the WLC does not negotiate so no LACP or PAGP.  Put the physical ports the WLC is connected to into the ether channel, and done.

neilmac Wed, 08/25/2010 - 04:52

Thanks, Stephen.

But the question is, does the LAG support 50 ap's ?

NM

neilmac Wed, 08/25/2010 - 05:32

Many thanks.

Do you have a config example for the etherports on the switch ?

Stephen Rodriguez Wed, 08/25/2010 - 05:38

port-channel 1

switchport

switchport mode trunk

switchport trunk native-vlan 100

G1/0/1-2

switchport

switchport mode trunk

switchport trunk native-vlan 100

switchport trunk allowed-vlan 1,100,110,120

channel-group 1 mode on

neilmac Wed, 08/25/2010 - 07:00

OK; I have this:

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk

and:

interface GigabitEthernet1/0/19
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet1/0/21
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode on

I set the controller to use LAG on reboot, now I have lost contact withit, can't oing, can't open web page, nothing.

What could be worng ?

Thanks,

NM

Stephen Rodriguez Wed, 08/25/2010 - 07:33

I bet you have the native VLAN untagged on the WLC, and that the subnet it is in, is not VLAN 1.

you need to add the switchport trunk native vlan < vlan > command under the Port-Channel

Actions

This Discussion