CIPC on Windows 7

Unanswered Question
Aug 25th, 2010


I have installed CIPC(v7.0.3) on a windows 7(64-bit) computer. When I am trying to configure Audio devices through "Audio Tuning Wizard", it is not allowing me to select other audio devices installed in my computer to use with "headset", "speaker" and "microphone". It is just displaying the "Default Audio Device" for headset, speaker, and microphone.

My goal is to configure different devices for headset, and speaker but as said above, it is not allowing me to do so. Is this expected behavior or I am doing something wrong?


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Chris Tolley Wed, 08/25/2010 - 09:03

My installation is the same. I've set playback to my (USB) headphone, with the same for the mic. If these

are not plugged in then WIndows defaults to the regular speaker/mic.

jaskenyon Fri, 10/08/2010 - 12:31

Getting the exact same problem here and trying to find a solution...

Using 7.0.2 on a Win 7 64bit OS, HP elitebook 8540p

Under windows vista 64 on the old laptop this worked perfectly, and I find here under Win 7 the only option to show all my devices is the "ringer" drop down box other wise the rest only give the option of Default windows audio device.

Sorry to the poster above but if I have the headset specifically for my phone, then it is not good enough to have all the other system sounds bonging around during a call also... plus I wish to have the option of setting it up for profiles which can give a speaker phone for conferences if necessary.

Is there any known error or anything in the way of a fix for this or manual tuning possible?



Chris Tolley Fri, 10/08/2010 - 13:19

In my particular case (Win7 32, CIPC, I don't have any choice other than default windows

device in CIPC configuration.

To get around this I had setup the headphones as default in Windows config.

jaskenyon Fri, 10/08/2010 - 13:37

Understood, however it isnt a solution...

I can use the headphones by making them default yes but then it cuts the rest of the functions and I have the unwanted windows sounds cropping into the conversations.

This is a product issue and I am looking for a fix.

aitchmd68 Mon, 10/22/2012 - 12:51

CIPC on a HP 6560-b

This is the best i could do to get options into the Audio Tuning Wizard drop down lists ....

Right click on the Speakers icon in the PC System tray (lower right)


Playback tab

Communications Headphones – Right click

Check off (a) show disabled devices (b) show disconnected devices

THEN Disable

Highlight Speakers (USB Audio) and Set that as Default from the drop down

Recording tab

Integrated Microphone Array – Right Click


Highlight Microphone (USB Audio) and Set that as Default from the drop down


Launch Cisco IP Communicator like you would normally

Right click on the Softphone image if you are not prompted to run the Audio Tuning Wizard.

Audio Tuning Wizard

About Audio Tuning Wizard – Next

Select Audio Devicesyou should now have the option to change the HEADset, Speaker Phone, and HANDset drop down list (before ‘Default Windows Audio Device’ was the only option).

Adjust Listening Volume – Playback Device should be Speakers USB Audio --> Test --> Next

Adjust The Microphone Volume – Recording Device should be Microphone USB Audio  --> Test --> Next

You have now Completed ….  Finish

I was told that one option was to  ....

DeskTop Cisco IP Communicator Icon – Right click


Compatibility Tab

Check off – Run this program in compatibility mode for …

   Windows Vista (Service Pack 2) – from the drop down

   No items checked in the Settings field (if there are, uncheck those before you apply and save)



That never worked for me.

I tried all the different options from the drop down list.

So I don’t know if that is a HP 6560-b thing or not.

Ran as admin and as per normal user … same result.

No luck.


This Discussion