ASA VPN trying to get authentications sent to NMS via snmp traps

Unanswered Question
Aug 25th, 2010

I am unable to get my ASA to send snmp traps to my NMS when a user vpns in.  i get it in the form of a syslog even but i want it as an snmp trap that way i can do better alerts.

here are my configs:

logging enable
logging timestamp
logging list VPN_Authentication level informational
logging list VPN_Authentication message 716038
logging list test level informational
logging console errors
logging buffered debugging
logging trap informational
logging history VPN_Authentication
logging asdm informational
logging host INSIDE host
logging permit-hostdown
logging class auth history informational

snmp-server host INSIDE host community ********* version 2c
snmp-server location ************
no snmp-server contact
snmp-server community *************
snmp-server enable traps snmp authentication linkup linkdown coldstart
snmp-server enable traps syslog
snmp-server enable traps ipsec start stop
snmp-server enable traps entity config-change fru-insert fru-remove
snmp-server enable traps remote-access session-threshold-exceeded

any ideas what im missing?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
scott.mcnitt Mon, 08/30/2010 - 09:40

I am using SNMPc for my NMS if that helps.  And we used to have it working on our VPN 3000 Concentrator, once we replaced it with the ASA it doesnt not work as it is different in the setup.  I have watched the logs in ASDM to check for success and failed VPN auth. attemps and wrote down the Syslog IDs.  tried adding them into the logging event filters - but no dice.  they show up on the Syslog server but i need them to show up in the SNMP

Actions

This Discussion