Layer 3 Switch and Multicasts

Answered Question
Aug 25th, 2010

We have a Cisco 4948 Switch which appears to be sending Multicast traffic outside of its intended VLAN and consequently flooding an external network.  Perhaps I am missing a configuration to restrict this traffic. Can you help?

Thanks,

~~c

I have this problem too.
0 votes
Correct Answer by Jerry Ye about 6 years 3 months ago

You can remove sparse-dense-mode on the VLAN that you don't want multicast traffic to be received. To contain the multicast traffic in a single L2 VLAN, you can leave ip pim sparse-dense-mode configured or like what you said, configured igmp snooping querier. This should do the trick.

HTH,

jerry

Correct Answer by Jon Marshall about 6 years 3 months ago

gdwingnuts wrote:

We have a Cisco 4948 Switch which appears to be sending Multicast traffic outside of its intended VLAN and consequently flooding an external network.  Perhaps I am missing a configuration to restrict this traffic. Can you help?

Thanks,

~~c

As Jerry says, config would be useful but some questions -

1) Is the 4948 responsible for L3 inter-vlan routing ?

2) if 1) then have you enabled ip multicast routing on the switch

3) if 2) have you enabled PIM on any of the vlan interfaces and if so which PIM, sparse or dense mode ?

4) Do you have any receivers that are not in the intended vlan ?

Be aware that PIM dense mode is a flood and prune technology so it will send the multicast traffic onto any vlan that has PIM enabled. If you want to avoid this you could either -

1) use PIM sparse mode which does not use flood and prune

2) if you only need multicast within the actual vlan then disable multicast routing and use IGMP snooping querier on that L3 vlan interface.

Jon

Correct Answer by martin_knorre about 6 years 3 months ago

Hi,

without the config, I can only guess. But you can try to set the storm-control multicast level or see the following page:

https://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_cfg_rpgmp_ps6441_TSD_Products_Configuration_Guide_Chapter.html

Maybe it helps you

Regards

Martin

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.
Jerry Ye Wed, 08/25/2010 - 13:54

Can you post the config and detail explaining what is happening?

Regards,

jerry

Correct Answer
Jon Marshall Thu, 08/26/2010 - 06:58

gdwingnuts wrote:

We have a Cisco 4948 Switch which appears to be sending Multicast traffic outside of its intended VLAN and consequently flooding an external network.  Perhaps I am missing a configuration to restrict this traffic. Can you help?

Thanks,

~~c

As Jerry says, config would be useful but some questions -

1) Is the 4948 responsible for L3 inter-vlan routing ?

2) if 1) then have you enabled ip multicast routing on the switch

3) if 2) have you enabled PIM on any of the vlan interfaces and if so which PIM, sparse or dense mode ?

4) Do you have any receivers that are not in the intended vlan ?

Be aware that PIM dense mode is a flood and prune technology so it will send the multicast traffic onto any vlan that has PIM enabled. If you want to avoid this you could either -

1) use PIM sparse mode which does not use flood and prune

2) if you only need multicast within the actual vlan then disable multicast routing and use IGMP snooping querier on that L3 vlan interface.

Jon

gdwingnuts Thu, 08/26/2010 - 08:40

Jon,

We do have inter vlan routing configured.  We also have ip pim sparse-dense-mode configured on two of the three VLANs.  Just to be clear, if I wanted Multicast within only one VLAN should I remove the ip pim sparse-dense-mode from other VLAN interfaces, and then enable IGMP snooping querier on that VLAN interface as well?  Also, I have found the problem with the unwanted traffic.  An engineer connected to the wrong VLAN.  Actually he connected to the VLAN which has the Multicast Traffic.  I guess it was user error in this case.  Thanks for the useful information.

Correct Answer
Jerry Ye Thu, 08/26/2010 - 08:49

You can remove sparse-dense-mode on the VLAN that you don't want multicast traffic to be received. To contain the multicast traffic in a single L2 VLAN, you can leave ip pim sparse-dense-mode configured or like what you said, configured igmp snooping querier. This should do the trick.

HTH,

jerry

Actions

This Discussion