voip project

Answered Question
Aug 25th, 2010

Hello...

i am new in all this stuff (voip) and i have to do a project for the university.

What i have to do is to connect two ip phones in order to place a call

between this wo phone (cisco 7905 )

the hardware that i have is a cisco router( 1700 series) a cisco switch( catalyst 2950 series) a cisco pc (MCS 7800 series) with windows 2000 and call manager 3.3.

I don't need o make any outcoming calls or incoming . only calls from one phone to the other.

What i managed to do until know is to connect all this stuf and to configure the call manager and DHCP but i must has done something wrong...

The ip phones passes alla the tests ( configuring ip via DHCP etc.) but after all this the phones then restarts and do all this from the begining....

i have read deferent thinks on the internet but i just confused more.

can someone guide me one what to read and in witch ored i have to do think (for example if (and somewhere to read how) i have to configure DHCP first an then CCM (i did it in this order) what i have to configure in CCM and in witch order etc.  ?

P.S sry for my english (it's being a long time since i last wrote something in english)

I have this problem too.
0 votes
Correct Answer by Amit Sharma about 6 years 2 months ago

George,

1) Make sure that the TFTP service is up and running on your cucm server.

2) Make sure that you have a 7905 firmware load on the CUCM server, in the TFTP root directory.

3) Configure both phones on CUCM, and give each phone an extension/DN. Then save and reset from CUCM.

4)  Make sure both extensions/DN's are in a CSS that contains the partition  that the other DN is in.  If extension A is in partion 1, make sure the  CSS you assign to extension B contains partions 1, and vice-versa.

5) On your DHCP server, make sure you have "option 150" set as the CUCM server you're using for TFTP service.

Then reset your phones.

If these are above ppoints not ok for your problem removal then you have to do manual ip confiugration and then see what is coming ip phone.

If still same issue coming go to system on cucm server nad check the connectivity ebtween both side devices for verify the full connectivity of setup.

If it is ok then chekc how many license files are you haivng and how is used and not used in system.

If then not work, please chekc the basic network connectivity for setup.

PLease provide the whole network setup with details so that verify where is the problem?

please also tell hwta is coming on ip phone that is not registering wtih cucm sever?

Amit

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
David Smith Wed, 08/25/2010 - 15:14

George,

1) Make sure that the TFTP service is up and running on your cucm server.

2) Make sure that you have a 7905 firmware load on the CUCM server, in the TFTP root directory.

3) Configure both phones on CUCM, and give each phone an extension/DN. Then save and reset from CUCM.

4) Make sure both extensions/DN's are in a CSS that contains the partition that the other DN is in.  If extension A is in partion 1, make sure the CSS you assign to extension B contains partions 1, and vice-versa.

5) On your DHCP server, make sure you have "option 150" set as the CUCM server you're using for TFTP service.

Then reset your phones.

What should happen is the phone will send out a DHCP request, get it's option 150 (TFTP address) contact the call manager, upgrade it's firmware if needed, pull it's configuration file, then register to CUCM.

Thanks, -Dave

Jaime Valencia Wed, 08/25/2010 - 15:26

Also make sure CCM service is running, TFTP delivers the config but unless CCM is running phones won't register.

Config is pretty easy, device -> phone -> add new. Just fill in the blanks. Then use left hand menu to add a DN, again, just fill in the blanks.

If really all you need is to have phone A call phone B and viceversa you can bypass CSS and partitions and leave everything in .

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

ProjectGeo Wed, 08/25/2010 - 15:49

javalenc,

Config is pretty easy, device -> phone -> add new. Just fill in the blanks.

i've done this already

as i said in my previous message some thinks sound strange to me (DN for example...)

this think with the partitions is what confuses me more... i'll try to do it without partitions first and then i'll try to find out what partitions is and how it works( i have read somethinks but didn't knew if i sould do or not partitions) and i'll try it with partitions too...

yes the only think that i want to do is calls from phone a to phone b and vise versa

thanks for your answer too...

Jaime Valencia Wed, 08/25/2010 - 15:54

Then i'd start by reading this

Calling Privileges in Cisco Unified CallManager

Dialing privileges are configured in order to control which types of  calls are allowed (or prevented) for a particular endpoint (such as  phones, gateways, or CTI applications). All calls handled by  Cisco Unified CallManager are subjected to the dialing privileges  implemented through the configuration of the following elements:

Partitions

Calling  Search Spaces

http://www.cisco.com/en/US/docs/voice_ip_comm/cucm/srnd/4x/42dialpl_ps556_TSD_Products_Implementation_Design_Guide_Chapter.html#wp1043737

HTH

java

If this helps, please rate

www.cisco.com/go/pdihelpdesk

ProjectGeo Wed, 08/25/2010 - 15:37

Thanks for the quick response,

some thinks sounds completly strange to me (probably that's why nothing works , i must have passed some thinks )  but i'll look on the internet and i hope not to get confused again...

thnks for the helpfull answer ( now i know from where to start...)

i'll  try to do what you say and be back soon with the results...

hope it works

thanks again for the quick response

David Smith Wed, 08/25/2010 - 18:05

George,

Javalenc is correct, leave both the CSS and Partion as "none" and you'll be able to make calls.

As long as the phones can register, with a DN, then this should work fine.

Confirm the TFTP service/settings, CCM service etc...seen above, and you should be able to get the phones to register.

Thanks, -Dave


ProjectGeo Wed, 09/01/2010 - 15:20

hello back again with no proggres done..

have some more questions

1) Make sure that the TFTP service is up and running on your cucm server.    DONE

is this necessary??? i find how to do it here http://www.cisco.com/en/US/docs/voice_ip_comm/cuipph/7905g_7912g/firmware/1_2_1/english/release/notes/05_121.html

but my first problem is that everthing is a bit diffrent from what is said in the document and the firmware i find here(if it is the right one )

it's for 7905g my ip phones are 7905.

and also i can't dl it it sais

To download this software you must have a valid Technical Support Services Agreement associated to your Cisco.com user ID.

2) Make sure that you have a 7905 firmware load on the CUCM server, in the TFTP root directory.

3) Configure both phones on CUCM, and give each phone an extension/DN. Then save and reset from CUCM. DONE

(NOT NEEDED )

4) Make sure both extensions/DN's are in a CSS that contains the partition that the other DN is in.  If extension A is in partion 1, make sure the CSS you assign to extension B contains partions 1, and vice-versa.

5) On your DHCP server, make sure you have "option 150" set as the CUCM server you're using for TFTP service. DONE

moreover i think my problem is on how i setup my DHCP server but i imagine you xcan't help me on this one...

Then reset your phones.

What should happen is the phone will send out a DHCP request, get it's option 150 (TFTP address) contact the call manager, upgrade it's firmware if needed, pull it's configuration file, then register to CUCM.

Thanks, -Dave

gohlex8848 Thu, 09/02/2010 - 01:20

Hi George,

Is the call manager showing the two ip phone is registered?you can check it at Device->Phone page.

is the two ip phone able to get ip address from your dhcp?

Alex

ProjectGeo Thu, 09/02/2010 - 09:29

no that's why i believe the problem is there...

it says  no phone connected or something like this.

gohlex8848 Thu, 09/02/2010 - 18:26

you might want to check and make sure the phone is getting an ip and

it reachable to the callmanager. also check on the phone->network

setting and see it is pointing to correct active call manager ip add.

Two phones setup should be quite a straight forward..

Alex

ProjectGeo Mon, 11/01/2010 - 01:37

Hi, after reading everything you told me (and match more) i find out that the DHCP and CM configuration are ok...

my problem seems to be that my cisco router doesn't get ip.....

starting from the easy ones i thougt maybe i made some mistake on how i connect everything....

(the switch with the computer the router and the phones... isn't this right??)

and then i read something about giving ip to the router manually or something like this....

(something like the dsl configuration) but i dont know how to get "access" to the router configuration page...

(sry for my "stupid" quetions as i said before all this are new to me... my project isn't about this staff... it supposed that the "equipment" was ok and i have to "examine" voip packages....)

Correct Answer
Amit Sharma Mon, 11/01/2010 - 01:53

George,

1) Make sure that the TFTP service is up and running on your cucm server.

2) Make sure that you have a 7905 firmware load on the CUCM server, in the TFTP root directory.

3) Configure both phones on CUCM, and give each phone an extension/DN. Then save and reset from CUCM.

4)  Make sure both extensions/DN's are in a CSS that contains the partition  that the other DN is in.  If extension A is in partion 1, make sure the  CSS you assign to extension B contains partions 1, and vice-versa.

5) On your DHCP server, make sure you have "option 150" set as the CUCM server you're using for TFTP service.

Then reset your phones.

If these are above ppoints not ok for your problem removal then you have to do manual ip confiugration and then see what is coming ip phone.

If still same issue coming go to system on cucm server nad check the connectivity ebtween both side devices for verify the full connectivity of setup.

If it is ok then chekc how many license files are you haivng and how is used and not used in system.

If then not work, please chekc the basic network connectivity for setup.

PLease provide the whole network setup with details so that verify where is the problem?

please also tell hwta is coming on ip phone that is not registering wtih cucm sever?

Amit

Amit Sharma Mon, 11/01/2010 - 03:00

Hello,

thanks for voip setup.

it looks ok but for safety apr pls check the connectivity from every point.

plug the systen in palce of ip phone and chekc whole connectivity if not done after that all connectivity is ok then sure that ip phone haivng issue

If not that may be some issue in cucm sever and check license part of system.

please try to register with manula setup so that chekc what is issue coming?

please try with any other phone if you have so that chekc the issue?

Amit

ProjectGeo Tue, 02/08/2011 - 07:45

thnks everyone for the help...

i had to do manual ip confiugration as armit said and everythink works fine know....

gohlex8848 Mon, 11/01/2010 - 03:12

Hi George,

Basically for this simple setup, I don't think a router is needed.

Since you confirmed the DHCP is working fine, then what you can do to test Is directly connect the two IP phone to the 2950 switch and of course the Call manager server in the same switch too.

Make sure the phone is getting the ip from dhcp server with the option 150 too (you can press the setting button on the phone and check the network detail)

Once the phone is able to get the ip address, then u can go into call manager to verify that you have the correct mac address added under the Phone device. Once it says phone is registered, then u can proceed configured directory number and so on.

Let me know how is it going

Cheers,
Alex

ProjectGeo Mon, 11/01/2010 - 10:09

the reason i have to use the router is because it supports SRST (Cisco® Unified Survivable Remote Site Telephony) but i'll try with out it to see if it works and then i'll try to do it with the router...

thanks for your answers. i'll try everything you told me and i'll be back with good news i hope....

Actions

This Discussion