VRF Import Not Working?

Unanswered Question
Aug 25th, 2010
User Badges:

Hi,


I am trying to import certain routes from the Global Routing Table to a VRF table without any success.  Could you help?  Thanks.


CAR_A#sh ip route
O IA 172.23.0.0/16 [110/2] via 10.68.0.3, 00:25:21, FastEthernet1/0


CAR_A#sh run | in ip prefix
ip prefix-list data-center-net seq 15 permit 172.23.0.0/16 le 32


CAR_A#sh run | b route-map data-center-net
route-map data-center-net permit 10
match ip address prefix-list data-center-net


CAR_A#sh run | b ip vrf data
ip vrf data
import ipv4 unicast map data-center-net



CAR_A#sh ip route vrf data
Routing Table: data
C       10.68.31.0 is directly connected, FastEthernet0/0.2


As you can see, the vrf data routing table is not learning 172.23.0.0/16 imported from the Global Routing Table.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Chetan Kumar Ress Thu, 08/26/2010 - 15:23
User Badges:
  • Silver, 250 points or more

Hi Kevin


Can you post the config !!


And also please can you share  the output of

1] Sh ip vrf (name) detail

2] Sh ip bgp vpnv4 vrf (name)


And check whether RD has configured under your vrf.


Regards

Chetan Kumar

http://chetanress.blogspot.com

kevin.hu Mon, 08/30/2010 - 13:14
User Badges:

Chetan,


I finally got it working by just reloading the router.  Feels like troubleshooting Windows product now - reboot first!


Now, I got the import working.  I am wondering if there is a dynamic export feature to export VRF routes into Global Routing Table.


Here is the problem.  All sites are connected to a MPLS VPN cloud.  Networks located at the Data Centers are in the Global Routing Table.  Branch offices have several VRFs using VRF-lite, for example, Engineer VRF and Finance VRF.  All VRF-lites are also configured on the data center WAN edge routers.  So far I have managed to import data center networks into both Engineer VRF and Finance VRF using "import ipv4 unicast" command.  How do I export Engineer networks and Finance networks to the data center?  "export ipv4 unicast" does not exist.   

kevin.hu Tue, 08/31/2010 - 10:53
User Badges:

I finally tried GRE based route leaking on the same router.  I can finally have connectivity between a VRF and the Global Routing Table.



interface Loopback100
 ip address 192.0.2.1 255.255.255.255
!
interface Tunnel100
 ip address 192.0.2.129 255.255.255.252
 tunnel source Loopback100
 tunnel destination 192.0.2.2
!
router ospf 100
 network 192.0.2.129 0.0.0.0 area 0
!


interface Loopback101
 ip address 192.0.2.2 255.255.255.255
!
interface Tunnel101
 ip vrf forwarding 
 


ip address 192.0.2.130 255.255.255.252
 tunnel source Loopback101
 tunnel destination 192.0.2.1
!
router ospf 101 vrf 
 network 192.0.2.130 0.0.0.0 area 0

However, this might not be an ideal solution for the data center as it routes all traffic thru a GRE tunnel.  I will try the cross-over cable trick next.

Actions

This Discussion