Unity connection V8 - MVI not off after msg read

Unanswered Question
Aug 25th, 2010

Hi ;

encounter an issue that with unity connection v8. The system work fine, but how am i to turn off MWI when voice mail message been read. Curently MWI still on even voice message been read, untill i have to delete the voice mail then MWI will trun off.

I not able find where is the setting to turn off MWI after voice message been read. Pls advice. THanks.



ps: CUCM v8 also.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
potan Tue, 08/31/2010 - 17:05

hi sopayne ;

This WMI work fine, only that after user hear the voice message the MWI never turn off. Untill user have to delete the voice mail message then MWI will trun off. Where to find the setting to trun off MWI when voice message been hear. Thanks.



potan Wed, 09/01/2010 - 02:06

Sopayne ;

I need the MWI to be turn off when user listen the voice mail. But it still on, until I have to delete the voice mail then only MWI will be off. Any setting can be find ? Thanks.




This email and all contents are subject to the following disclaimer:


sopayne Wed, 09/01/2010 - 08:51

There's no setting that will only turn off the MWI when the message is read.

There's no setting that will only turn off the MWI when the message is deleted.

MWIs turn off by design when a message is either read or is deleted.

If the message is marked as new after reading it (marked new or marked unread) then the MWI *should* be on by design.

Based on what you have described, I would suggest that you review the troubleshooting guide and see if you can reach resolution that way...


Open a Service Request with Cisco TAC.

Kapil Atrish Fri, 06/24/2011 - 17:10

Did you find the solution to this issue? I am experiencing same behavior on Unity connection 7.0.2.

Kapil Atrish Sat, 06/25/2011 - 09:23

No worries guys, I found the setting. Its under User>>Playback settings. You can control whether to mark the message as Saved or NEW when Subscriber hung up.

oliversh54 Fri, 09/13/2013 - 14:46

On CUC 8.6.2ES44.22900-44 we had the same issue. After the message was listened to in its entirety via the TUI, it was still not marked as read and the MWI of course stayed on until the user selected Save or Delete option.

We followed Kapil's recommendation:

Users -> Playback Message Settings -> When Disconnected or User Hangs Up During Message Playback -> Mark a New Message -> changed from New to Saved.

Now have expected behavior that the message is marked as read after it is listened to and the MWI goes off.

anmcbrid Fri, 09/03/2010 - 07:24

If MWI is never being turned off make sure the MWI off number is configured in CCM, that it's set correctly in UC.

If MWI off works sometimes but not others then check to make sure you don't have port memory configured, thats a UC configuration option thats not meant for CUCM integrations.

You can also check the MWI device on the user, see if MWI is off or pending.  If it's off then it means connection believes it's turned off MWI, if it's pending then something is wrong and it's not able to turn it off.


This Discussion