CAD- Integration with TSRM(CRM)

Unanswered Question
Aug 25th, 2010

Hi,

     I have implemented the integation of CAD with IBM's Tivoli Service Request Manager(a case management tool) successfully. Neveretheless, one of the agents is facing an issue with this integration. The ideal scenario would be, when a caller calls into the system and punches his ID, all the information for that ID should get populated within the integrated browser. Basically, I am using the HTTP action in CDA and doing a POST to the TSRM url by appending the entered ID. It is working perfectly in all the agents laptops except one. Though I am able to see that the ID is getting populated in the CAD's enterprise data, no data gets populated in the integraed browser (TSRM screen). I have checked the logs on both sides but nothing looks fishy. I looked into the agents's user id previledges in the TSRM, that too looks ok. I then upgraded the IE from version 6 to version 8 but no luck. I am running out of options to troubleshoot this.

Any leads to resolves this is appreciated.

Thanks,

DM

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Aaron Harrison Thu, 08/26/2010 - 00:28

Hi

Firstly, CAD doesn't use Internet Explorer if you use a HTTP action within the CAD window. It uses it's own browser, which can lead to compatibility issues. If you want to use IE you usually end up using the macro facilities of CAD.

If it's simply not launching the URL, then have you definately added the problem user to the correct workflow in CDA, and have they definately fully closed down the Agent and reopened it to get the changes? If so, perhaps restart the 'Deskop Sync' service in UCCX Control Center and get them to close/reopen CAD to ensure they have the workflow applied.

If that doesn't help, or the URL is being launched but is failing, you need to work out whether it's not working on this one agent because of a problem with CAD, or something else.

I would do this:

1) Run a wireshark capture on the 'bad' agent, see what is sent out by CAD and see what is returned

2) Same on a 'good' agent for comparison

If you send out the same URL in the correct format on both, but one returns an error, then show that to the customer and leave it to them to troubleshoot their app...

Aaron

Please rate helpful posts...

dmurthy74 Thu, 08/26/2010 - 08:45

Thanks for your response.

I am glad I learnt that the integrated browser is not IE and we use macros if we need to you IE with CAD. Thanks for correctimg me here.

Regarding the URL population, yes , the URL is getting populated in the integrated browser but it is just that the data is not being seen on the CAD Integrtated browser.

I will surely do the wireshark suggestion to sniff the packets and see where the problem is.

Thanks,

DM

Actions

This Discussion