Aironet 1250 LWAPP to Autonomous Downgrade

Unanswered Question
Aug 25th, 2010

Like an Idiot I upgraded my home AP from Autonomous to Lwapp.  I was an Idiot and thought i was getting an IOS upgrade. I need to revert it back to autonomous and a simple "mode" button reset doesnt work.  I read that I need to Reload original IOS software, but It appears I cant get it without a support contract.  I cant afford servicenet and need to obtain old ios to revert to factory default 12.4(10b)JA1.  Do I need a contract to roll back?  Is there an archive (backup image) of the old IOS that could be still stored on the device.  I didnt back it up and need to obtain the image.  I know,  im dumb!  Dont mess with stuff, and always backup.  Very dumb :-(

I have this problem too.
1 vote
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Leo Laohoo Thu, 08/26/2010 - 16:26

Don't kick yourself.  Everyone makes mistakes.  It's important that you learn your mistakes. 

Hopefully we can offer some help.

Console into your AP and in enable mode, enter the command "dir flash:".

If the APs asking for username/password, try "Cisco"/"Cisco".

I hope you'll see two IOS files, one with the "rcv" the other with "k9w7".  Delete the directory that contains the "rcv" using the command "delete /f /r flash:" and reboot the AP.

Please don't forget to rate our useful posts.  Thanks.

Kagemaru_87 Thu, 07/19/2012 - 00:07

I am currently working upgrading our APs from Autonomous to LWAPP and we have a spare in which I could test on. I was able to convert it to LWAPP using the AP's GUI and the AP was also able to communicate with the wireless controller. The AP initially was on downloading status as mentioned by the wireless controller then that changed to REG. Then after I was satisfied, I decided to convert it back to Autonomous as the unit is a spare. Again I checked the net, and found a command like below:

archive download-sw /overwrite tftp://x.x.x.x/c1250-k9w7-tar.124-25d.JA1.tar

That didnt work on the AP as the device doesnt ever recognize the archive command. So I went further and saw this article and tried it out.

What happened is, the AP booted with the Autonomous image but still has the LWAPP config. No start-up config is present though. I couldnt even enter configuration terminal nor could I access the GUI (running-config says no ip http server). I tried the unplug replug hold the button for a few seconds then rebooted the AP, still no go.

Any suggestions?

Kagemaru_87 Tue, 07/24/2012 - 14:18

Thanks leolaohoo. This have worked. I'd be trying to bring it to LWAPP again and back to autonomouse with everything documented. Any steps you could suggest when I have to bring it back to autonomous or the above should already work even without deleting whats in flash?

Leo Laohoo Tue, 07/24/2012 - 14:40

The abovementioned link will convert a WAP, running controller-based IOS, to automatically load an autonomous IOS with the press of the (Mode) button.

If you want to convert an autonomous IOS WAP into controller-based, it is as simple as copying the controller-based IOS into the WAP using the more traditional method of "archive download-sw tftp:/IOS.tar".

Actions

This Discussion

Related Content