WRP400 randomly fails to register with voip provider after power outage.

Unanswered Question
Aug 26th, 2010
User Badges:

Hello,


I've the following problem:


The WRP400 WAN port is connected to a Cable Modem. When I power cycle both systems at the same time, via common AC line switch, sometimes the WRP400 will not register with the voip provider. It will keep retrying the registration every 30 seconds but will always fail.


Nevertheless, if I power cycle the WRP400 only, then it will register normally.


Have anyone seen this problem? I've found two forums threads where they discussed similar situations but no conclusion or solution was found.


Some help will be very appreciated. I'd like to be able to shutdown the cable modem and the WRP400 to avoid wasting energy when they're not in use.


Thanks!


PS: I can get the syslog traces if someone thinks it is necessary. I dont have them with me right now.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
nestico_cisco Thu, 09/02/2010 - 02:20
User Badges:

Hello all,


I am kind of sad i've havent got any reply. I'd like to suppose that it is because there is no enough information in may previous post.


I continue to face this issue:WRP400 connected to cable modem. Both switched ON at the same time, sometimes he WRP400 voip module will not register and will keep retrying forever.


I attached a syslog obtained when the issue is present. In the log file I added the information obtained from the info page (fw and hw version, etc)


Would you please try to give me some insight on this problem? I got this product recently because I thought was a great product from Linksys, it is a little bit frustrating to have it turned ON and (only sometimes 1 out ~5) voip is not registered.


Thanks to you all in advance,

Nestor.


PS: This problem was observed by at least someone else... They discussed it in this thread, but with no clear answer.


Original url:

http://www.voipsnak.dk/forum/viewthread.php?thread_id=1075&pid=6471


Translated url:

http://translate.google.com/translate?u=http%3A%2F%2Fwww.voipsnak.dk%2Fforum%2Fviewthread.php%3Fthread_id%3D1075%26pid%3D6471&sl=da&tl=en&hl=&ie=UTF-8

David Carr Fri, 09/03/2010 - 06:42
User Badges:
  • Silver, 250 points or more

Hello Nestor, sorry for the late reply.  I have a question about the way your booting up the devices.  When you power up the modem, do you let it power up completely before you power up the wrp400 or do you power them up at the same time.  If your powering them up at the same time, can you try to let the modem power up completely and then power up the wrp400.  The reason behind me saying this, you said that when the modem has been left on, you can powercycle the wrp400 and it will register.  Give this a try and see if the results are the same.  Hope this helps.

David Carr Fri, 09/03/2010 - 06:52
User Badges:
  • Silver, 250 points or more

Are you running the latest firmware, the 2.00.05, If not I would upgrade  to the latest and see if the issue persist


One other question i have, I seen in the logs that your registering to sip.sipcall.ch.  Are you using the internet service providers DNS server or are you using a manual.  If your not using a manual, we can see if it is a DNS issue and try a different DNS server, possibly 4.2.2.2, 4.2.2.1 or 8.8.8.8.


I seen  in the logs that the WRP400 is getting reg address change and failing to register as posted by your logs.  Lets try the dns issue and see if that resolves the issue.

nestico_cisco Fri, 09/03/2010 - 07:06
User Badges:

Hello davicarr,


Thank you very much for your reply.


You are correct. Both devices are being powered up exactly at the same time. (Via single switch power outlet)


No, I havent upgraded to the 2.00.05. I read the release notes, and did not see any particular item addressed at this issue, so I decided not to upgrade for the moment unless someone from Cisco(Linksys) suggests that this fixes the issue.


Regarding the delayed powering of the WRP400, it may workaround the issue, but we wouldnt know the root cause.(But i can consider it as a solution if we fail to identify the main problem )


I have automatic DNS. I will try the manual DNS. Should I completely remove all the DNS that are automatically assigned?


Please note that even if Voip module will not register, all other internet access seems to keep working correctly. Is this an argument against the manual DNS solution?


Thanks and best regards,


Nestor.

David Carr Fri, 09/03/2010 - 07:38
User Badges:
  • Silver, 250 points or more

Yeah lets upgrade to the latest firmware that way were not troubleshooting a fixed issue.  I know that typically when i boot up devices i let one boot up completely and then boot up the other device.  The manual dns is an option.  The reason i was saying that is the logs kept trying to register to your proxy address and would try another address.  Give this a shot and see if it works.

nestico_cisco Tue, 09/07/2010 - 06:00
User Badges:

Hello,


I've upgraded to latetest FW and I am observing the behaviour. I will post again in a few days with the results.

Alberto Montilla Tue, 09/07/2010 - 08:53
User Badges:
  • Cisco Employee,

Dear Sir;


The issue is related to a DHCP timeout on the box, so it stop requesting the address. This is a synchronization issue, as the modem seems to take too long to answer although connectivity is up. Workarounds are:

- Set a static IP address for the router (WAN), so that it is not affected by the modem delay.

- If not possible, then reboot the box after the modem comes in service.


Regards

Alberto

nestico_cisco Sat, 09/11/2010 - 00:29
User Badges:

Hello Alberto,


When the issue was present (phone not registered) the WRP400 had its WAN address assigned correctly. And by the way it was the same WAN address that I always get from the cable operator.


So I really dont see how this can be a DHCP issue.


Follow up to my FW upgrade to 2.00.05:


1) The phone registering issue seemed solved. No issues up to this morning. (This counts for 6 days and similar number of reboots)


To my frustration, the phone did not registered today. I went to look for the syslog traces. Nosyslog  traces from the voice part... I went to look to the web interface: The "Voice" page on the web interface was blank.


There is a new link on the web interface on fw version 2.00.05 to reboot. Click on it. Wait. Everything back to normal.


2) I am experiencing a new issue on fw 2.00.05. Sometimes, WRP400 will stop responding. Has happened 3 times in the last 6 days. Access to internet is lost. Access to the web interface is lost. But ping to 192.168.15.1 works fine. (Ping tested on the wireless interface)


This looks like the problem being discussed in the super long thread "WRP400 stops responding after browsing certain websites"


Thanks four your help.


Nestor

nestico_cisco Tue, 09/21/2010 - 01:11
User Badges:

Hello,


Since one week I've upgraded to the 2.00.20 FW version. Up to now everything is working fine. Everytime I power up the WRP400 simultaneously with the cable modem it will register with the SIP provider. The router hasn't stop responding up to now. Looks fine.


I will wait for one month more, and if I dont see any issue I will mark the problem as solved. At least to me.


Nestor.

nestico_cisco Sat, 09/25/2010 - 06:20
User Badges:

Hello again,


I was really hoping to click on problem solved button. But I cant.


Actually the original post's failing registration issue seems solved. The wrp400 seems to always register with my sip provider. Good indicator that the original issue was a problem on version 1.00.06 of the wrp400 fw.


On the other hand, the wrp400 not responding issue has not dissapeared. This problem  appeared after I installed FW version 2.00.05 and is still present in version 2.00.20.


I've seen it two times in one day. The moment seems to be completely random.

In the first crash I had left the router ON connected to the cable modem, which was also ON during all night. There was no LAN or wireless activity during all night. The morning after when I switched on one of my PCs it would not connect to internet. Even though the phone led was lit, there is no dialing tone.


The second crash was even more interesting and can give you some more insight. I was chatting with Symantec Norton  client support and the customer support agent asked me to navigate to a website. All of a sudden i had lost web access. On two more computers (also connected via wireless) windows said: connection has no connectivity.The telephone was not working either.


Quite surprisingly the chat session with the Symantec Support continued to work. I could really not understand this.I had to reboot the router to get full internet connection again


This should be a clear indicator for your engineering team that there is at least one bug in the wrp400 FW version 2.00.20 that needs to be solved.


I am really worried that a mature product like the wrp400 (has more than two years on the field now) keeps having so many issues. I bought mine two months ago and it is still in warranty. I am spending my time in giving you all this constructive feedback in order to see my product working as expected. I really need a solution.


Thanks,

Nestor

Actions

This Discussion