SIP and H323

Unanswered Question
Aug 26th, 2010

We have the attached setup (attached)  that we have local H.323 network, which includes Cisco 3845 (Gateway), Cisco CVP 3.1 (IVR), Cisco Call Manager and IP Phones.

The gateway was having PRI ISDN Ports and was working fine end-to-end. Then we needed to test using SIP instead of the PRI E1s. that as making the gateway (Cisco 3845) as signaling gateway only with SIP-H.323 signaling conversion. That’s it receive and sends the SIP with the Ericsson Switch (MSC) and H.323 signals with the other Internal system. Also the payload to directed directly from the MSCs to the IVR or the IP Phones, without passing the gateway. We faced a problem to hear IVR when start testing. So to simplify troubleshooting, I configure the dial peers in order to direct the call request directly to the call manager and then to phone for testing purposes.

The case is that when we call from outside (call to 912080000) the phone rings and the caller hear the ringing tone, but when we hang up the phone, the caller still hear the ring and the line is not opened at his side. It looks for me that the signal is not travelling well throughout the Gateway.  Attach is output for the SIP & H323 debug, plus an output for “show SIP call”  during the call.

Can you please help me in this, and if there is something wrong with the configurations.

Below is the Gateway configuration:

Building configuration...

Current configuration : 4044 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname IPCC-Test-GW

!

boot-start-marker

boot-end-marker

!

logging message-counter syslog

enable secret 5 $1$baVf$Tze2yBVuBGTThhX47t2fu.

!

no aaa new-model

network-clock-participate wic 0

!

ip source-route

ip cef

!

!

!

!

ip domain name icm.ipcclab

ip host isn-vxml 192.168.40.44

ip host media 192.168.40.44

ip host isn-server 192.168.40.44

ip host mediaserver 192.168.40.44

no ipv6 cef

multilink bundle-name authenticated

!

!

!

isdn switch-type primary-net5

!

voice-card 0

!

!

voice call send-alert

voice call convert-discpi-to-prog tunnel-IEs

voice rtp send-recv

voice disc-pi-incoming-on

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

fax protocol cisco

h323

  emptycapability

  h225 timeout setup 20

  no h225 timeout keepalive

sip

!

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

codec preference 3 g729r8

!

!

!

voice class h323 1

  call start fast

!

!

!

!

!

!

!

!

!

!

!

http client cache memory pool 1000

http client cache memory file 100

http client cache refresh 200000

no http client cookie

http client connection timeout 60

http client response timeout 30

ivr prompt memory 16384

ivr prompt streamed all

!

application

service new-call flash:bootstrap.vxml

  paramspace english language en

  paramspace english index 0

  paramspace english location flash

  paramspace english prefix en

!

service vru-leg flash:bootstrap.tcl

  paramspace english language en

  paramspace english index 0

  paramspace english location flash

  paramspace english prefix en

!

service handoff flash:handoff.tcl

  paramspace english language en

  paramspace english index 0

  paramspace english location flash

  paramspace english prefix en

!

!

vxml tree memory 5000

!

!

archive

log config

  hidekeys

!

!

controller E1 0/0/0

framing NO-CRC4

pri-group timeslots 1-31

!

!

!

!

!

interface GigabitEthernet0/0

ip address 10.0.231.35 255.255.255.0

ip accounting output-packets

ip flow ingress

duplex auto

speed auto

media-type rj45

keepalive 1800

h323-gateway voip interface

h323-gateway voip id ZAINSD ipaddr 10.0.232.32 1719

h323-gateway voip h323-id IPCC-Test-GW

h323-gateway voip tech-prefix 2#

h323-gateway voip bind srcaddr 10.0.231.35

!

interface GigabitEthernet0/1

ip address 10.18.1.135 255.255.255.240

ip accounting output-packets

ip flow ingress

duplex full

speed 1000

media-type rj45

!

interface Serial0/0/0:15

no ip address

encapsulation hdlc

isdn switch-type primary-net5

isdn incoming-voice voice

no cdp enable

!

ip forward-protocol nd

ip route 0.0.0.0 0.0.0.0 10.0.231.1

ip route 10.3.3.0 255.255.255.128 10.18.1.131 name MG2-MG4

ip route 10.18.3.0 255.255.255.128 10.18.1.131 name MSC-S1

!

!

ip http server

!

!

!

!

control-plane

!

!

!

voice-port 0/0/0:15

!

voice-port 0/1/0

!

voice-port 0/1/1

!

voice-port 0/1/2

!

voice-port 0/1/3

!

!

!

!

!

dial-peer voice 999 voip

destination-pattern ..........

session protocol sipv2

session target sip-server

!

dial-peer voice 200 voip

description "VRU LEG"

translation-profile incoming block

service vru-leg

voice-class codec 1

incoming called-number 4619T

dtmf-relay rtp-nte h245-signal h245-alphanumeric

no vad

!

dial-peer voice 300 voip

max-conn 400

destination-pattern 46111

voice-class codec 1

session target ras

tech-prefix 2#

dtmf-relay rtp-nte h245-signal h245-alphanumeric

icpif 25

no vad

!

dial-peer voice 990 voip

voice-class codec 1

incoming called-number 91208....

dtmf-relay rtp-nte h245-signal h245-alphanumeric

!

dial-peer voice 995 voip

destination-pattern 4449

voice-class codec 1

session target ipv4:10.0.232.50

dtmf-relay h245-alphanumeric

!

!

num-exp 912080000 4449

gateway

timer receive-rtp 1200

!

sip-ua

sip-server ipv4:10.18.3.8

!

!

gatekeeper

shutdown

!

!

line con 0

line aux 0

line vty 0 4

password 7 070C285F4D06

login

!

scheduler allocate 20000 1000

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Average Rating: 1 (1 ratings)

Actions

Login or Register to take actions

This Discussion

Posted August 26, 2010 at 12:18 AM
Stats:
Replies:1 Avg. Rating:1
Views:702 Votes:0
Shares:0
Tags: No tags.

Discussions Leaderboard

Rank Username Points
1 5,918
2 2,958
3 2,203
4 1,882
5 1,756