PPP in ADSL CISCO 877

Unanswered Question
Aug 26th, 2010

Hi all,

my 877 Cisco Router is conected to an ADSL line. The CD light is ok but PPP light is off. This is the output of debug ppp negotiation command:

CPE#
*Mar  2 01:08:43.831: Vi2 LCP: Timeout: State Listen
*Mar  2 01:08:43.831: Vi2 PPP: No remote authentication for call-out
*Mar  2 01:08:43.831: Vi2 LCP: O CONFREQ [Listen] id 241 len 10
*Mar  2 01:08:43.831: Vi2 LCP:    MagicNumber 0x25996C7C (0x050625996C7C)
CPE#
*Mar  2 01:08:45.847: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:08:45.847: Vi2 LCP: O CONFREQ [REQsent] id 242 len 10
*Mar  2 01:08:45.847: Vi2 LCP:    MagicNumber 0x25996C7C (0x050625996C7C)
CPE#
*Mar  2 01:08:47.863: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:08:47.863: Vi2 LCP: O CONFREQ [REQsent] id 243 len 10
*Mar  2 01:08:47.863: Vi2 LCP:    MagicNumber 0x25996C7C (0x050625996C7C)

CPE#debug atm events
ATM events debugging is on
CPE251#
*Mar  2 01:10:26.199: atmsar_vc_tx_start(82D7A904).
*Mar  2 01:10:26.199: ATM0:atmsar_dequeue_pak, dequeued a pak = 0x82B36A80
*Mar  2 01:10:26.199: atmsar_transmit_pak_wrapper: deq(82B36A80). vcd: 1.atmsar_transmit_pak_wrapper : encap = Data
CPE#
*Mar  2 01:10:28.215: atmsar_vc_tx_start(82D7A904).
*Mar  2 01:10:28.215: ATM0:atmsar_dequeue_pak, dequeued a pak = 0x82B37950
*Mar  2 01:10:28.215: atmsar_transmit_pak_wrapper: deq(82B37950). vcd: 1.atmsar_transmit_pak_wrapper : encap = Data
CPE#
*Mar  2 01:10:30.231: atmsar_vc_tx_start(82D7A904).
*Mar  2 01:10:30.231: ATM0:atmsar_dequeue_pak, dequeued a pak = 0x830F30A8
*Mar  2 01:10:30.231: atmsar_transmit_pak_wrapper: deq(830F30A8). vcd: 1.atmsar_transmit_pak_wrapper : encap = Data
CPE251#
*Mar  2 01:10:32.247: atmsar_vc_tx_start(82D7A904).

CPE#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES unset  up                    down
FastEthernet1              unassigned      YES unset  up                    down
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
ATM0                       unassigned      YES NVRAM  up                    up
ATM0.1                     unassigned      YES unset  up                    up
Vlan1                      192.168.250.1   YES NVRAM  up                    down
NVI0                       unassigned      YES unset  administratively down down
Dialer1                    unassigned      YES NVRAM  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    down

Thanks for your help!!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Thu, 08/26/2010 - 03:44

You have likely configured the wrong VCI/VPI numbers.

The alternative, is that the configuration by ISP side, is wrong or incomplete.

Paolo Bevilacqua Thu, 08/26/2010 - 04:09

Since you do not receive packets from ISP, mean something is broken their side.

Note:

no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache cef
no ip route-cache
no ip mroute-cache
dsl enable-training-log
hold-queue 224 in

You do not need any of the above commands.

ip mtu 1492   <----  Should be "mtu 1492". Do debug ppp neg to understand why.
ip tcp adjust-mss 1452  <---- this goes under vlan interface, not Dialer

emilio1973 Thu, 08/26/2010 - 04:32

I don´t understand which is the difference when i configure ip mtu 1492 or mtu 1492.

CPE#debug ppp negotiation
PPP protocol negotiation debugging is on
CPE#
*Mar  2 01:51:22.823: Vi2 LCP: Timeout: State Listen
*Mar  2 01:51:22.823: Vi2 PPP: No remote authentication for call-out
*Mar  2 01:51:22.823: Vi2 LCP: O CONFREQ [Listen] id 239 len 10
*Mar  2 01:51:22.823: Vi2 LCP:    MagicNumber 0x25C078BF (0x050625C078BF)
CPE#
*Mar  2 01:51:24.823: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:51:24.823: Vi2 LCP: O CONFREQ [REQsent] id 240 len 10
*Mar  2 01:51:24.823: Vi2 LCP:    MagicNumber 0x25C078BF (0x050625C078BF)
CPE#
*Mar  2 01:51:26.839: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:51:26.839: Vi2 LCP: O CONFREQ [REQsent] id 241 len 10
*Mar  2 01:51:26.839: Vi2 LCP:    MagicNumber 0x25C078BF (0x050625C078BF)
CPE#
*Mar  2 01:51:28.855: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:51:28.855: Vi2 LCP: O CONFREQ [REQsent] id 242 len 10
*Mar  2 01:51:28.855: Vi2 LCP:    MagicNumber 0x25C078BF (0x050625C078BF)
CPE#und
*Mar  2 01:51:30.871: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:51:30.871: Vi2 LCP: O CONFREQ [REQsent] id 243 len 10
*Mar  2 01:51:30.871: Vi2 LCP:    MagicNumber 0x25C078BF (0x050625C078BF)
CPE#undebu
*Mar  2 01:51:32.887: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:51:32.887: Vi2 LCP: O CONFREQ [REQsent] id 244 len 10
*Mar  2 01:51:32.887: Vi2 LCP:    MagicNumber 0x25C078BF (0x050625C078BF)
CPE#undebug all
All possible debugging has been turned off

CPE251#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
CPE(config)#int di
CPE(config)#int dialer 1
CPE(config-if)#no  ip mtu 1492
CPE(config-if)#ip mtu 1492
CPE(config-if)#end
CPE#d
*Mar  2 01:52:52.607: %SYS-5-CONFIG_I: Configured from console by ibx777 on console
CPE251#debug ppp negotiation
PPP protocol negotiation debugging is on
CPE#
*Mar  2 01:53:03.159: Vi2 LCP: Timeout: State Listen
*Mar  2 01:53:03.159: Vi2 PPP: No remote authentication for call-out
*Mar  2 01:53:03.159: Vi2 LCP: O CONFREQ [Listen] id 3 len 10
*Mar  2 01:53:03.159: Vi2 LCP:    MagicNumber 0x25C200B1 (0x050625C200B1)
CPE#
*Mar  2 01:53:05.175: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:53:05.175: Vi2 LCP: O CONFREQ [REQsent] id 4 len 10
*Mar  2 01:53:05.175: Vi2 LCP:    MagicNumber 0x25C200B1 (0x050625C200B1)
CPE#
*Mar  2 01:53:07.191: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:53:07.191: Vi2 LCP: O CONFREQ [REQsent] id 5 len 10
*Mar  2 01:53:07.191: Vi2 LCP:    MagicNumber 0x25C200B1 (0x050625C200B1)
CPE#
*Mar  2 01:53:09.207: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:53:09.207: Vi2 LCP: O CONFREQ [REQsent] id 6 len 10
*Mar  2 01:53:09.207: Vi2 LCP:    MagicNumber 0x25C200B1 (0x050625C200B1)
CPE#
*Mar  2 01:53:11.223: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:53:11.223: Vi2 LCP: O CONFREQ [REQsent] id 7 len 10
*Mar  2 01:53:11.223: Vi2 LCP:    MagicNumber 0x25C200B1 (0x050625C200B1)
CPE#
*Mar  2 01:53:13.239: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:53:13.239: Vi2 LCP: O CONFREQ [REQsent] id 8 len 10
*Mar  2 01:53:13.239: Vi2 LCP:    MagicNumber 0x25C200B1 (0x050625C200B1)
CPE#und
*Mar  2 01:53:15.255: Vi2 LCP: Timeout: State REQsent
*Mar  2 01:53:15.255: Vi2 LCP: O CONFREQ [REQsent] id 9 len 10
*Mar  2 01:53:15.255: Vi2 LCP:    MagicNumber 0x25C200B1 (0x050625C200B1)
CPE#undebug all

emilio1973 Thu, 08/26/2010 - 03:53

Hi Paolo,

I have checked and is the same as other lines of the same ISP to work correctly. (8 / 35).

Add my config. Thanks for your time.

interface ATM0
description DSL line Phone #913758086
no ip address
no ip redirects
no ip unreachables
no ip proxy-arp
no ip route-cache cef
no ip route-cache
no ip mroute-cache
no atm ilmi-keepalive
dsl operating-mode auto
dsl enable-training-log
hold-queue 224 in
!
interface ATM0.1 point-to-point
no ip route-cache
pvc 8/35
  encapsulation aal5mux ppp dialer
  dialer pool-member 1

interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname [email protected]@xdsl
ppp chap password 7 03074B0E465D741D
ppp pap sent-username [email protected]@xdsl password 7 06051F241E1B58

mfurnival Thu, 08/26/2010 - 08:32

Try "debug ppp authentication" - it might be that your PPP negotiation is failing because of an authentication error.

Paolo Bevilacqua Thu, 08/26/2010 - 08:36

mfurnival wrote:

Try "debug ppp authentication" - it might be that your PPP negotiation is failing because of an authentication error.

Incorrect, authentication happens after negotiation, that fails because no PPP packets are ever received.

emilio1973 Fri, 08/27/2010 - 04:29

I think the problem is the bundle-enable command. I can´t set it but in the config of the other line that actually working right appears it:

c870-advipservicesk9-mz.124-6.T9.bin"

interface ATM0

description DSL line Phone #914572301

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

no ip route-cache cef

no ip route-cache

no ip mroute-cache

no atm ilmi-keepalive

bundle-enable

dsl operating-mode auto

dsl enable-training-log

hold-queue 224 in

In this IOS (c870-advsecurityk9-mz.124-15.T7.bin), i can´t set it. Someone knows why?  Thanks

Paolo Bevilacqua Fri, 08/27/2010 - 12:44

No, that is not the problem.

Want to prove it? Try onbe of these adsl modems that the ISP give for free, you should not be able to connect anyway.

emilio1973 Sat, 08/28/2010 - 02:17

I tested with a free router and a technician from my ISP and sync properly. I placed the router that was used in the old headquarters still does not turn the light PPP

CPE3#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
FastEthernet0              unassigned      YES unset  up                    up
FastEthernet1              unassigned      YES unset  up                    down
FastEthernet2              unassigned      YES unset  up                    down
FastEthernet3              unassigned      YES unset  up                    down
ATM0                       unassigned      YES NVRAM  up                    up
ATM0.1                     unassigned      YES unset  up                    up
Vlan1                      192.168.100.1   YES NVRAM  up                    up
NVI0                       unassigned      NO  unset  up                    up
Dialer1                    unassigned      YES NVRAM  up                    up
Virtual-Access1            unassigned      YES unset  up                    up
Virtual-Access2            unassigned      YES unset  up                    down

What mean NO state in NVI0 interface?

Thanks

Paolo Bevilacqua Sat, 08/28/2010 - 13:12

emilio1973 wrote:

I tested with a free router and a technician from my ISP and sync properly.


The cisco syncs also. The question is if the free router passes traffic and you can use the internet with it.

emilio1973 wrote:

I placed the router that was used in the old headquarters still does not turn the light PPP

Because the problem is with ISP, not router.

emilio1973 Thu, 09/02/2010 - 05:33

Hi again,

add the output of debug atm  errors:

CPE3#debug atm errors
ATM errors debugging is on
CPE3#
*Mar 11 05:33:45.631: ATM0 DSL: Defect: LOM
*Mar 11 05:33:45.631: DSL: Defect: LOF: retraining
CPE3#
*Mar 11 05:33:49.415: DBS is not configured on ATM0.1 vc 8/35

What is DBS?

The output of debug atm events:

CPE3#deb
*Mar 11 05:48:46.567: %SYS-5-CONFIG_I: Configured from console by ibx777 on console
CPE3#debug atm events
ATM events debugging is on
CPE3#
*Mar 11 05:48:52.195: ATM0: vcd = 1, safe_start called from periodic
*Mar 11 05:48:53.191: ATM0: vcd = 1, safe_start called from periodic
CPE3#
*Mar 11 05:48:53.663: atmsar_vc_tx_start(82E550BC).
*Mar 11 05:48:53.663: ATM0:atmsar_dequeue_pak, dequeued a pak = 0x82B248FC
*Mar 11 05:48:53.663: atmsar_transmit_pak_wrapper: deq(82B248FC). vcd: 1.atmsar_transmit_pak_wrapper : encap = Data
*Mar 11 05:48:54.191: ATM0: vcd = 1, safe_start called from periodic
CPE3#
*Mar 11 05:48:55.191: ATM0: vcd = 1, safe_start called from periodic
*Mar 11 05:48:56.191: ATM0: vcd = 1, safe_start called from periodic
CPE3#
*Mar 11 05:48:57.091: ATM0: atmsar_atm_get_stats,vcinfo = 0x0
*Mar 11 05:48:57.191: ATM0: vcd = 1, safe_start called from periodic
CPE3#
*Mar 11 05:48:58.191: ATM0: vcd = 1, safe_start called from periodic
*Mar 11 05:48:59.191: ATM0: vcd = 1, safe_start called from periodic

emilio1973 Sat, 08/28/2010 - 02:54

I detected flaps in ATM0 interface when reload the router:

*Mar 11 05:29:28.975: %LINK-3-UPDOWN: Interface ATM0, changed state to down
*Mar 11 05:29:29.975: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to down

emilio1973 Wed, 09/15/2010 - 03:24

In the end we got it to work.

We  spent the whole configuration of the subinterface to the physical  interface, the default encapsulation and the line "pppoe-client  dial-pool-number 1" and work right.

Thanks for your help

Actions

This Discussion