Upgradeing Cisco Unity 4.05 to Connection 7.x

Unanswered Question
Aug 26th, 2010

Hi All,

I've a little problem... i try to upgrade unity 4.05 to 7.x.. the reconfiguration and Upgrade Guide for Cisco Unity Connection Release 7.x says, that i have to install cobras for migrating most of the data including callhandlers... im a little bit confused, because it's not possible to install corbas on my unity - i allways get the error "Data Access Objects (DAO) 3.6 or later is required and not found on the local machine.  Exiting setup".

I found out, that the dao360.dll is in the correct directory (C:\Program Files\Common Files\Microsoft Shared\DAO).

Any Ideas why this happens?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
David Hailey Thu, 08/26/2010 - 10:46

A couple things:

COBRAS Export for Unity - this needs to be installed on your Unity server.

COBRAS Import for Unity Connection & Informix ODBC Drivers - these can be installed on any supported machine from which you wish to establish a remote connection to import data into Unity Connection.  A pre-requisite is that .NET 2.0 also be installed on this machine as well.  Depending on the OS on your Unity system, you may or may not install these components there.

So, questions:

Which COBRAS tool do you have issues installing?

What OS is on your Unity box (my assumption is Windows 2000)?

Have you read the COBRAS Help File thoroughly? http://www.ciscounitytools.com/Applications/General/COBRAS/Help/COBRAS.htm


Please rate helpful posts!

daniel.ehemann Thu, 08/26/2010 - 10:55


i tried to install the Cobras Export for Unity Version 7.0.98 on the Unity 4.05 Server. The Os of the Server is windows 2000 SP4.

I've not tried to install Corbas Import, because I think first of all i should install the export util.

greetings daniel

lindborg Thu, 08/26/2010 - 11:20

THe DAO check done by qSetup is pretty straight forward - if the OS is not reporting it installed, something is missing either in the files or registry.  Windows 2000 SP4 should include MDAC 2.6 which has the necessary files although it's not unheard of for the MDAC to get damaged over time.  Search for MDAC Download in Google and it'll take you to the MDAC download page from Microsoft - 2.8 will be the latest - should be safe to install and at that point the DAO check should pass.

if not, something else deeper is at play with your system...

lindborg Fri, 08/27/2010 - 09:10

hmmm... not sure what to make of that.  I know the setup is fine (just tried it on several 4.x installs and it's been used hundreds of times in the field) - I could cut a version of the install that removes that check or just throws a warning but lets you continue instead of forcing an exit - however I'm reasonably certain that will just kick the can down the road and it'll fail when you run the application then.

Are you installing/running via VPN perhaps?  You installed MDAC as the same account you're installing COBRAS with?  Nothing unusual there that might be tripping the checks up?

lindborg Wed, 09/01/2010 - 11:14

Just to follow up here - I built an updated setup (build 100) that changes the DAO check to just a warning and lets you continue with the install anyway.  We haven't been able to repro this on any systems but on the off chance that the install framework's DAO check is overly strict somehow, you can try this setup and see if they can get a good export - if they get a bunch of DB errors on export then we'll know the setup's DAO check wasn't lying and something is mangled on that system we'll have to get to the bottom of.

you can get the updated setup on the temporary download page here:



This Discussion