One way Audio on Cisco1841

Unanswered Question
Aug 28th, 2010


I am  using Cisco 1841 and running VoIP based telephone system ( Not Cisco). I  have a one way audio problem. If I call out within the network to outside world, I can hear them but they can't hear me. Seems like RTP is having some probelms.

If I replace Cisco 1841 with Netgear router then it works fine without any problem, I think I have mis configured Cisco 1841( NAT or firewall rule) which casuing the  RTP porblems.

I have attached the config if  you can spot any problem then please advise. I may  have not right ACL entries or firewall rules to allow outbound communication.

Many thanks.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)


You might want to check the bug-id in my problem:

Ik have the same problem. The 1841 is not translating all the "c=" headers within the SIP Invite message. This is causing the other party to respond to your actual (inside) addres and not to your natted addres. In other words, the RTP stream is going the wrong (non routable) way!

A single C= header from your voice device works fine (tested this myself with a sipura box). If you have multiple c= headers in your SIP Invite message, only parts of the header get rewritten by the 1841. Let hope Cisco fixes this annoying bug fast!



s.nasheet Sun, 08/29/2010 - 08:14


Thanks for the input. I have checked the Cisco bug tool and this case is still open and not solved  yet, so no solution or work around been given. Did you managed to  fix  your problem?

Any idea which IOS version doesn't have this bug then I will load that IOS on my 1841 to see if this fixes the issue.



Tracy Larson Sun, 08/29/2010 - 08:34

Have you tried adding "ip inspect myfw out" on dialer 0. Might need both in and out. Might then make debugging easier as well if something is blocked.

s.nasheet Sun, 08/29/2010 - 08:45

Let me try that on Monday to see if  it  makes any difference.
s.nasheet Sun, 08/29/2010 - 08:48


Let me try that on  Monday to see if it makes any difference.



Steven Holl Mon, 08/30/2010 - 07:13

For anyone hitting this bug:

Because this has never worked in the Cisco NAT code, it is  considered a 'feature enhancement request' by our development team.   They need a strong business case to get this bug fix on the roadmap so  that it can be fixed.

I STRONGLY encourage you to  contact your Cisco account team and have them file a PERS request to get  this bug on the roadmap with development so that it can be fixed.  That  is the proper avenue to getting sev6 bugs pushed through and worked on  by development for a future release.  The more customers that get PERS  filed for this, the quicker it will get addressed.



This Discussion